Have attached Cisco CME config based on CME version 7.0.0.1 below. The Cisco is running off a GNS3 lab on my laptop. Also put some screenshots that will show the line config (h323 line) on the avaya side. Calls are working perfectly. The Avaya is running on IPO version 5(26), so might differ slightly from the current v9. the extension on the cisco is 9001, and 31xx on the Avaya. The CME is on 192.168.1.100 and the Avaya IPO 500 on 192.168.1.1. The Cisco IP Phone is on the 10.10.xx LAN.
Cisco CME Config
For Cisco CME version 7.0.0.1 seesion log
Building configuration...
Current configuration : 2508 bytes
!
! Last configuration change at 12:23:00 lusaka Thu Aug 21 2014
! NVRAM config last updated at 12:23:02 lusaka Thu Aug 21 2014
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CEZM-CME
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
clock timezone lusaka 2
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
h323
sip
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g729br8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username cisco privilege 15 secret 5 $1$e6M1$A65lksLSvlHTB7Y9AVG8Z0
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.100 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip id CO ipaddr 192.168.1.1 1719
h323-gateway voip h323-id CO
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 192.168.1.100
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 192.168.100.231
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 1 voip
destination-pattern 31..
session target ipv4:192.168.71.1
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!
gateway
timer receive-rtp 1200
!
!
!
telephony-service
max-ephones 100
max-dn 200
ip source-address 10.10.10.1 port 2000
time-zone 29
max-conferences 8 gain -6
web admin system name cisco secret 5 $1$GARC$JqzHAhMzMwHEzjsechfiM1
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1 dual-line
number 9001
label Kavambu
name Kavambu
!
!
ephone 1
device-security-mode none
mac-address A4BA.DB9F.AC2D
type CIPC
button 1:1
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
CEZM-CME#
AVAYA IPO CONFIG
Am unable to paste the screen shots for the Avaya IPO 500 config but basically on the IP Line (h323), select automatic codec and no supplementary service. Also de-select direct media path, just enable fast start and OOB DTMF.
Then create a short code for the Cisco Extensions (similar to dial-peer) and point to the line id of the IP Line above. Merge or Immediate restart to save config and it should work.
COMPONENTS USED
I used an image of a 3725 cisco router under dynamips/gns3 emulation with a Cisco IP Communicator. You have to create loopbacks and probably connect to one of your NICs. My setup is that we use Avaya IPO in the office hence already had Avaya Extensions etc. v
Hope this helps, I went through a couple of loops to get to this.
Cisco CME Config
For Cisco CME version 7.0.0.1 seesion log
Building configuration...
Current configuration : 2508 bytes
!
! Last configuration change at 12:23:00 lusaka Thu Aug 21 2014
! NVRAM config last updated at 12:23:02 lusaka Thu Aug 21 2014
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CEZM-CME
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
clock timezone lusaka 2
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
h323
sip
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g729br8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username cisco privilege 15 secret 5 $1$e6M1$A65lksLSvlHTB7Y9AVG8Z0
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.100 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip id CO ipaddr 192.168.1.1 1719
h323-gateway voip h323-id CO
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 192.168.1.100
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 192.168.100.231
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 1 voip
destination-pattern 31..
session target ipv4:192.168.71.1
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!
gateway
timer receive-rtp 1200
!
!
!
telephony-service
max-ephones 100
max-dn 200
ip source-address 10.10.10.1 port 2000
time-zone 29
max-conferences 8 gain -6
web admin system name cisco secret 5 $1$GARC$JqzHAhMzMwHEzjsechfiM1
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1 dual-line
number 9001
label Kavambu
name Kavambu
!
!
ephone 1
device-security-mode none
mac-address A4BA.DB9F.AC2D
type CIPC
button 1:1
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
CEZM-CME#
AVAYA IPO CONFIG
Am unable to paste the screen shots for the Avaya IPO 500 config but basically on the IP Line (h323), select automatic codec and no supplementary service. Also de-select direct media path, just enable fast start and OOB DTMF.
Then create a short code for the Cisco Extensions (similar to dial-peer) and point to the line id of the IP Line above. Merge or Immediate restart to save config and it should work.
COMPONENTS USED
I used an image of a 3725 cisco router under dynamips/gns3 emulation with a Cisco IP Communicator. You have to create loopbacks and probably connect to one of your NICs. My setup is that we use Avaya IPO in the office hence already had Avaya Extensions etc. v
Hope this helps, I went through a couple of loops to get to this.