cisconewbee
Programmer
Hi,
I have a web server and a sendmail/pop3s based email server behind a PIX 501 with one external IP. I have a problem with the email server. When a user tries to download theiremail using Outlook, the pop3s server cannot be reached.They can send outbound email just fine. I have the Outlook client configured to contact the POP server on Port 995. Tests inside the network are successful. (I can download and send email on any machine on the 192.168.1.x network)
Outlook error:
Task 'mail.mydomain.com - Receiving' reported error (0x800CCC0F) : 'The connection to the server was interrupted. If this problem continues, contact your server administrator or Internet service provider (ISP).'
Ping and tracert are both successful from the PC, so DNS is OK.
Pix Config:
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxx encrypted
hostname pixxxxxxxxxx
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit tcp any host x.x.6.39 eq smtp
access-list 101 permit tcp any host x.x.6.39 eq http
access-list 101 permit tcp any host x.x.6.39 eq www
access-list 101 permit tcp any host x.x.6.39 eq https
access-list 101 permit tcp any host x.x.6.39 eq pop3
access-list 101 permit tcp any host x.x.6.39 eq ftp
access-list 101 permit tcp any any eq 443
access-list 101 permit tcp any host x.x.6.39 eq 995
pager lines 24
logging on
logging timestamp
logging standby
logging trap notifications
logging facility 19
logging host inside 192.168.1.11
mtu outside 1500
mtu inside 1500
ip address outside x.x.6.39 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp x.x.6.39 smtp 192.168.1.11 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 pop3 192.168.1.11 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 995 192.168.1.11 995 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 http 192.168.1.54 http netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 https 192.168.1.54 https netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 ftp 192.168.1.54 ftp netmask 255.255.255.255 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.6.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.100-192.168.1.249 inside
dhcpd dns x.x.x.200 x.x.x.202
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
I have a web server and a sendmail/pop3s based email server behind a PIX 501 with one external IP. I have a problem with the email server. When a user tries to download theiremail using Outlook, the pop3s server cannot be reached.They can send outbound email just fine. I have the Outlook client configured to contact the POP server on Port 995. Tests inside the network are successful. (I can download and send email on any machine on the 192.168.1.x network)
Outlook error:
Task 'mail.mydomain.com - Receiving' reported error (0x800CCC0F) : 'The connection to the server was interrupted. If this problem continues, contact your server administrator or Internet service provider (ISP).'
Ping and tracert are both successful from the PC, so DNS is OK.
Pix Config:
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxx encrypted
hostname pixxxxxxxxxx
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit tcp any host x.x.6.39 eq smtp
access-list 101 permit tcp any host x.x.6.39 eq http
access-list 101 permit tcp any host x.x.6.39 eq www
access-list 101 permit tcp any host x.x.6.39 eq https
access-list 101 permit tcp any host x.x.6.39 eq pop3
access-list 101 permit tcp any host x.x.6.39 eq ftp
access-list 101 permit tcp any any eq 443
access-list 101 permit tcp any host x.x.6.39 eq 995
pager lines 24
logging on
logging timestamp
logging standby
logging trap notifications
logging facility 19
logging host inside 192.168.1.11
mtu outside 1500
mtu inside 1500
ip address outside x.x.6.39 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp x.x.6.39 smtp 192.168.1.11 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 pop3 192.168.1.11 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 995 192.168.1.11 995 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 http 192.168.1.54 http netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 https 192.168.1.54 https netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 255.255.255.255 0 0
static (inside,outside) tcp x.x.6.39 ftp 192.168.1.54 ftp netmask 255.255.255.255 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.6.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.100-192.168.1.249 inside
dhcpd dns x.x.x.200 x.x.x.202
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80