I just inherited a Catalyst 2900 (24 port) switch (model WS-C2924) and I have never before used any Cisco gear (only HP and 3COM).
The problem is that I can't get this switch to communicate to any Ethernet devices.
I would greatly appreciate it if you could point in a direction that will help me figure out what I need to do to make this talk. I do want to learn this which is why I’ve been reading for days, but I haven’t been able to find all that I need or I must not understand something.
Here's what I've done.
I managed to get my HyperTerminal working on the console.
There was a password on it that I didn't have so I ended up formatting flash: (because I didn't have enough space to upload a new .bin file and I couldn't get wildcards to work with the delete command). Once I figure out how to make this work then I’ll re-copy the .tar over and fix the flash:html that I deleted.
After formatting flash I used xmodem to send c2900XL-hs-mz-112.8.11-SA6.bin to the switch. I then set the switch to boot to the .bin file. (Now THAT was SLOW)
I tried answering yes to the setup question and entering the data but that didn't help AND it installed a password; which I'd rather not have; so I wiped flash, copied the .bin file over, booted, and this time I entered "NO" to the ?setup? question and configured everything through “config terminal”.
I setup vlan 1 with all 24 ports under it (default). Eventually I want 3 vlans on this (8 ports each) but I’m keeping it simple so far.
I assigned an IP to vlan1
I copied the running config to the startup-config and then reloaded
I tried pinging to/from the switch without success.
And from there I general mucked with every single setting that I could find in hopes that I would eventually make something work; which I have not. After 2 full days of "mucking around", I've exhausted every piece of documentation that I could find and thus come to you.
I have been attempting to ping the switch by connecting my nic directly to port 24 and/or 1. My client has a static IP of 192.168.1.47/24. Ping both ways fails.
My goal is to make this switch function on my 192.168.1/24 subnet with the IP of 192.168.1.9 and use 192.168.1.1 for a gateway (the firewall port IP). I'll need to connect port 24 to my firewall's dmz port so that this switch can be used as our "dmz" switch.
So I'm not asking for step by step instructions (unless you feel like giving them). I've been reading manuals for 2 days and feel as though I have read everything that exists and yet it seems like I'm missing something simple. I've never had to do anything more than setup an ip address and gateway on my other switches so I don't know where to look next.
Here’s my config:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch
!
!
!
!
!
interface VLAN1
ip address 192.168.1.9 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
ip default-gateway 192.168.1.1
!
line con 0
stopbits 1
line vty 0 4
login
line vty 5 9
login
!
end
Any thoughts?
The problem is that I can't get this switch to communicate to any Ethernet devices.
I would greatly appreciate it if you could point in a direction that will help me figure out what I need to do to make this talk. I do want to learn this which is why I’ve been reading for days, but I haven’t been able to find all that I need or I must not understand something.
Here's what I've done.
I managed to get my HyperTerminal working on the console.
There was a password on it that I didn't have so I ended up formatting flash: (because I didn't have enough space to upload a new .bin file and I couldn't get wildcards to work with the delete command). Once I figure out how to make this work then I’ll re-copy the .tar over and fix the flash:html that I deleted.
After formatting flash I used xmodem to send c2900XL-hs-mz-112.8.11-SA6.bin to the switch. I then set the switch to boot to the .bin file. (Now THAT was SLOW)
I tried answering yes to the setup question and entering the data but that didn't help AND it installed a password; which I'd rather not have; so I wiped flash, copied the .bin file over, booted, and this time I entered "NO" to the ?setup? question and configured everything through “config terminal”.
I setup vlan 1 with all 24 ports under it (default). Eventually I want 3 vlans on this (8 ports each) but I’m keeping it simple so far.
I assigned an IP to vlan1
I copied the running config to the startup-config and then reloaded
I tried pinging to/from the switch without success.
And from there I general mucked with every single setting that I could find in hopes that I would eventually make something work; which I have not. After 2 full days of "mucking around", I've exhausted every piece of documentation that I could find and thus come to you.
I have been attempting to ping the switch by connecting my nic directly to port 24 and/or 1. My client has a static IP of 192.168.1.47/24. Ping both ways fails.
My goal is to make this switch function on my 192.168.1/24 subnet with the IP of 192.168.1.9 and use 192.168.1.1 for a gateway (the firewall port IP). I'll need to connect port 24 to my firewall's dmz port so that this switch can be used as our "dmz" switch.
So I'm not asking for step by step instructions (unless you feel like giving them). I've been reading manuals for 2 days and feel as though I have read everything that exists and yet it seems like I'm missing something simple. I've never had to do anything more than setup an ip address and gateway on my other switches so I don't know where to look next.
Here’s my config:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch
!
!
!
!
!
interface VLAN1
ip address 192.168.1.9 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
ip default-gateway 192.168.1.1
!
line con 0
stopbits 1
line vty 0 4
login
line vty 5 9
login
!
end
Any thoughts?