hawkinstlh
IS-IT--Management
- May 22, 2009
- 12
We've got a site that has a T1 to our MPLS network and their web traffic travels across the MPLS to the datacenter and then out to the Internet. Rather than pay for more bandwidth on their circuit, they have purchased cable Internet through their local provider. I have configured FastEthernet 0/1 with the static ip from the cable provider and I am able to route all traffic over the cable using the following configuration:
interface FastEthernet0/1
description Cable Internet
ip address xxx.xxx.xxx.xxx 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
access-list 101 permit ip any any
!
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx (next-hop router from cable)
!
ip nat inside source list 101 interface fastEthernet 0/1 overload
!
With that config in place, all traffic (other than bgp defined) is routed out the cable modem. This is great, except I want my smtp traffic from the Exchange server to still traverse the MPLS for Internet because I can't send email out the blacklisted cable modem ip address.
My question: Is there a way to either route only across the cable and route all other over MPLS or is there a way to segregate a single host (Exchange server) for routing over MPLS and send all others over cable modem?
I have tried using route-maps and access lists but my router still sends all traffic over the cable modem.
I hope I have explained this fully. Please let me know if you need any more config.
Thanks.
Travis
interface FastEthernet0/1
description Cable Internet
ip address xxx.xxx.xxx.xxx 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
access-list 101 permit ip any any
!
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx (next-hop router from cable)
!
ip nat inside source list 101 interface fastEthernet 0/1 overload
!
With that config in place, all traffic (other than bgp defined) is routed out the cable modem. This is great, except I want my smtp traffic from the Exchange server to still traverse the MPLS for Internet because I can't send email out the blacklisted cable modem ip address.
My question: Is there a way to either route only across the cable and route all other over MPLS or is there a way to segregate a single host (Exchange server) for routing over MPLS and send all others over cable modem?
I have tried using route-maps and access lists but my router still sends all traffic over the cable modem.
I hope I have explained this fully. Please let me know if you need any more config.
Thanks.
Travis