Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Mike Lewis on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

VPN client cannot connect to inside network

Status
Not open for further replies.

splicerguy

IS-IT--Management
Jul 6, 2005
18
0
0
CA
Hi,

My clients are able to connect to my PIX using the Cisco VPN client, however they cannot connect to any internal computer.

I've tried a bunch of different changes to my config (based on other people's similar problem), but I've probably just muddle it up more.

Here's my config. I'm a bit of a newbie, but assume it has to do with NAT?



PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix515
domain-name mynetwork
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list nonat permit ip host 192.168.0.50 host 192.168.0.70
access-list SPLIT permit ip host 192.168.0.50 host 192.168.0.70
pager lines 24
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside **.119.167.69 255.255.255.240
ip address inside 172.16.1.253 255.255.254.0
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnip 192.168.0.50-192.168.0.70

pdm location 172.16.0.10 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 **.119.167.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth (inside) host 172.16.0.10 mypass
timeout 5

http server enable
http 172.16.0.0 255.255.254.0 inside

no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside

isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400

vpngroup myvpn address-pool vpnip
vpngroup myvpn dns-server 172.16.0.10
vpngroup myvpn wins-server 172.16.0.10
vpngroup myvpn default-domain corpnet
vpngroup myvpn split-tunnel SPLIT
vpngroup myvpn idle-time 1800
vpngroup myvpn password ********

telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
 
try adding this:
Code:
isakmp nat-traversal

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
In addition to the code posted by unclerico you might want to create proper subnets for your vpn pool, makes ip management easy. See if the code below works.

Code:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix515
domain-name mynetwork
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
[b]fixup protocol pptp 47[/b]
names
access-list nonat permit ip host 192.168.0.33 host 192.168.0.62
access-list SPLIT permit ip host 192.168.0.33 host 192.168.0.62
pager lines 24
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside **.119.167.69 255.255.255.240
ip address inside 172.16.1.253 255.255.254.0
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnip 192.168.0.33-192.168.0.62
[b]pdm location 192.168.0.32 255.255.255.224 outside[/b]
pdm location 172.16.0.10 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 10 interface
[b]nat (inside) 100 0.0.0.0 0.0.0.0 0 0[/b]
route outside 0.0.0.0 0.0.0.0 **.119.167.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth (inside) host 172.16.0.10 mypass
timeout 5
http server enable
http 172.16.0.0 255.255.254.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share       
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
[b]isakmp nat-traversal 20[/b]
vpngroup myvpn address-pool vpnip
vpngroup myvpn dns-server 172.16.0.10
vpngroup myvpn wins-server 172.16.0.10
vpngroup myvpn default-domain corpnet
vpngroup myvpn split-tunnel SPLIT
vpngroup myvpn idle-time 1800
vpngroup myvpn password ********
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80


HTH
-Viconsul
 
I've made those changes yet I still cannot connect to computers on my inside network (172.16.x.x)

When I do an IPCONFIG on my client pc, this is what it shows:

Description: Cisco Systems VPN Adapter
IP Address: 192.168.0.33
Subnet Mark: 255.255.255.0
Default Gateway:
DNS Server: 172.16.0.10
WINS Server: 172.16.0.10

This is what my PIX config looks like now:

PIX Version 6.3(3)

interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown

nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4

enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix515
domain-name beediegroup.ca

fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 47
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69

names
access-list nonat permit ip host 192.168.0.33 host 192.168.0.62
access-list SPLIT permit ip host 192.168.0.33 host 192.168.0.62

pager lines 24
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside **.119.167.69 255.255.255.240
ip address inside 172.16.1.253 255.255.254.0
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.0.33-192.168.0.62
pdm location 172.16.0.10 255.255.255.255 inside
pdm location 192.168.0.32 255.255.255.224 outside
pdm history enable
arp timeout 14400
global (outside) 10 interface

nat (inside) 100 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 **.119.167.65 1

timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth (inside) host 172.16.0.10 *******

timeout 5
http server enable
http 172.16.0.0 255.255.254.0 inside

no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable

sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside

isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400

vpngroup myvpn address-pool vpnpool
vpngroup myvpn dns-server 172.16.0.10
vpngroup myvpn wins-server 172.16.0.10
vpngroup myvpn default-domain corpnet
vpngroup myvpn split-tunnel SPLIT
vpngroup myvpn idle-time 1800
vpngroup myvpn password ********

telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
 
Bizounett,

Try this
Code:
access-list inside-out permit tcp host x.x.x.x any eq smtp
Where inside-out is your outbound traffic acl and x.x.x.x is your internal smtp server ip.

HTH

-Viconsul
 
Wrong thread, please ignore preceeding post.

-Viconsul
 
Hello Splicerguy,

Try this -

Code:
route inside 172.16.0.0 255.255.254.0 172.16.1.253

-Viconsul
 
Try adding this in:
Code:
no access-list nonat line 1 permit ip host 192.168.0.33 host 192.168.0.62
access-list nonat permit ip 172.16.0.0 255.255.254.0 192.168.0.32 255.255.255.224

nat (inside) 0 access-list nonat

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Is the PIX your main gateway on your internal network or do you have something else in the mix like a separate layer 3 switch?? When you get connected to the VPN can you issue a route print and list the results??

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
The PIX is my main gateway on the internal network. Nothing else in the way.

Route Print results from vpn client machine:

Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 10.179.147.96 10.179.147.96 1
10.179.147.96 255.255.255.255 127.0.0.1 127.0.0.1 50
10.255.255.255 255.255.255.255 10.179.147.96 10.179.147.96 50
66.119.167.69 255.255.255.255 10.179.147.96 10.179.147.96 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.33 192.168.0.33 30
192.168.0.33 255.255.255.255 127.0.0.1 127.0.0.1 30
192.168.0.33 255.255.255.255 192.168.0.33 192.168.0.33 1
192.168.0.255 255.255.255.255 192.168.0.33 192.168.0.33 30
224.0.0.0 240.0.0.0 192.168.0.33 192.168.0.33 30
224.0.0.0 240.0.0.0 10.179.147.96 10.179.147.96 1
255.255.255.255 255.255.255.255 10.179.147.96 2 1
255.255.255.255 255.255.255.255 10.179.147.96 3 1
255.255.255.255 255.255.255.255 10.179.147.96 10.179.147.96 1
255.255.255.255 255.255.255.255 192.168.0.33 192.168.0.33 1
Default Gateway: 10.179.147.96


 
Try adding this to your windows client:
Code:
route add 172.16.0.0 mask 255.255.254.0 192.168.0.33

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Thanks, that worked. I've fix the config so now the correct route is always added.

Thanks again
 
Good to hear.

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top