Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

VPN and Voice over Frame Relay 4

Status
Not open for further replies.

burtsbees

Programmer
Jan 29, 2007
7,657
0
0
US
Anyone ever try this? I know VPN over frame seems like doing the same thing two different ways to achieve the same result, but I read a post that a guy that is a consultant had to use 4 routers (2 to simulate the WAN connection), but I have a 2530 config'd as a frame switch, with a 2620 on either side of it. I do have an additional 2620XM, but I would have to buy another WIC-1T if I need to go the 4 router path. Also, has anyone here actually had any experience with VoFR? thanks.

Burt
 
Sorry about the delay. Got shipped out of town for the week last week. Here is what I promised:

Code:
ip domain name domain.net
!
isdn switch-type primary-ni
!
voice-card 0
 no dspfarm
!
voice-card 1
 no dspfarm
!
controller T1 0/1/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/1/1
 shutdown
 framing esf
 linecode b8zs
!
controller T1 0/3/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 0/3/1
 shutdown
 framing esf
 linecode b8zs
!
class-map match-any CONTROL
 match ip dscp af31
 match ip dscp cs3
class-map match-all VIDEO
 match ip dscp af41
class-map match-any VOICE
 match ip dscp ef
 match ip dscp cs5
!
!
policy-map WAN
 class VOICE
  priority 352
 class VIDEO
  priority 128
 class CONTROL
  bandwidth 32
 class class-default
  fair-queue
!
!
!
!
!
!
interface Loopback0
 ip address 10.16.1.1 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
 no ip proxy-arp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.5
 encapsulation dot1Q 5 native
 ip address 172.16.5.20 255.255.255.0
 no ip route-cache
 no snmp trap link-status
!
interface GigabitEthernet0/0.201
 encapsulation dot1Q 201
 ip address 10.201.1.2 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip route-cache
 no snmp trap link-status
!
interface GigabitEthernet0/1
 no ip address
 no ip proxy-arp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0:0
 description Main Office
 bandwidth 1536
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache cef
 no ip route-cache
 load-interval 30
 no fair-queue
 frame-relay traffic-shaping
 hold-queue 800 out
!
interface Serial0/1/0:0.18 point-to-point
 description Frame to Site 2
 ip address 10.218.1.1 255.255.255.252
 no ip route-cache
 frame-relay interface-dlci 18
  class FR-SHAPING
!
interface Serial0/1/0:0.20 point-to-point
 description Frame to Site 1
 ip address 10.217.1.1 255.255.255.252
 no ip route-cache
 frame-relay interface-dlci 20
  class FR-SHAPING
!
interface Serial0/3/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
router eigrp 2007
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet0/0.5
 no passive-interface GigabitEthernet0/0.201
 no passive-interface Serial0/1/0:0.18
 no passive-interface Serial0/1/0:0.20
 network 10.16.1.0 0.0.0.255
 network 10.201.1.0 0.0.0.255
 network 10.217.1.0 0.0.0.3
 network 10.218.1.0 0.0.0.3
 network 192.168.70.0
 auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.201.1.1
!
!
ip http server
no ip http secure-server
!
!
map-class frame-relay FR-SHAPING
 frame-relay cir 768000
 frame-relay bc 7680
 frame-relay be 0
 frame-relay mincir 768000
 service-policy output WAN
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
 timing hookflash-out 500
 description Paging Port
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/3/0:23
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
voice-port 1/1/0
!
voice-port 1/1/1
!
voice-port 1/1/2
!
voice-port 1/1/3
!
ccm-manager redundant-host 172.16.32.17
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.16.32.18 172.16.32.17
ccm-manager config
!
mgcp
mgcp call-agent 172.16.32.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
!
!
dial-peer voice 999000 pots
 service mgcpapp
 port 0/0/0
!
dial-peer voice 999100 pots
 service mgcpapp
 port 1/0/0
!
dial-peer voice 999101 pots
 service mgcpapp
 port 1/0/1
!
dial-peer voice 999102 pots
 service mgcpapp
 port 1/0/2
!
dial-peer voice 999103 pots
 service mgcpapp
 port 1/0/3
!

scheduler allocate 20000 1000
ntp clock-period 17180246
ntp server 10.201.1.1
!
end

Something to remember on frame is that if you have any shaping at all and not on every piece of it the pieces you don't have shaping on will default to 56k.

I do not know why Cisco did this but it caused me a waste of 2 days.

 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top