Ok...Ive got my Vlan setup and I'm having some issues. I've configured 3 VLans and they can all PING each other perfectly. I have a windows 03 server running DNS, DHCP and Routing/remote access. Problem is any host that is not in the same Vlan (2) as my server cant get to the internet, BUT they can ping websites by Name which means my dns is working i guess...If you have any suggestion, I would like to hear them
Vlan 1 management 192.168.0.1
Vlan 2 server 192.168.1.1 (Server 192.168.1.4 -> internet)
Vlan 10 hosts 192.168.10.1 (H 192.168.10.2 Gw 192.168.10.1)
Vlan 20 Hosts 192.168.20.1 (H 192.168.20.2 Gw 192.168.20.1)
Also my firefox browser says cannot connect instead of cannot find server. IE doesnt work either
Router Config
Building configuration...
Current configuration : 1108 bytes
!
! Last configuration change at 05:24:19 UTC Tue Jun 2 2009
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2600
!
enable secret
enable password
!
!
!
!
!
ip subnet-zero
ip domain-name Home.local
ip name-server 192.168.1.4
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
router rip
version 2
network 192.168.1.0
network 192.168.10.0
network 192.168.20.0
!
ip default-gateway 192.168.1.4
ip classless
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
line 33 48
line aux 0
line vty 0 4
p
login
!
ntp clock-period 17180585
ntp server 192.168.1.4
end
Switch Config
Building configuration...
Current configuration:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch
!
enable
!
!
ip domain-name Home.local
ip name-server 192.168.1.4
!
interface VLAN1
ip address 192.168.0.2 255.255.255.0
no ip route-cache
!
interface FastEthernet0/1
description Connected to Router
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 2
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
switchport access vlan 10
!
interface FastEthernet0/10
switchport access vlan 10
!
interface FastEthernet0/11
switchport access vlan 10
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
switchport access vlan 20
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
ip default-gateway 192.168.1.4
banner motd ^C
Vlan 1 management 192.168.0.1
Vlan 2 server 192.168.1.1 (Server 192.168.1.4 -> internet)
Vlan 10 hosts 192.168.10.1 (H 192.168.10.2 Gw 192.168.10.1)
Vlan 20 Hosts 192.168.20.1 (H 192.168.20.2 Gw 192.168.20.1)
Also my firefox browser says cannot connect instead of cannot find server. IE doesnt work either
Router Config
Building configuration...
Current configuration : 1108 bytes
!
! Last configuration change at 05:24:19 UTC Tue Jun 2 2009
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2600
!
enable secret
enable password
!
!
!
!
!
ip subnet-zero
ip domain-name Home.local
ip name-server 192.168.1.4
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
router rip
version 2
network 192.168.1.0
network 192.168.10.0
network 192.168.20.0
!
ip default-gateway 192.168.1.4
ip classless
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
line 33 48
line aux 0
line vty 0 4
p
login
!
ntp clock-period 17180585
ntp server 192.168.1.4
end
Switch Config
Building configuration...
Current configuration:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname Switch
!
enable
!
!
ip domain-name Home.local
ip name-server 192.168.1.4
!
interface VLAN1
ip address 192.168.0.2 255.255.255.0
no ip route-cache
!
interface FastEthernet0/1
description Connected to Router
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 2
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
switchport access vlan 10
!
interface FastEthernet0/10
switchport access vlan 10
!
interface FastEthernet0/11
switchport access vlan 10
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
switchport access vlan 20
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
ip default-gateway 192.168.1.4
banner motd ^C