CertifiedNut
Technical User
I have a 2821 set up on my network to replace an old 3Com router. I have a few satic routes set up that are needed to route through to another site.
However, when i try to access the internet from the network, i have lost access. I know this is down to the new default gateway, but don't know what i need to add to the config to get the route to the internet via my PIX firewall (ip add 10.0.10.250). Can anyone help with how i set it up so that it routes all other traffic, not destined for the site to site link, to the internet firewall on my network - I believe it's called setting the gateway of last resort??? I posted the config below.
Thanks
Nut
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MOTADGW
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
ip domain name yourdomain.com
!
username cisco privilege 15 secret 5 $1$3WLd$EXDEYhtYinFFfX1dQyZs/1
!
!
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 10.0.10.254 255.255.255.0
duplex full
speed 100
!
interface GigabitEthernet0/1
ip address 192.168.20.10 255.255.255.0
duplex auto
speed auto
!
interface Group-Async0
physical-layer async
no ip address
no group-range
!
interface Group-Async1
physical-layer async
no ip address
!
ip default-gateway 10.0.10.250
ip classless
ip route 10.0.10.0 255.255.255.0 192.168.20.20
ip route 10.1.0.0 255.255.0.0 192.168.20.20 name xxxxxx
ip route 10.2.0.0 255.255.0.0 192.168.20.20 name xxxxxxxxx
ip route 191.1.0.0 255.255.0.0 192.168.20.20 name xxxxx
ip route 192.168.168.100 255.255.255.255 192.168.20.20 xxxxxxx
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
control-plane
!
banner exec ^C
% Password expiration warning.
---------------------------------------------------------------------
^C
banner login ^C
---------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege level of 15.
Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want to use.
For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to ---------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
However, when i try to access the internet from the network, i have lost access. I know this is down to the new default gateway, but don't know what i need to add to the config to get the route to the internet via my PIX firewall (ip add 10.0.10.250). Can anyone help with how i set it up so that it routes all other traffic, not destined for the site to site link, to the internet firewall on my network - I believe it's called setting the gateway of last resort??? I posted the config below.
Thanks
Nut
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MOTADGW
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
ip domain name yourdomain.com
!
username cisco privilege 15 secret 5 $1$3WLd$EXDEYhtYinFFfX1dQyZs/1
!
!
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 10.0.10.254 255.255.255.0
duplex full
speed 100
!
interface GigabitEthernet0/1
ip address 192.168.20.10 255.255.255.0
duplex auto
speed auto
!
interface Group-Async0
physical-layer async
no ip address
no group-range
!
interface Group-Async1
physical-layer async
no ip address
!
ip default-gateway 10.0.10.250
ip classless
ip route 10.0.10.0 255.255.255.0 192.168.20.20
ip route 10.1.0.0 255.255.0.0 192.168.20.20 name xxxxxx
ip route 10.2.0.0 255.255.0.0 192.168.20.20 name xxxxxxxxx
ip route 191.1.0.0 255.255.0.0 192.168.20.20 name xxxxx
ip route 192.168.168.100 255.255.255.255 192.168.20.20 xxxxxxx
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
control-plane
!
banner exec ^C
% Password expiration warning.
---------------------------------------------------------------------
^C
banner login ^C
---------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege level of 15.
Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want to use.
For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to ---------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end