I am trying to set it up so that a host on my network (with address 192.168.1.2) is only allowed 8000 bytes (64000 bits) of bandwidth going to the outside world. Below is my running-config. I can't figure out why the heck this isn't working. I tried putting the "traffic-shape group 102 64000" on both the inside card and the outside card.
it is a cisco 1720 router
thanks,
matt
---[snip]
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
!
hostname cc
!
boot system flash c1700-y-mz.121-3.XT1
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
logging console warnings
enable secret <DELETED OUT>
enable password <DELETED OUT>
!
memory-size iomem 20
no ip subnet-zero
no ip finger
ip name-server 192.168.1.2
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool dhcp_pool
network 192.168.1.0 255.255.255.0
domain-name <DELETED OUT>
default-router 192.168.1.1
dns-server 192.168.1.2
!
!
!
!
interface Ethernet0
ip address dhcp
ip nat outside
half-duplex
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed auto
full-duplex
traffic-shape group 102 64000 8000 8000 1000
no cdp enable
!
interface Dialer0
no ip address
shutdown
no cdp enable
!
ip nat translation timeout 21600
ip nat pool natpool x.x.x.x x.x.x.x netmask 255.255.254.0 (THE x.x.x.x HERE IS MY OUTSIDE IP ADDRESS)
ip nat inside source list 1 pool natpool overload
ip nat inside source static tcp 192.168.1.2 80 interface Ethernet0 80
no ip classless
ip route x.0.0.0 255.0.0.0 x.x.x.x
no ip http server
!
logging 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 deny any
access-list 102 permit ip host 192.168.1.2 any
snmp-server engineID local <DELETED OUT>
snmp-server community public RO
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password <DELETED OUT>
login
!
no scheduler allocate
end
it is a cisco 1720 router
thanks,
matt
---[snip]
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
!
hostname cc
!
boot system flash c1700-y-mz.121-3.XT1
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
logging console warnings
enable secret <DELETED OUT>
enable password <DELETED OUT>
!
memory-size iomem 20
no ip subnet-zero
no ip finger
ip name-server 192.168.1.2
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool dhcp_pool
network 192.168.1.0 255.255.255.0
domain-name <DELETED OUT>
default-router 192.168.1.1
dns-server 192.168.1.2
!
!
!
!
interface Ethernet0
ip address dhcp
ip nat outside
half-duplex
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed auto
full-duplex
traffic-shape group 102 64000 8000 8000 1000
no cdp enable
!
interface Dialer0
no ip address
shutdown
no cdp enable
!
ip nat translation timeout 21600
ip nat pool natpool x.x.x.x x.x.x.x netmask 255.255.254.0 (THE x.x.x.x HERE IS MY OUTSIDE IP ADDRESS)
ip nat inside source list 1 pool natpool overload
ip nat inside source static tcp 192.168.1.2 80 interface Ethernet0 80
no ip classless
ip route x.0.0.0 255.0.0.0 x.x.x.x
no ip http server
!
logging 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 deny any
access-list 102 permit ip host 192.168.1.2 any
snmp-server engineID local <DELETED OUT>
snmp-server community public RO
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password <DELETED OUT>
login
!
no scheduler allocate
end