Can you suggest what I have to do to be able to receive email? I can send fine but can't receive.
SBS 2000
int NIC 192.162.16.2 gtwy 10.0.0.2
ext NIC 10.0.0.2 gtwy 10.0.0.1
Cisco 802
eth 0 10.0.0.1
wan 67.x.x.x
I believe I have entered correct port forwarding via:
ip nat inside source static tcp 10.0.0.2 25 67.x.x.x 25 extendable
I can telnet into the domain from home using 67.x.x.x port 23 and config the router. I can't telnet into the domain if I select port 25.
Router config:
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxxxx
!
logging buffered 8192 debugging
enable secret 5 $1$JV0M$eWjRkd9gcEgXuayGPtQtQ/
!
username xxx password x sssssssssssssss
!
!
!
!
ip subnet-zero
no ip source-route
!
no ip domain-lookup
isdn switch-type basic-ni
!
!
process-max-time 200
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip access-group 121 in
no ip directed-broadcast
no ip proxy-arp
ip nat inside
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 xxxxxxxxxxxxxxxxx
isdn spid2 xxxxxxxxxxxxxxxxx
ppp authentication chap pap callin
ppp multilink
!
interface Dialer1
description ISP
ip address negotiated
ip access-group 121 in
no ip directed-broadcast
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
dialer remote-name Cisco1
dialer idle-timeout 300
dialer string 4571899 class DialClass
dialer string 3891311 class DialClass
dialer hold-queue 10
dialer load-threshold 10 either
dialer pool 1
dialer-group 1
fair-queue 64 16 0
pulse-time 0
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxxxxxxx
ppp chap password xxxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxx password xxxxxx
ppp multilink
!
ip nat inside source list 18 interface Dialer1 overload
ip nat inside source static tcp 10.0.0.2 25 67.x.x.x 25 extendable
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
map-class dialer DialClass
dialer isdn speed 56
access-list 18 permit 10.0.0.0 0.255.255.255
access-list 121 deny udp any eq netbios-dgm any
access-list 121 deny udp any eq netbios-ns any
access-list 121 deny udp any eq netbios-ss any
access-list 121 deny tcp any eq 137 any
access-list 121 deny tcp any eq 138 any
access-list 121 deny tcp any eq 139 any
access-list 121 permit ip any any time-range TIME
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
!
time-range TIME
periodic daily 0:00 to 23:59
!
end
Any help greatly appreciated!
SBS 2000
int NIC 192.162.16.2 gtwy 10.0.0.2
ext NIC 10.0.0.2 gtwy 10.0.0.1
Cisco 802
eth 0 10.0.0.1
wan 67.x.x.x
I believe I have entered correct port forwarding via:
ip nat inside source static tcp 10.0.0.2 25 67.x.x.x 25 extendable
I can telnet into the domain from home using 67.x.x.x port 23 and config the router. I can't telnet into the domain if I select port 25.
Router config:
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxxxx
!
logging buffered 8192 debugging
enable secret 5 $1$JV0M$eWjRkd9gcEgXuayGPtQtQ/
!
username xxx password x sssssssssssssss
!
!
!
!
ip subnet-zero
no ip source-route
!
no ip domain-lookup
isdn switch-type basic-ni
!
!
process-max-time 200
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip access-group 121 in
no ip directed-broadcast
no ip proxy-arp
ip nat inside
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 xxxxxxxxxxxxxxxxx
isdn spid2 xxxxxxxxxxxxxxxxx
ppp authentication chap pap callin
ppp multilink
!
interface Dialer1
description ISP
ip address negotiated
ip access-group 121 in
no ip directed-broadcast
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
dialer remote-name Cisco1
dialer idle-timeout 300
dialer string 4571899 class DialClass
dialer string 3891311 class DialClass
dialer hold-queue 10
dialer load-threshold 10 either
dialer pool 1
dialer-group 1
fair-queue 64 16 0
pulse-time 0
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxxxxxxx
ppp chap password xxxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxx password xxxxxx
ppp multilink
!
ip nat inside source list 18 interface Dialer1 overload
ip nat inside source static tcp 10.0.0.2 25 67.x.x.x 25 extendable
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
map-class dialer DialClass
dialer isdn speed 56
access-list 18 permit 10.0.0.0 0.255.255.255
access-list 121 deny udp any eq netbios-dgm any
access-list 121 deny udp any eq netbios-ns any
access-list 121 deny udp any eq netbios-ss any
access-list 121 deny tcp any eq 137 any
access-list 121 deny tcp any eq 138 any
access-list 121 deny tcp any eq 139 any
access-list 121 permit ip any any time-range TIME
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
!
time-range TIME
periodic daily 0:00 to 23:59
!
end
Any help greatly appreciated!