I want to be able to allow a host on the internal network to connect via a specific port xxxx. The inside net is currently using a nat overload on a single ip. I have tried static nat setup with specific port info and adding that ip/port combo to a deny statement in the dynamic nat access list. The internal host still seems to create a dynamic port number everytime it connects to the outside host. The traffic does go out with the correct port xxxx as destination and comes back with source port correct but i think the application is having a problem because it is actually recieving the data at the dynamic port. Any help is appreciated. BTW i have removed the access list and it does not help. Thanks, Damon
Config ::
Using 2824 out of 29688 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
!
hostname ihs-1720
!
boot system flash
logging buffered 4096 debugging
enable secret 5 blah
enable password 7 blah
!
ip subnet-zero
no ip source-route
no ip domain lookup
ip name-server 192.168.1.1
ip name-server blah
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.50
!
ip dhcp pool dhcppool
network 192.168.1.0 255.255.255.0
domain-name blah
default-router 192.168.1.254
dns-server 192.168.1.1
!
no ip bootp server
ip inspect name inspectfilter smtp alert on
ip inspect name inspectfilter ftp alert on
ip inspect name inspectfilter tcp alert on
ip inspect name inspectfilter udp alert on
ip inspect name inspectfilter http alert on
ip audit info action alarm drop reset
ip audit notify log
ip audit po max-events 100
!
!
!
!
interface Ethernet0
description Internet Ethernet Connection
ip address x.x.x.x 255.255.255.0
ip access-group 101 in
no ip redirects
no ip unreachables
ip nat outside
ip inspect inspectfilter out
half-duplex
no cdp enable
!
interface FastEthernet0
ip address 192.168.1.254 255.255.255.0
no ip redirects
no ip unreachables
ip nat inside
speed auto
no cdp enable
!
ip nat inside source list 150 interface Ethernet0 overload
ip nat inside source static tcp 192.168.1.1 25 interface Ethernet0 25
ip nat inside source static tcp 192.168.1.17 6877 interface Ethernet0 6877
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.y
ip route 192.168.1.0 255.255.255.0 FastEthernet0
no ip http server
!
logging 192.168.1.1
access-list 11 permit 192.168.1.16
access-list 101 permit tcp host z.z.z.z host x.x.x.x eq 6877
access-list 101 permit tcp any host x.x.x.x eq smtp
access-list 101 permit tcp any any eq 1723
access-list 101 permit gre any any
access-list 101 permit icmp any any administratively-prohibited
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any echo
access-list 101 permit icmp any any packet-too-big
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any traceroute
access-list 101 permit icmp any any unreachable
access-list 101 deny icmp any any
access-list 101 deny ip any any
access-list 101 deny tcp any any
access-list 101 deny udp any any
access-list 150 deny tcp host 192.168.1.1 eq smtp any eq smtp
access-list 150 deny tcp host 192.168.1.17 eq 6877 any eq 6877
access-list 150 permit ip 192.168.1.0 0.0.0.255 any
no cdp run
!
line con 0
login
line aux 0
exec-timeout 5 0
login
line vty 0 4
session-timeout 1
exec-timeout 5 0
password 7 03105A121200231C1F
login
transport input none
!
scheduler allocate 4000 1000
end
Config ::
Using 2824 out of 29688 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
!
hostname ihs-1720
!
boot system flash
logging buffered 4096 debugging
enable secret 5 blah
enable password 7 blah
!
ip subnet-zero
no ip source-route
no ip domain lookup
ip name-server 192.168.1.1
ip name-server blah
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.50
!
ip dhcp pool dhcppool
network 192.168.1.0 255.255.255.0
domain-name blah
default-router 192.168.1.254
dns-server 192.168.1.1
!
no ip bootp server
ip inspect name inspectfilter smtp alert on
ip inspect name inspectfilter ftp alert on
ip inspect name inspectfilter tcp alert on
ip inspect name inspectfilter udp alert on
ip inspect name inspectfilter http alert on
ip audit info action alarm drop reset
ip audit notify log
ip audit po max-events 100
!
!
!
!
interface Ethernet0
description Internet Ethernet Connection
ip address x.x.x.x 255.255.255.0
ip access-group 101 in
no ip redirects
no ip unreachables
ip nat outside
ip inspect inspectfilter out
half-duplex
no cdp enable
!
interface FastEthernet0
ip address 192.168.1.254 255.255.255.0
no ip redirects
no ip unreachables
ip nat inside
speed auto
no cdp enable
!
ip nat inside source list 150 interface Ethernet0 overload
ip nat inside source static tcp 192.168.1.1 25 interface Ethernet0 25
ip nat inside source static tcp 192.168.1.17 6877 interface Ethernet0 6877
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.y
ip route 192.168.1.0 255.255.255.0 FastEthernet0
no ip http server
!
logging 192.168.1.1
access-list 11 permit 192.168.1.16
access-list 101 permit tcp host z.z.z.z host x.x.x.x eq 6877
access-list 101 permit tcp any host x.x.x.x eq smtp
access-list 101 permit tcp any any eq 1723
access-list 101 permit gre any any
access-list 101 permit icmp any any administratively-prohibited
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any echo
access-list 101 permit icmp any any packet-too-big
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any traceroute
access-list 101 permit icmp any any unreachable
access-list 101 deny icmp any any
access-list 101 deny ip any any
access-list 101 deny tcp any any
access-list 101 deny udp any any
access-list 150 deny tcp host 192.168.1.1 eq smtp any eq smtp
access-list 150 deny tcp host 192.168.1.17 eq 6877 any eq 6877
access-list 150 permit ip 192.168.1.0 0.0.0.255 any
no cdp run
!
line con 0
login
line aux 0
exec-timeout 5 0
login
line vty 0 4
session-timeout 1
exec-timeout 5 0
password 7 03105A121200231C1F
login
transport input none
!
scheduler allocate 4000 1000
end