telecotek1
Vendor
I have a pretty simple configuration that i want to run past the group. Can someone tell me if Im way off. The configuration consist of 3 sr2330's in a hub and spoke configuration. (meaning one sr2330 has 2 T1's configured and connected to Sr2330 at remote locations) Each router has Ethernet interfaces 0/1 and 0/2 in a vlan and then assigned a static address on 0/3. All we want to do is have the interfaces on 0/1 and 0/2 of each router be reachable across the T1 point to point.
Things that are glaring not that i know exactly how to configure it framing and coding on my WAN bundles or T1's, ip routing probably should point across the wan interface not to the vlan and finally the firewall - should be disable or set to permit all somehow.
Hub router Config
sh run
Retrieving configuration... please wait
system logging
console
priority crit
exit console
syslog
module alarms local0 none
module dos local0 none
module forwarding local0 none
module voip-ssm-cdr local0 none
module voip-cdr local0 none
module voip-gwy local0 none
exit syslog
exit logging
hostname HubRouter
log utc
event
exit event
terminal
exit terminal
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
module t1 1/1
alarms
thresholds
exit thresholds
exit alarms
linemode
exit linemode
exit t1
module t1 1/2
alarms
thresholds
exit thresholds
exit alarms
linemode
Press any key to continue (q : quit) :
exit linemode
exit t1
aaa
tacacs
exit tacacs
radius
primary_server
exit primary_server
secondary_server
exit secondary_server
exit radius
exit aaa
vlan database
vlan 10
exit database
vlan classification
exit classification
bridge
mstp
exit mstp
Press any key to continue (q : quit) :
exit bridge
lacp
exit lacp
interface ethernet 0/1
aaa
exit aaa
switchport
switchport pvid 10
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/2
aaa
exit aaa
switchport
switchport pvid 10
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/3
ip address 10.10.10.77 255.255.255.0
aaa
exit aaa
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface bundle wan
link t1 1/1
Press any key to continue (q : quit) :
encapsulation ppp
ip address 100.100.100.1 255.255.255.0
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.100.2
ppp src-addr 100.100.100.1
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface bundle wan2
link t1 1/2
encapsulation ppp
ip address 100.100.101.1 255.255.255.0
Press any key to continue (q : quit) :
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.101.2
ppp src-addr 100.100.101.1
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface vlan vlan1
qos
chassis
exit chassis
exit qos
exit vlan
Press any key to continue (q : quit) :
interface vlan vlan10
ip address 192.168.10.1 255.255.255.0
qos
chassis
exit chassis
exit qos
exit vlan
interface console
aaa
exit aaa
exit console
gvrp
exit gvrp
snmp-server
engine-id
local 0000000c000000007f000001
exit engine-id
chassis-id HubRouter
enable traps
exit traps
Press any key to continue (q : quit) :
exit snmp-server
rmon
exit rmon
oam
cfm
enable
ethtype 88e6
exit cfm
exit oam
icmp_timestamp
telnet_banner
exit telnet_banner
sntp
exit sntp
ip proxy-dns
exit proxy-dns
ip host_add HubRouter 192.168.24.10
ip load-balancing per-flow
ip route 192.168.11.0/24 192.168.11.1
ip route 192.168.12.0/24 192.168.12.1
Press any key to continue (q : quit) :
ipv6 unicast-routing
ipv6 load-balancing per-flow
mpls tunnel-mode uniform
firewall global
algs
dns
exit dns
exit algs
max-connection-limit self 2048
exit firewall
firewall internet
exit firewall
firewall corp
policy 1024 out permit
exit policy
exit firewall
dst
no enable
exit dst
----------------------------------------------------------------------------------------------------------------
Spoke A Router config config
system logging
console
priority crit
exit console
syslog
module alarms local0 none
module dos local0 none
module forwarding local0 none
module voip-ssm-cdr local0 none
module voip-cdr local0 none
module voip-gwy local0 none
exit syslog
exit logging
hostname SpokeARouter
log utc
event
exit event
terminal
exit terminal
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
module t1 1/1
clock_source line
alarms
thresholds
exit thresholds
exit alarms
linemode
exit linemode
exit t1
module t1 1/2
alarms
thresholds
exit thresholds
exit alarms
Press any key to continue (q : quit) :
linemode
exit linemode
exit t1
aaa
tacacs
exit tacacs
radius
primary_server
exit primary_server
secondary_server
exit secondary_server
exit radius
exit aaa
vlan database
vlan 11
exit database
vlan classification
exit classification
bridge
mstp
Press any key to continue (q : quit) :
exit mstp
exit bridge
lacp
exit lacp
interface ethernet 0/1
aaa
exit aaa
switchport
switchport pvid 11
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/2
aaa
exit aaa
switchport
Press any key to continue (q : quit) :
switchport pvid 11
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/3
ip address 10.10.11.77 255.255.255.0
aaa
exit aaa
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface bundle wan
Press any key to continue (q : quit) :
link t1 1/1
encapsulation ppp
ip address 100.100.100.2 255.255.255.0
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.100.1
ppp src-addr 100.100.100.2
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface vlan vlan11
ip address 192.168.11.1 255.255.255.0
qos
Press any key to continue (q : quit) :
chassis
exit chassis
exit qos
exit vlan
interface console
aaa
exit aaa
exit console
gvrp
exit gvrp
snmp-server
engine-id
local 0000000c000000007f000001
exit engine-id
chassis-id SpokeARouter
enable traps
exit traps
exit snmp-server
rmon
exit rmon
Press any key to continue (q : quit) :
oam
cfm
enable
ethtype 88e6
exit cfm
exit oam
icmp_timestamp
telnet_banner
exit telnet_banner
sntp
exit sntp
ip proxy-dns
exit proxy-dns
ip host_add SpokeARouter 192.168.24.10
ip load-balancing per-flow
ip route 0.0.0.0/0 192.168.10.1
ipv6 unicast-routing
ipv6 load-balancing per-flow
mpls tunnel-mode uniform
firewall global
Press any key to continue (q : quit) :
algs
dns
exit dns
exit algs
max-connection-limit self 2048
exit firewall
firewall internet
exit firewall
firewall corp
policy 1024 out permit
exit policy
exit firewall
dst
no enable
exit dst
------------------------------------------------------------------------------------------------------------------------------------
Spoke B Router Config
system logging
console
priority crit
exit console
syslog
module alarms local0 none
module dos local0 none
module forwarding local0 none
module voip-ssm-cdr local0 none
module voip-cdr local0 none
module voip-gwy local0 none
exit syslog
exit logging
hostname SpokeBRouter
log utc
event
exit event
terminal
exit terminal
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
module t1 1/1
clock_source line
alarms
thresholds
exit thresholds
exit alarms
linemode
exit linemode
exit t1
module t1 1/2
alarms
thresholds
exit thresholds
exit alarms
Press any key to continue (q : quit) :
linemode
exit linemode
exit t1
aaa
tacacs
exit tacacs
radius
primary_server
exit primary_server
secondary_server
exit secondary_server
exit radius
exit aaa
vlan database
vlan 12
exit database
vlan classification
exit classification
bridge
mstp
Press any key to continue (q : quit) :
exit mstp
exit bridge
lacp
exit lacp
interface ethernet 0/1
aaa
exit aaa
switchport
switchport pvid 12
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/2
aaa
exit aaa
switchport
Press any key to continue (q : quit) :
switchport pvid 12
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/3
ip address 10.10.12.77 255.255.255.0
aaa
exit aaa
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface bundle wan
Press any key to continue (q : quit) :
link t1 1/1
encapsulation ppp
ip address 100.100.101.2 255.255.255.0
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.101.1
ppp src-addr 100.100.101.2
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface vlan vlan12
ip address 192.168.12.1 255.255.255.0
qos
Press any key to continue (q : quit) :
chassis
exit chassis
exit qos
exit vlan
interface console
aaa
exit aaa
exit console
gvrp
exit gvrp
snmp-server
engine-id
local 0000000c000000007f000001
exit engine-id
chassis-id SpokeBRouter
enable traps
exit traps
exit snmp-server
rmon
exit rmon
Press any key to continue (q : quit) :
oam
cfm
enable
ethtype 88e6
exit cfm
exit oam
icmp_timestamp
telnet_banner
exit telnet_banner
sntp
exit sntp
ip proxy-dns
exit proxy-dns
ip host_add SpokeBRouter 192.168.24.10
ip load-balancing per-flow
ip route 0.0.0.0/0 192.168.10.1
ipv6 unicast-routing
ipv6 load-balancing per-flow
mpls tunnel-mode uniform
firewall global
Press any key to continue (q : quit) :
algs
dns
exit dns
exit algs
max-connection-limit self 2048
exit firewall
firewall internet
exit firewall
firewall corp
policy 1024 out permit
exit policy
exit firewall
dst
no enable
exit dst
Things that are glaring not that i know exactly how to configure it framing and coding on my WAN bundles or T1's, ip routing probably should point across the wan interface not to the vlan and finally the firewall - should be disable or set to permit all somehow.
Hub router Config
sh run
Retrieving configuration... please wait
system logging
console
priority crit
exit console
syslog
module alarms local0 none
module dos local0 none
module forwarding local0 none
module voip-ssm-cdr local0 none
module voip-cdr local0 none
module voip-gwy local0 none
exit syslog
exit logging
hostname HubRouter
log utc
event
exit event
terminal
exit terminal
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
module t1 1/1
alarms
thresholds
exit thresholds
exit alarms
linemode
exit linemode
exit t1
module t1 1/2
alarms
thresholds
exit thresholds
exit alarms
linemode
Press any key to continue (q : quit) :
exit linemode
exit t1
aaa
tacacs
exit tacacs
radius
primary_server
exit primary_server
secondary_server
exit secondary_server
exit radius
exit aaa
vlan database
vlan 10
exit database
vlan classification
exit classification
bridge
mstp
exit mstp
Press any key to continue (q : quit) :
exit bridge
lacp
exit lacp
interface ethernet 0/1
aaa
exit aaa
switchport
switchport pvid 10
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/2
aaa
exit aaa
switchport
switchport pvid 10
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/3
ip address 10.10.10.77 255.255.255.0
aaa
exit aaa
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface bundle wan
link t1 1/1
Press any key to continue (q : quit) :
encapsulation ppp
ip address 100.100.100.1 255.255.255.0
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.100.2
ppp src-addr 100.100.100.1
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface bundle wan2
link t1 1/2
encapsulation ppp
ip address 100.100.101.1 255.255.255.0
Press any key to continue (q : quit) :
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.101.2
ppp src-addr 100.100.101.1
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface vlan vlan1
qos
chassis
exit chassis
exit qos
exit vlan
Press any key to continue (q : quit) :
interface vlan vlan10
ip address 192.168.10.1 255.255.255.0
qos
chassis
exit chassis
exit qos
exit vlan
interface console
aaa
exit aaa
exit console
gvrp
exit gvrp
snmp-server
engine-id
local 0000000c000000007f000001
exit engine-id
chassis-id HubRouter
enable traps
exit traps
Press any key to continue (q : quit) :
exit snmp-server
rmon
exit rmon
oam
cfm
enable
ethtype 88e6
exit cfm
exit oam
icmp_timestamp
telnet_banner
exit telnet_banner
sntp
exit sntp
ip proxy-dns
exit proxy-dns
ip host_add HubRouter 192.168.24.10
ip load-balancing per-flow
ip route 192.168.11.0/24 192.168.11.1
ip route 192.168.12.0/24 192.168.12.1
Press any key to continue (q : quit) :
ipv6 unicast-routing
ipv6 load-balancing per-flow
mpls tunnel-mode uniform
firewall global
algs
dns
exit dns
exit algs
max-connection-limit self 2048
exit firewall
firewall internet
exit firewall
firewall corp
policy 1024 out permit
exit policy
exit firewall
dst
no enable
exit dst
----------------------------------------------------------------------------------------------------------------
Spoke A Router config config
system logging
console
priority crit
exit console
syslog
module alarms local0 none
module dos local0 none
module forwarding local0 none
module voip-ssm-cdr local0 none
module voip-cdr local0 none
module voip-gwy local0 none
exit syslog
exit logging
hostname SpokeARouter
log utc
event
exit event
terminal
exit terminal
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
module t1 1/1
clock_source line
alarms
thresholds
exit thresholds
exit alarms
linemode
exit linemode
exit t1
module t1 1/2
alarms
thresholds
exit thresholds
exit alarms
Press any key to continue (q : quit) :
linemode
exit linemode
exit t1
aaa
tacacs
exit tacacs
radius
primary_server
exit primary_server
secondary_server
exit secondary_server
exit radius
exit aaa
vlan database
vlan 11
exit database
vlan classification
exit classification
bridge
mstp
Press any key to continue (q : quit) :
exit mstp
exit bridge
lacp
exit lacp
interface ethernet 0/1
aaa
exit aaa
switchport
switchport pvid 11
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/2
aaa
exit aaa
switchport
Press any key to continue (q : quit) :
switchport pvid 11
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/3
ip address 10.10.11.77 255.255.255.0
aaa
exit aaa
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface bundle wan
Press any key to continue (q : quit) :
link t1 1/1
encapsulation ppp
ip address 100.100.100.2 255.255.255.0
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.100.1
ppp src-addr 100.100.100.2
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface vlan vlan11
ip address 192.168.11.1 255.255.255.0
qos
Press any key to continue (q : quit) :
chassis
exit chassis
exit qos
exit vlan
interface console
aaa
exit aaa
exit console
gvrp
exit gvrp
snmp-server
engine-id
local 0000000c000000007f000001
exit engine-id
chassis-id SpokeARouter
enable traps
exit traps
exit snmp-server
rmon
exit rmon
Press any key to continue (q : quit) :
oam
cfm
enable
ethtype 88e6
exit cfm
exit oam
icmp_timestamp
telnet_banner
exit telnet_banner
sntp
exit sntp
ip proxy-dns
exit proxy-dns
ip host_add SpokeARouter 192.168.24.10
ip load-balancing per-flow
ip route 0.0.0.0/0 192.168.10.1
ipv6 unicast-routing
ipv6 load-balancing per-flow
mpls tunnel-mode uniform
firewall global
Press any key to continue (q : quit) :
algs
dns
exit dns
exit algs
max-connection-limit self 2048
exit firewall
firewall internet
exit firewall
firewall corp
policy 1024 out permit
exit policy
exit firewall
dst
no enable
exit dst
------------------------------------------------------------------------------------------------------------------------------------
Spoke B Router Config
system logging
console
priority crit
exit console
syslog
module alarms local0 none
module dos local0 none
module forwarding local0 none
module voip-ssm-cdr local0 none
module voip-cdr local0 none
module voip-gwy local0 none
exit syslog
exit logging
hostname SpokeBRouter
log utc
event
exit event
terminal
exit terminal
Press any key to continue (q : quit) :
qos
module
exit module
chassis
exit chassis
exit qos
module t1 1/1
clock_source line
alarms
thresholds
exit thresholds
exit alarms
linemode
exit linemode
exit t1
module t1 1/2
alarms
thresholds
exit thresholds
exit alarms
Press any key to continue (q : quit) :
linemode
exit linemode
exit t1
aaa
tacacs
exit tacacs
radius
primary_server
exit primary_server
secondary_server
exit secondary_server
exit radius
exit aaa
vlan database
vlan 12
exit database
vlan classification
exit classification
bridge
mstp
Press any key to continue (q : quit) :
exit mstp
exit bridge
lacp
exit lacp
interface ethernet 0/1
aaa
exit aaa
switchport
switchport pvid 12
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/2
aaa
exit aaa
switchport
Press any key to continue (q : quit) :
switchport pvid 12
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface ethernet 0/3
ip address 10.10.12.77 255.255.255.0
aaa
exit aaa
qos
module
exit module
chassis
exit chassis
exit qos
exit ethernet
interface bundle wan
Press any key to continue (q : quit) :
link t1 1/1
encapsulation ppp
ip address 100.100.101.2 255.255.255.0
ppp pap
exit pap
ppp chap
exit chap
ppp authentication-database local
ppp peer-addr 100.100.101.1
ppp src-addr 100.100.101.2
aaa
exit aaa
qos
chassis
exit chassis
exit qos
exit bundle
interface vlan vlan12
ip address 192.168.12.1 255.255.255.0
qos
Press any key to continue (q : quit) :
chassis
exit chassis
exit qos
exit vlan
interface console
aaa
exit aaa
exit console
gvrp
exit gvrp
snmp-server
engine-id
local 0000000c000000007f000001
exit engine-id
chassis-id SpokeBRouter
enable traps
exit traps
exit snmp-server
rmon
exit rmon
Press any key to continue (q : quit) :
oam
cfm
enable
ethtype 88e6
exit cfm
exit oam
icmp_timestamp
telnet_banner
exit telnet_banner
sntp
exit sntp
ip proxy-dns
exit proxy-dns
ip host_add SpokeBRouter 192.168.24.10
ip load-balancing per-flow
ip route 0.0.0.0/0 192.168.10.1
ipv6 unicast-routing
ipv6 load-balancing per-flow
mpls tunnel-mode uniform
firewall global
Press any key to continue (q : quit) :
algs
dns
exit dns
exit algs
max-connection-limit self 2048
exit firewall
firewall internet
exit firewall
firewall corp
policy 1024 out permit
exit policy
exit firewall
dst
no enable
exit dst