leegregory
Technical User
Help.
We are trying to create a VPN tunnel using 2 ADSL lines and 2 Cisco 1840 routers.
When we go to test the VPN we get an error message saying that the IPSEC rules are not matched.
We have checked and double checked and they are identicle to each other. (The routers are set to DHCP but that is only for testing perposes there will be a DHCP server set-up on the network in the final configuration)
The config of one of the routers is below.
Building configuration...
Current configuration : 5584 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname STORO01
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
no logging buffered
logging console critical
enable secret 5 $1$VUWL$uQSSQL41S3OZTSuE3kIn10
!
no aaa new-model
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.50.1 192.168.50.9
!
ip dhcp pool sdm-pool1
import all
network 192.168.50.0 255.255.255.0
dns-server 158.152.1.58 158.152.1.43
default-router 192.168.50.1
!
!
ip tcp synwait-time 10
no ip bootp server
ip domain name blemain.local
ip name-server 158.152.1.58
ip name-server 158.152.1.43
ip ssh time-out 60
ip ssh authentication-retries 2
!
multilink bundle-name authenticated
!
crypto pki trustpoint TP-self-signed-1315490008
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1315490008
revocation-check none
rsakeypair TP-self-signed-1315490008
!
!
username administrator privilege 15 secret 5 $1$Ob0W$ueS4xvbgd/q.VNySnL5l9.
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key blemain address 62.49.74.193
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac comp-lzs
mode transport
!
crypto map SDM_CMAP_1 1 ipsec-isakmp
description Tunnel to62.49.74.193
set peer 62.49.74.193
set transform-set ESP-3DES-SHA
match address 100
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$
ip address 192.168.50.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
shutdown
duplex auto
speed auto
no mop enabled
!
interface ATM0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
no snmp trap link-status
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer0
ip address 62.49.162.161 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
crypto map SDM_CMAP_1
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.50.0 0.0.0.255
access-list 100 remark SDM_ACL Category=4
access-list 100 remark IPSec Rule
access-list 100 permit ip 192.168.50.0 0.0.0.255 62.49.74.192 0.0.0.3
access-list 101 remark SDM_ACL Category=2
access-list 101 remark IPSec Rule
access-list 101 deny ip 192.168.50.0 0.0.0.255 62.49.74.192 0.0.0.3
access-list 101 permit ip 192.168.50.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
!
route-map SDM_RMAP_1 permit 1
match ip address 101
!
!
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 4000 1000
end
We are trying to create a VPN tunnel using 2 ADSL lines and 2 Cisco 1840 routers.
When we go to test the VPN we get an error message saying that the IPSEC rules are not matched.
We have checked and double checked and they are identicle to each other. (The routers are set to DHCP but that is only for testing perposes there will be a DHCP server set-up on the network in the final configuration)
The config of one of the routers is below.
Building configuration...
Current configuration : 5584 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname STORO01
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
no logging buffered
logging console critical
enable secret 5 $1$VUWL$uQSSQL41S3OZTSuE3kIn10
!
no aaa new-model
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.50.1 192.168.50.9
!
ip dhcp pool sdm-pool1
import all
network 192.168.50.0 255.255.255.0
dns-server 158.152.1.58 158.152.1.43
default-router 192.168.50.1
!
!
ip tcp synwait-time 10
no ip bootp server
ip domain name blemain.local
ip name-server 158.152.1.58
ip name-server 158.152.1.43
ip ssh time-out 60
ip ssh authentication-retries 2
!
multilink bundle-name authenticated
!
crypto pki trustpoint TP-self-signed-1315490008
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1315490008
revocation-check none
rsakeypair TP-self-signed-1315490008
!
!
username administrator privilege 15 secret 5 $1$Ob0W$ueS4xvbgd/q.VNySnL5l9.
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key blemain address 62.49.74.193
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac comp-lzs
mode transport
!
crypto map SDM_CMAP_1 1 ipsec-isakmp
description Tunnel to62.49.74.193
set peer 62.49.74.193
set transform-set ESP-3DES-SHA
match address 100
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$
ip address 192.168.50.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
shutdown
duplex auto
speed auto
no mop enabled
!
interface ATM0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
no snmp trap link-status
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer0
ip address 62.49.162.161 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
crypto map SDM_CMAP_1
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.50.0 0.0.0.255
access-list 100 remark SDM_ACL Category=4
access-list 100 remark IPSec Rule
access-list 100 permit ip 192.168.50.0 0.0.0.255 62.49.74.192 0.0.0.3
access-list 101 remark SDM_ACL Category=2
access-list 101 remark IPSec Rule
access-list 101 deny ip 192.168.50.0 0.0.0.255 62.49.74.192 0.0.0.3
access-list 101 permit ip 192.168.50.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
!
route-map SDM_RMAP_1 permit 1
match ip address 101
!
!
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 4000 1000
end