Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Simple router set-up for 2651 3

Status
Not open for further replies.

silverhairbp

IS-IT--Management
Aug 30, 2007
82
US
Follows is a script I wrote for setting up a 2651.

The following is the proposed scerario:

Router connected to a DSL (or possible cable modem in the future) on FastEthernet0/0, to a LAN switch for our home on FastEthernet0/1. Modem handles authentication and logon, (by my understanding) it acts as a simple gateway.

FastEthernet0/0, on the WAN, the router is a DHCP client and should import the DNS info from the downstream host.

FastEthernet0/1 is the LAN side; on the LAN, the router is a DHCP host and should provide DNS info to the clients. Router address should be 192.168.1.1, DHCP client address range should be 192.168.1.100 through 192.168.1.150.

The interface names may be wrong. It would also be nice to implement a "basic firewall" but I have no idea what commands are needed for that.

I admit that I used other scripts to write this so I'm not sure I'm even close. Also, there may be a conflict between "import all" and assigning a name server.

(Is there a GUI set-up tool available for a 2651 running IOS 12.3.36? If there is, please let me know!)

Any comments would be appreciated. Is more than this needed for the router to operate in the scenario note above?

Thanks in advance,

Bill


router>en
router#conf t
router(config)#ip dhcp pool silver1
router(dhcp-config)#network 192.168.1.0 255.255.255.0
router(dhcp-config)#default-router 192.168.1.1
router(dhcp-config)#dns-server 24.217.1.162
router)dhcp-config)#import all
router(dhcp-config)#lease 7
router(dhcp-config)#exit
router(config)#int FastEthernet0/1
router(config-if)#ip add 192.168.1.1 255.255.255.0
router(config-if)#no shut
router(config-if)#ip nat inside
router(config-if)#exit
router(config)#int FastEthernet0/0
router(config-if)#ip add dhcp
router(config-if)#ip nat outside
router(config-if)#no ip redirects
router(config-if)#no shut
router(config-if)#exit
router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
router(config)#ip nat inside source list 1 int FastEthernet0/0 overload
router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.99
router(config)#ip dhcp excluded-address 192.168.1.151 192.168.1.254
router(config)#ip name-server 24.217.1.162
router(config)#line vty 0 4
router(config-line)#password whatever
router(config-line)#login
router(config-line)#exit
router(config)#ip http server
router(config)#ip http secure-server
router(config)#ip http authentication local
router(config)#username [namehere] priv 15 secret [passwordhere]
router(config)#service password-encryption
router(config)#access-list 101 deny tcp any 192.168.1.0 0.0.0.255
router(config)#access-list 101 permit ip any any
router(config)#no service tcp-small-servers
router(config)#no service udp-small-servers
router(config)#no ip source-route
router(config)#ip cef
router(config)#no ip dhcp use vrf connected
router(config)#no ip bootp server
router(config)#ip name-server 24.217.1.162
router(config)#hostname 2651router
2651router (config)#line con 0
2651router (config-line)#logg sync
router(config-if)#exit
2651router (config)#end
2651router #copy run start



 
Did this work for the 831? If the modem provides dhcp and gives fa0/0 a private IP address, you won't need NAT. Also, duplex settings may need to be 1/2. Also, you will want to make fa0/1 a totally different class (like 10.x.x.x 255.255.255.0, or 172.16.x.x, etc.) because I know AT&T modems like to dhcp the entire range of 192.168.0.0/16 which covers 192.168.0.1 all the way through 192.168.255.254, so that would conflict with what you have on fa0/1.
One more thing---PLEASE keep trying on the 877! It's a better router for what you need, and I have a 2620XM that I could not for the LIFE of me get to work with a modem (AT&T), so I went and got a WIC-1ADSL. Look at the last post in your thread! I know we can all get it working! Screw what AT&T says!

Burt
 
I'm going to chime in here also and second Burt's opinions on two fronts; a) don't give up on the 877, it'll work just fine, and b) I freaking HATE working with AT&T; we (meaning my company) are just looking for any reason to drop them as our WAN provider and I can't wait for that day!!!!

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Well, I can't say much about AT&T either. My chat session with them to try to get ANY information was disappointing.

I have the 2651 being shipped, but could use that as a cold standby (using the AT&T modem). Worst case is that its certainly worth more on eBay than what I paid for it. I got a, 831 working with that modem, I was thinking that "cloning" the 831 config with a few changes to fit the 2651 would be fairly easy.

I'll to continue with the 877. It just seemed frustrating to continue to get nowhere. And I was beginning to get concerned that I was imposing too much on the good nature and helpfulness of, in particular, Burt.

 
Meh, use and abuse Burt he likes it ;-)...if nothing else these issues will hone your skills on these beasts

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 

I've reset the router back to factory defaults, loaded in enough config to get SDM running and tried a few variations to the "first" SDM set-up. I can test the config later when SWMBO calls it a night.

I'll post a sh run after I test.

 
I feel sooooo used...lol
I enjoy all of this---you're helping me out as well---I get more experience doing this than I do at my job! I am a server hardware guy that happens to have gone through Cisco Academy CCNA 1-4, read a few books, set up labs with Boson CCNP Lab Sim, a total of 6 routers (one 1720, one 837, two 2620's, one 2620XM, and a 2503), four switches (three 2924XLs and one C2980G, running CatOS), and a PIX520, all in various labs, and got my CCNA and then a year later CCNP, all with no job experience. To this day, I have had three Cisco calls! I have a 1750 at work, but no more 1720 or 837, though my 2620XM at home has a WIC-1ADSL. The other routers have mostly WIC-1t cards and WIC-1DSU-T1 cards.
In other words...keep the questions coming! I look forward to trying to help, and especially learn from others, when I can!
One more thing---I am not sure who is worse as far as help desks go---Dell or AT&T...now THAT's BAD!

Burt
 
Above was posted to wrong thread.

The 831 had a similar config as above, but I recall blowing a lot of it away when I went DSL. Used CRWS for the basic DSL set-up (using the Motorola modem) then tweaked it until it worked. Not a big deal at the time (a year ago).

The 831 run config was listed on the 877 LAN thread. I was trying to simplify it above.
 
And I'm an old crypto guy (until I retired) who used to be a programmer, analyst, yada, yada... So this isn't completely foreign, but some of the more extreme details and many of the commands and their syntax are challenging.

I'm enjoying this, but from the perspective "wow, this thing really has a lot of options!" My longer range concern is based on what happens if I upgrade to very high-speed broadband (16mbs+). Maybe I'll get to have all this fun again.

I've debated several times whether to pick up the CCNA study guides, but have talked myself out of it. Retirement just takes up too much time. ;)
 
Yeah, the 16 meg service just might require more horsepower, like the 2651, so...
There is "CCNA For Dummies" book---PLEASE don't take that wrong! It is an excellent starter book for CCNA. It gives a basic understanding of CCNA stuff, but not enough to necessarily pass the exam(s). Perhaps that's all you would need, not necessarily getting your CCNA...just a thought. I know I have a .pdf of it somewhere...I'll look and put it on FTP. I have a lot of stuff...

ftp://smsstlftp.gotdns.com

Also check out our company...


We do deal with a lot of older stuff, including the PDP series (yes, the PDP 1! Go Space War!). I fixed a MicroVAX II a few months ago, which had tw0 2KB memory cards in it, and a 160MB hard drive.

By the way, the real name is Tim.

Burt/Tim
 
I've used the "Dummies" books before. Found them a good and useful intro to a lot of things including being a nice Linux primer.

You've probably never heard of my former employer:


I was with them for a little more than 20 years. Lucky enough to get involved in some interesting projects. Lots of security work.

Can't thank you enough for the help.

Bill
 
I picked up "CCNA for Dummies" this evening. 2nd edition from 2004. Its a little exam-oriented, first couple of chapters are fairly simple. I'll dive into it next week on vacation. Nothin' like a good book to help relax. In Vegas. :)
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top