Hello. I just finished setting up a site to site VPN with another company. However we're only allowing a single IP to pass through the tunnel so I need to setup an overloaded NAT to be able to let all the computers necessary pass through.
My setup is a bit strange. We have a frame relay so my Serial 0/0 interface has an IP. Then my ethernet 0/0 has the actual IP of the router on the internet. Then I want to setup ethernet 0/1 to be the local interface.
So my config should look roughly like this (example IP's...), I thought, but I can't make it work :
interface FastEthernet0/0
ip address 208.56.147.1 255.255.255.0
ip nat outside
...
interface FastEthernet0/1
ip address 10.0.0.17 255.255.248.0
ip nat inside
ip nat pool vpnpool 208.56.147.190 208.56.147.190 prefix-length 24
ip nat inside source list 2 pool vpnpool overload
access-list 2 permit 10.0.0.0 0.0.0.100
And then the access-list for the actual VPN only permits 208.56.147.190 to pass through the VPN. I thought with the above config it would setup a pool, 'vpnpool', with only 208.56.147.190. Then the overload would allow multiple inside ip's to use the single outside ip. And with access-list 2 I should be allowing 10.0.0.0 through 10.0.0.100 to use that nat, correct? But I've tried it from several 10.0.0.x IP's within that range and it just won't work.
What am I missing here? Any help would be greatly appreciated...
Thanks,
Richard
My setup is a bit strange. We have a frame relay so my Serial 0/0 interface has an IP. Then my ethernet 0/0 has the actual IP of the router on the internet. Then I want to setup ethernet 0/1 to be the local interface.
So my config should look roughly like this (example IP's...), I thought, but I can't make it work :
interface FastEthernet0/0
ip address 208.56.147.1 255.255.255.0
ip nat outside
...
interface FastEthernet0/1
ip address 10.0.0.17 255.255.248.0
ip nat inside
ip nat pool vpnpool 208.56.147.190 208.56.147.190 prefix-length 24
ip nat inside source list 2 pool vpnpool overload
access-list 2 permit 10.0.0.0 0.0.0.100
And then the access-list for the actual VPN only permits 208.56.147.190 to pass through the VPN. I thought with the above config it would setup a pool, 'vpnpool', with only 208.56.147.190. Then the overload would allow multiple inside ip's to use the single outside ip. And with access-list 2 I should be allowing 10.0.0.0 through 10.0.0.100 to use that nat, correct? But I've tried it from several 10.0.0.x IP's within that range and it just won't work.
What am I missing here? Any help would be greatly appreciated...
Thanks,
Richard