We have a new ASA5505 with the Security Plus Unlimited License. We are trying to setup two web servers in our DMZ with PUBLIC IP addresses (as required by our application). These machines CANNOT be NAT'ed in the DMZ.
Network Space (IP's have been sanitized from their production values):
Inside -- 192.168.2.1/24
VPN Pool -- 192.168.1.1/24
Outside -- 71.1.2.246/30 (ISP Router is 71.1.2.245)
Assigned IP Block from ISP (DMZ Addresses): 71.1.6.160/29
* As you'll see in the config, the inside addresses NAT outbound which works perfectly
* The DMZ hosts are configured with rules to allow inbound ICMP and HTTP traffic.
* Each server in the DMZ is using 71.1.6.161 as it's gateway (which is the address bound to the DMZ interface on the ASA). Each server can ping each other as well as the gateway IP successfully.
* If you attempt to browse (HTTP) to a DMZ webserver from an outside computer, the ASA logs the traffic request (i.e.: Built inbound TCP connection 2140 for outside:152.71.13.29/37768 (152.71.13.29/37768) to dmz:71.1.6.163/80 (71.1.6.163/80)), but nothing is ever served up
* There's also quite a few deny messages in the logs for people trying to connect to SSH and FTP, which makes me believe that the firewall portion is setup properly.
The strange thing is that we cannot connect to the internet FROM either of the webservers, nor can we ping the webservers by IP from outside, nor does it appear that any traffic is making it to the servers.
Pings from the ASA to the DMZ IP's work properly if over the DMZ interface. If you do a ping using the outside interface, the ASA logs an error: (Routing failed to locate next hop for icmp from NP Identity Ifc:71.1.2.246/0 to outside:71.1.6.163/0)
I'm apparently missing something on the routing between the DMZ Public IP's and the outside Interface. Any assistance would be appreciated!
Thanks!
Network Space (IP's have been sanitized from their production values):
Inside -- 192.168.2.1/24
VPN Pool -- 192.168.1.1/24
Outside -- 71.1.2.246/30 (ISP Router is 71.1.2.245)
Assigned IP Block from ISP (DMZ Addresses): 71.1.6.160/29
* As you'll see in the config, the inside addresses NAT outbound which works perfectly
* The DMZ hosts are configured with rules to allow inbound ICMP and HTTP traffic.
* Each server in the DMZ is using 71.1.6.161 as it's gateway (which is the address bound to the DMZ interface on the ASA). Each server can ping each other as well as the gateway IP successfully.
* If you attempt to browse (HTTP) to a DMZ webserver from an outside computer, the ASA logs the traffic request (i.e.: Built inbound TCP connection 2140 for outside:152.71.13.29/37768 (152.71.13.29/37768) to dmz:71.1.6.163/80 (71.1.6.163/80)), but nothing is ever served up
* There's also quite a few deny messages in the logs for people trying to connect to SSH and FTP, which makes me believe that the firewall portion is setup properly.
The strange thing is that we cannot connect to the internet FROM either of the webservers, nor can we ping the webservers by IP from outside, nor does it appear that any traffic is making it to the servers.
Pings from the ASA to the DMZ IP's work properly if over the DMZ interface. If you do a ping using the outside interface, the ASA logs an error: (Routing failed to locate next hop for icmp from NP Identity Ifc:71.1.2.246/0 to outside:71.1.6.163/0)
I'm apparently missing something on the routing between the DMZ Public IP's and the outside Interface. Any assistance would be appreciated!
Thanks!
Code:
Note: This has been SANITIZED with Fake IP's
--------------------------------------------------------
ASA Version 8.2(1)
!
hostname asa5505
domain-name company.com
enable password <<REMOVED>> encrypted
passwd <<REMOVED>> encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 71.1.2.246 255.255.255.252
!
interface Vlan12
nameif dmz
security-level 50
ip address 71.1.6.161 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
speed 100
duplex full
!
interface Ethernet0/1
switchport access vlan 12
!
interface Ethernet0/2
switchport access vlan 12
!
interface Ethernet0/3
switchport access vlan 12
!
interface Ethernet0/4
switchport access vlan 12
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name company.com
same-security-traffic permit intra-interface
object-group network web_servers
network-object host 71.1.6.163
network-object host 71.1.6.164
access-list clientvpn_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.224
access-list dmz_access_in extended permit icmp any object-group web_servers
access-list outside_access_in extended permit tcp any object-group web_servers eq www
access-list outside_access_in extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpn_pool 192.168.1.11-192.168.1.20 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
icmp permit any dmz
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (dmz,outside) 71.1.6.163 71.1.6.163 netmask 255.255.255.255
static (dmz,outside) 71.1.6.164 71.1.6.164 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 71.1.2.245 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
ssh version 2
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.2.11-192.168.2.20 inside
dhcpd dns 208.67.222.222 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy clientvpn internal
group-policy clientvpn attributes
dns-server value 4.2.2.2
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value clientvpn_splitTunnelAcl
username <<REMOVED>> password <<REMOVED>> encrypted privilege 0
username <<REMOVED>> attributes
vpn-group-policy clientvpn
tunnel-group clientvpn type remote-access
tunnel-group clientvpn general-attributes
address-pool vpn_pool
default-group-policy clientvpn
tunnel-group clientvpn ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:0cedb446a0ef0f7577804f665c473427
: end
no asdm history enable