I assume that you have two computers set up, one on each segment, that you're trying to ping? Barring something like an access-list, this should work as long as your computers have routes to the other side. Setting the default routes to the corresponding router addresses will do it.
Looking at your post it seems that your using only one router, hence the E0 and E1. Routers know about directly connected interfaces. So without having any routing protocols turned or or static routes, you should be able to ping from E0 to E1. If not, please post your configuration.
"I can picture a world without war. A world without hate. A world without fear. And I can picture us attacking that world, because they'd never expect it."
- Jack Handey, Deep Thoughts
The first thing I would make sure of is that you are able to ping both interfaces(E0/E1) gateways from those clients before you ping across. I've setup something similar and ended up setting up a static routing config which is painfully simple with two interfaces. Good luck.
I can ping the default gateway on the router on each segment from any of the 2 pc, but not from machine to machine.
I have 2 PC.
PC 1: IP 10.1.0.20/16
GW 10.1.0.1/16
PC 2: IP 192.168.1.10/24
GW 192.168.1.1/24
The router configuration is:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
interface Ethernet0
description LAN
ip address 10.1.0.1 255.255.0.0
!
interface Ethernet1
description WAN
ip address 192.168.1.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
ip classless
!
!
line con 0
line vty 0 4
login
!
end
With the version of code your running "ip routing" is turned on automatically. I wouldn't use the static routes. If you're going through all that trouble, I'd try this:
config t
ip routing
router rip
network 10.0.0.0
network 192.168.0.0
end
It will work for sure that way. If you don't mind turning on a routing protocol.
"I can picture a world without war. A world without hate. A world without fear. And I can picture us attacking that world, because they'd never expect it."
- Jack Handey, Deep Thoughts
You don't need to use routing protocols or statics for a single router with these networks directly connected. If the user posts a 'sh ip route' the router should have both networks in the routing table as 'directly connected networks'.
eg.
optical_mgmt#sh ip route
<snip>
Gateway of last resort is 192.168.3.1 to network 0.0.0.0
C 1.0.0.0/8 is directly connected, Ethernet0
C 192.168.204.0/24 is directly connected, Ethernet0
C 192.168.3.0/24 is directly connected, FastEthernet0
S* 0.0.0.0/0 [1/0] via 192.168.3.1
Chris.
**********************
Chris Andrew, CCNA, CCSA
chris@iproute.co.uk
**********************
IProute...we do realise that.What we are saying is that if it is not working like it should (Which it apparently is not working) then trying out the methods explained may help.
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.