Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Routing across VPN

Status
Not open for further replies.

sfortner

Programmer
Nov 22, 2002
17
US
I have two physical networks, the main office and a remote office. The subnet of the remote office is 10.3.0.0/16. The main office has two logical networks, 10.2.0.0/16 and 10.13.0.0/16. There is a Win2K router(10.2.10.2/10.13.10.2) in between 10.2 and 10.13. I have a Pix506 in each office. There is a VPN setup between the 10.3 (remote) and 10.2 (main). Everything routes properly between 10.3 and 10.2. How can I setup 10.3 (remote) to forward packets destined for 10.13 over the VPN to the Win2k router (10.2.10.2)? THanks.
 
On the remote office Pix:
route outside 10.13.0.0 255.255.0.0 <pub_ip_of_home>

Of course, this communication must also be added to the nat 0 and crypto ACLs.

If you use PDM to set up the VPN, I think this is all done for you. At least, I'm pretty sure the route is.
 
On the remote side...
nat includes:
nat (inside) 0 access-list IpsecVpn

IpsecVpn includes:
access-list IpsecVpn line 3 permit ip 10.3.0.0 255.255.0.0 10.13.0.0 255.255.0.0

the access-list for the Internal interface includes:
access-list Internal line 31 permit ip any 10.13.0.0 255.255.0.0

route includes (I tried each one of these separately with the same result):
route outside 10.13.0.0 255.255.0.0 <public ip of main router> 1
route outside 10.13.0.0 255.255.0.0 <Internal ip of main router> 1
route outside 10.13.0.0 255.255.0.0 10.2.10.2 1

When I do tracert I am getting Request timed out across the board. The IpsecVpn access-list is showing lots of hitcnt, as well as the Internal access-list.

What should I do now to continue troubleshooting this?

 
In addition you need

access-list IpsecVpn line 3 permit ip 10.3.0.0 255.255.0.0 10.2.0.0 255.255.0.0


If that doesnt work you can paste both configs and I can sort it out for you.
 
That line is already in there as well, part of the original config. Here are the two configurations:

Pix at main:

PixCorp2# show run
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password vzKnnetrhuuUwlob encrypted
passwd vzKnnetrhuuUwlob encrypted
hostname PixCorp2
domain-name cibtcorp.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list IpsecVpnHo permit ip 10.2.0.0 255.255.0.0 10.3.0.0 255.255.0.0
access-list Internal remark Houston
access-list Internal permit ip any 10.3.0.0 255.255.0.0
access-list Internal permit icmp any any
access-list Internal permit tcp host 10.2.10.11 any eq smtp
access-list Internal permit udp host 10.2.10.11 any eq domain
access-list Internal permit udp host 10.2.10.5 any eq domain
access-list Internal permit tcp host 10.2.10.5 any eq smtp
access-list Internal permit tcp host 10.2.10.5 any eq www
access-list Internal permit tcp host 10.2.10.5 any eq https
access-list External permit icmp any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 66.166.46.227 255.255.255.248
ip address inside 10.2.1.3 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.0.0.0 255.0.0.0 inside
pdm location 192.0.0.0 255.0.0.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list IpsecVpnHo
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group External in interface outside
access-group Internal in interface inside
route outside 0.0.0.0 0.0.0.0 66.166.46.225 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
fragment chain 1
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map VpnMap 20 ipsec-isakmp
crypto map VpnMap 20 match address IpsecVpnHo
crypto map VpnMap 20 set peer 68.165.147.210
crypto map VpnMap 20 set transform-set strong
crypto map VpnMap interface outside
isakmp enable outside
isakmp key ******** address 68.165.147.210 netmask 255.255.255.255
isakmp identity address
isakmp keepalive 10 3
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:13206b84d9f2a43bef5e4c3d35a08c7f
: end

Pix at remote:
PixHo# show run
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password vzKnnetrhuuUwlob encrypted
passwd vzKnnetrhuuUwlob encrypted
hostname PixHo
domain-name cibtcorp.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list IpsecVpn remark Corporate
access-list IpsecVpn permit ip 10.3.0.0 255.255.0.0 10.2.0.0 255.255.0.0
access-list IpsecVpn permit ip 10.3.0.0 255.255.0.0 10.13.0.0 255.255.0.0
access-list Internal remark DNS
access-list Internal permit udp any host 64.105.113.138 eq domain
access-list Internal permit udp any host 64.105.97.90 eq domain
access-list Internal permit icmp any any
access-list Internal remark Allow Traffic HO->Corp
access-list Internal permit ip any 10.2.0.0 255.255.0.0
access-list Internal remark UPS
access-list Internal permit tcp any host 153.2.224.40 eq https
access-list Internal permit tcp any host 153.2.224.40 eq www
access-list Internal permit tcp any host 153.2.224.60 eq https
access-list Internal permit tcp any host 153.2.224.60 eq www
access-list Internal remark FedEx
access-list Internal permit tcp any host 199.81.204.50 eq https
access-list Internal permit tcp any host 199.81.204.50 eq www
access-list Internal permit tcp any host 199.81.203.50 eq https
access-list Internal permit tcp any host 199.81.203.50 eq www
access-list Internal permit tcp any host 199.81.205.50 eq www
access-list Internal permit tcp any host 199.81.205.50 eq https
access-list Internal remark Full Access Clients
access-list Internal permit tcp 10.3.39.0 255.255.255.0 any eq https
access-list Internal permit tcp 10.3.39.0 255.255.255.0 any eq www
access-list Internal remark FedEx
access-list Internal permit tcp any host 205.161.5.69 eq www
access-list Internal permit tcp any host 205.161.5.69 eq https
access-list Internal remark UPS
access-list Internal permit tcp any host 153.2.224.50 eq www
access-list Internal permit tcp any host 153.2.224.50 eq https
access-list Internal permit tcp any host 153.2.228.55 eq www
access-list Internal permit tcp any host 153.2.228.55 eq https
access-list Internal permit tcp 10.3.10.0 255.255.255.0 any eq ftp
access-list Internal permit ip any 10.13.0.0 255.255.0.0
access-list External permit icmp any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 68.165.147.210 255.255.255.248
ip address inside 10.3.1.2 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.0.0.0 255.0.0.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list IpsecVpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group External in interface outside
access-group Internal in interface inside
route outside 0.0.0.0 0.0.0.0 68.165.147.209 1
route outside 10.13.0.0 255.255.0.0 10.2.1.3 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
fragment chain 1
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map VpnMap 20 ipsec-isakmp
crypto map VpnMap 20 match address IpsecVpn
crypto map VpnMap 20 set peer 66.166.46.227
crypto map VpnMap 20 set transform-set strong
crypto map VpnMap interface outside
isakmp enable outside
isakmp key ******** address 66.166.46.227 netmask 255.255.255.255
isakmp identity address
isakmp keepalive 10 3
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:79b0b4797d42f2005a06e0610f8f1dbe
: end

Thanks.
 
I see that acl IPSecVPN allows the remote to talk to both networks at home. But, only one of the home networks is in IPSecVPNHo. Try adding (on the main office Pix):

access-list IpsecVpnHo permit ip 10.13.0.0 255.255.0.0 10.3.0.0 255.255.0.0

Most likely, remote can talk to home but home can't talk back.

Also, a general suggestion that I see a lot is to use separate ACLs for the crypto and nat 0 entries. This has nothing to do with your current issue, but if you ever forsee adding another site it helps a lot if you already have a single nat 0 acl and separate crypto acls.
 
Ok, got it. The piece that was missing was the following route statement on the 10.2 router:

route inside 10.13.0.0 255.255.0.0 10.2.10.2

I guess it makes since in hindsight. The main router was getting packets, but didn't know where to send them.

Thanks for your help.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top