Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Router Rip Problems

Status
Not open for further replies.

BudT

IS-IT--Management
Nov 14, 2000
87
0
0
US
I am trying to add rip to my Cisco 2501 I am configuring for our new Chicago office, but everytime I try to add the router rip network information for a class C's ir gives me calls A's. Example:

conf term
router rip
network 38.244.61.0
network 38.181.98.0
end
write

Now when I show configuration router rip has the network 38.0.0.0. What is going on here and why is it doing this? Many thanks to those who respond.

Here is the configuration file:

Using 1468 out of 32762 bytes
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname AspenChicago
!
enable password $%^&#
!
ip subnet-zero
no ip domain-lookup
appletalk routing
!
!
interface Ethernet0
description Standard Ethernet Interface
ip address 38.24.61.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
appletalk cable-range 9000-9099 9000.154
appletalk zone Aspen Chicago
no mop enabled
!
interface Serial0
description 512KB Frame Relay to Washington D.C.
ip address 38.181.98.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
bandwidth 512
appletalk cable-range 3-3 3.10
frame-relay map appletalk 3.2 220 broadcast
frame-relay lmi-type ansi
!
interface Serial1
description Not Currently Used
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
no keepalive
shutdown
!
router rip
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 206.0.100.2
ip route 38.0.0.0 255.0.0.0 206.0.100.2
ip route 38.244.58.0 255.255.255.0 206.0.101.250
ip route 38.244.59.0 255.255.255.0 206.0.101.250
ip route 38.244.60.0 255.255.255.0 206.0.101.250
ip route 206.0.100.0 255.255.255.0 Serial0
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
login
!
end
 
Make sure you use RIP II to get the classless routing.. if I remember RIP correctly, RIP I is a classful ONLY protocol. Hence, you get the class A only.. not the real subnet you want.

Here is the link for a good paper from Cisco about RIP


Mike S
"Diplomacy; the art of saying 'nice doggie' till you can find a rock" Wynn Catlin
 
Yes, you are using RIP version 1, and must switch to RIP version 2 if you want to use classless routing [as your explanation has stated]

The subnet mask for Classful routing always ends cleanly.
I.E.
255.0.0.0 for A
255.255.0.0 for B
255.255.255.0 for C

Classless routing looks as this example
255.224.0.0
--or--
255.255.240.0
--or--
some other "variable subnet mask"
RIP version 1 does not understand variable subnet mask"

But before switching to RIP version 2, make sure the router at both ends will talk the same version, else you aren't going to talk at all via RIP

Here's 1 way to verify which verion of RIP you are running
show running-config [sh run]
drop down to almost the bottom of the configuration and look for:

Router RIP


Here you will see the line ver 2, else you are ruinning ver 1.
You can also verify via "debug rip" and [ter mon if telnetted in], and watch the updates in real time. If one router is running ver 1 and another router is running ver 2, you will see ignore rip update messages!!

Cheers
Frank
 
I set up router rip to use version 2 and also set the interface to use both version 1 and 2. But still it sets network 38.244.61.0 to 38.0.0.0. See configuration file below. Any help grestly appreciated.

show configuration
Using 1550 out of 32762 bytes
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname AspenChicago
!
enable secret 5 %^%^%$#
enable password @))M^&%$
!
ip subnet-zero
no ip domain-lookup
appletalk routing
!
!
interface Ethernet0
description Standard Ethernet Interface
ip address 38.24.61.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
appletalk cable-range 9000-9099 9000.154
appletalk zone Aspen Chicago
no mop enabled
!
interface Serial0
description 512KB Frame Relay to Washington D.C.
ip address 38.181.98.2 255.255.255.0
no ip directed-broadcast
ip rip send version 1 2
ip rip receive version 1 2
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
bandwidth 512
appletalk cable-range 3-3 3.10
frame-relay map appletalk 3.2 220 broadcast
frame-relay lmi-type ansi
!
interface Serial1
description Not Currently Used
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
no keepalive
shutdown
!
router rip
version 2
network 38.0.0.0
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 206.0.100.2
ip route 38.0.0.0 255.0.0.0 206.0.100.2
ip route 38.244.58.0 255.255.255.0 206.0.101.250
ip route 38.244.59.0 255.255.255.0 206.0.101.250
ip route 38.244.60.0 255.255.255.0 206.0.101.250
ip route 206.0.100.0 255.255.255.0 Serial0
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
password @))M^^&^%$
login
!
end
 
What does the command DEBUG IP RIP display? [ter mon]
Frank
 
do away with rip and run EIGRP I find that this works better
for me using frame relay. #-) Jeter@LasVegas.com The best answer I could ever give is the one to maintain my Sanity
 
It seems that you have made all the entries as static routes. It will not show you the static routes under the RIP routes. If want use Redistribute command.
-bhandari
 
I think there is some confusion, here. Hopefully it isn't mine.

What I see being asked is, "Why, when I show the config, is the network entry 38.0.0.0?" But what I think people are answering is, "Why, when I show ip route, is the network entry 38.0.0.0?"

Two totally different things.

The way Cisco routers work, network statements will always be at the class boundary. This is independent of the routing protocol used.

Even with RIP 1, if you have addressed your interfaces as /24, you will see those subnetted routes if you do a "show ip route" command. You just won't see any subnets that have a different length mask unless you switch to RIP version 2.

Obviously this applies only to routes learned by RIP. You can learn different subnet masks through different protocols or statically.

--chris
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top