Howdy All! I'm in the process of replacing our current core router (Cisco 2501) with a newer, better (I hope) unit. I'm guessing our config is fairly straightforward (looks like it to me) but I was hoping someone could point out any gotcha's I might run into. Here's the old config:
!
version 11.1
service slave-log
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname *******
!
clock timezone EST -5
enable password 7 ******
!
ip subnet-zero
ip domain-list ******
ip domain-list ******
ip dhcp-server 10.1.1.50
ip dhcp-server 10.1.1.17
!
stun peer-name 10.4.0.1
stun protocol-group 9 basic
location *******
!
interface Loopback0
ip address 10.4.0.1 255.255.0.0
!
interface Ethernet0
ip address 10.1.1.110 255.255.0.0
ip helper-address 10.1.1.50
ip helper-address 10.1.1.17
no ip mroute-cache
no ip route-cache
!
interface Serial0
description ******* point-to-point T1 CH 1-23
ip address 10.2.1.110 255.255.0.0
ip helper-address 10.1.1.50
ip helper-address 10.1.1.17
no ip mroute-cache
no ip route-cache
!
router rip
network 10.0.0.0
!
ip host ******* 10.3.1.110
ip domain-name ********
ip name-server 10.1.1.26
ip name-server 10.1.1.27
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.120
ip route 10.3.0.0 255.255.0.0 10.2.1.111
ip route 10.9.0.0 255.255.0.0 10.1.1.120
ip route 10.20.0.0 255.255.0.0 10.1.1.120
ip route 10.30.0.0 255.255.0.0 10.1.1.120
ip http server
logging console critical
logging trap notifications
logging 10.1.1.40
!
snmp-server community public RO
snmp-server chassis-id 02112359-****** 2501
banner motd
This is an official computer system of *******. It is for authorized users only. Unauthorized users are prohibited. Users (authorized or unauthorized) have no explicit or implicit expectation of privacy.
!
line con 0
password 7 ********
login
line aux 0
transport input all
line vty 0 4
password 7 ********
login
line vty 5 15
password 7 ********
login
I astricked out the "sensitive" information but everything else is the same. As far as what will change with this, the Point to Point T1 on serial 0 will have the Cisco 2501 + DSU/CSU removed on it's end to be replaced with a WAN module in our Avaya G350 Media Gateway device. It will function as the router for that site. Some stuff I have questions about would be the loopback address, should I change it back to the standard or leave it as is? Do I need the "STUN" commands anymore? From what I've read it seems like it won't apply. Thanks for your input!
!
version 11.1
service slave-log
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname *******
!
clock timezone EST -5
enable password 7 ******
!
ip subnet-zero
ip domain-list ******
ip domain-list ******
ip dhcp-server 10.1.1.50
ip dhcp-server 10.1.1.17
!
stun peer-name 10.4.0.1
stun protocol-group 9 basic
location *******
!
interface Loopback0
ip address 10.4.0.1 255.255.0.0
!
interface Ethernet0
ip address 10.1.1.110 255.255.0.0
ip helper-address 10.1.1.50
ip helper-address 10.1.1.17
no ip mroute-cache
no ip route-cache
!
interface Serial0
description ******* point-to-point T1 CH 1-23
ip address 10.2.1.110 255.255.0.0
ip helper-address 10.1.1.50
ip helper-address 10.1.1.17
no ip mroute-cache
no ip route-cache
!
router rip
network 10.0.0.0
!
ip host ******* 10.3.1.110
ip domain-name ********
ip name-server 10.1.1.26
ip name-server 10.1.1.27
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.120
ip route 10.3.0.0 255.255.0.0 10.2.1.111
ip route 10.9.0.0 255.255.0.0 10.1.1.120
ip route 10.20.0.0 255.255.0.0 10.1.1.120
ip route 10.30.0.0 255.255.0.0 10.1.1.120
ip http server
logging console critical
logging trap notifications
logging 10.1.1.40
!
snmp-server community public RO
snmp-server chassis-id 02112359-****** 2501
banner motd
This is an official computer system of *******. It is for authorized users only. Unauthorized users are prohibited. Users (authorized or unauthorized) have no explicit or implicit expectation of privacy.
!
line con 0
password 7 ********
login
line aux 0
transport input all
line vty 0 4
password 7 ********
login
line vty 5 15
password 7 ********
login
I astricked out the "sensitive" information but everything else is the same. As far as what will change with this, the Point to Point T1 on serial 0 will have the Cisco 2501 + DSU/CSU removed on it's end to be replaced with a WAN module in our Avaya G350 Media Gateway device. It will function as the router for that site. Some stuff I have questions about would be the loopback address, should I change it back to the standard or leave it as is? Do I need the "STUN" commands anymore? From what I've read it seems like it won't apply. Thanks for your input!