The problem I am having is that I can't ping from the router to the switch or vise versa. Just need some advise what I may be doing wrong here.
Switch 3500 Series
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
ip subnet-zero
vtp file server
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
switchport access vlan 10
!
interface FastEthernet0/6
switchport access vlan 10
!
interface FastEthernet0/7
switchport access vlan 20
!
interface FastEthernet0/8
switchport access vlan 20
!
interface FastEthernet0/9
switchport access vlan 20
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.1.1
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
end
Router 2600 Series
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
!
interface Ethernet0/0.1
description default
encapsulation dot1Q 1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
description accounting
encapsulation dot1Q 10
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0.20
description marketing
encapsulation dot1Q 20
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
!
router rip
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
Switch 3500 Series
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
ip subnet-zero
vtp file server
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
switchport access vlan 10
!
interface FastEthernet0/6
switchport access vlan 10
!
interface FastEthernet0/7
switchport access vlan 20
!
interface FastEthernet0/8
switchport access vlan 20
!
interface FastEthernet0/9
switchport access vlan 20
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.1.1
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
end
Router 2600 Series
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
!
interface Ethernet0/0.1
description default
encapsulation dot1Q 1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
description accounting
encapsulation dot1Q 10
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0.20
description marketing
encapsulation dot1Q 20
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
!
router rip
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end