Hello,
I'm trying to allow RDP access through my PIX to a server. I've done this many times (add ACL and static map) but for some reason I cannot get access through this particular PIX. The difference between the ones that work and this one is that with this one I have a VPN site-to-site between locations whereas the ones that work do not. Any assistance would be greatly appreciated.
PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password w65RXk0Y4imVbQ8i encrypted
passwd TY3hwE1RIOYpJzgO encrypted
hostname NYREMOTE
domain-name remote.domain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any unreachable
access-list 110 permit ip 192.168.50.64 255.255.255.192 192.168.50.0 255.255.255.192
access-list 130 permit ip 192.168.50.64 255.255.255.192 192.168.50.128 255.255.255.192
access-list 140 permit ip 192.168.50.64 255.255.255.192 192.168.50.192 255.255.255.192
access-list 101 permit ip 192.168.50.64 255.255.255.192 192.168.50.0 255.255.255.192
access-list 101 permit ip 192.168.50.64 255.255.255.192 192.168.50.128 255.255.255.192
access-list 101 permit ip 192.168.50.64 255.255.255.192 192.168.50.192 255.255.255.192
access-list 101 permit tcp any host 168.xx.xx.33 eq 3389
pager lines 24
logging on
logging buffered errors
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 168.xx.xx.29 255.255.255.248
ip address inside 192.168.50.65 255.255.255.192
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 192.168.50.64 255.255.255.192 0 0
static (inside,outside) 168.xx.xx.33 192.168.50.70 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 168.xx.xx.25 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set firstset esp-des esp-md5-hmac
crypto ipsec transform-set esp-des-md5 esp-des esp-md5-hmac
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 110
crypto map newmap 10 set peer 209.xx.xx.xx
crypto map newmap 10 set transform-set firstset
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 209.xx.xx.xx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 3600
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 14400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 10
management-access inside
console timeout 0
terminal width 80
Cryptochecksum:914bb8f06a3efc50cd498183c43805c1
: end
I'm trying to allow RDP access through my PIX to a server. I've done this many times (add ACL and static map) but for some reason I cannot get access through this particular PIX. The difference between the ones that work and this one is that with this one I have a VPN site-to-site between locations whereas the ones that work do not. Any assistance would be greatly appreciated.
PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password w65RXk0Y4imVbQ8i encrypted
passwd TY3hwE1RIOYpJzgO encrypted
hostname NYREMOTE
domain-name remote.domain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any unreachable
access-list 110 permit ip 192.168.50.64 255.255.255.192 192.168.50.0 255.255.255.192
access-list 130 permit ip 192.168.50.64 255.255.255.192 192.168.50.128 255.255.255.192
access-list 140 permit ip 192.168.50.64 255.255.255.192 192.168.50.192 255.255.255.192
access-list 101 permit ip 192.168.50.64 255.255.255.192 192.168.50.0 255.255.255.192
access-list 101 permit ip 192.168.50.64 255.255.255.192 192.168.50.128 255.255.255.192
access-list 101 permit ip 192.168.50.64 255.255.255.192 192.168.50.192 255.255.255.192
access-list 101 permit tcp any host 168.xx.xx.33 eq 3389
pager lines 24
logging on
logging buffered errors
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 168.xx.xx.29 255.255.255.248
ip address inside 192.168.50.65 255.255.255.192
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 192.168.50.64 255.255.255.192 0 0
static (inside,outside) 168.xx.xx.33 192.168.50.70 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 168.xx.xx.25 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set firstset esp-des esp-md5-hmac
crypto ipsec transform-set esp-des-md5 esp-des esp-md5-hmac
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 110
crypto map newmap 10 set peer 209.xx.xx.xx
crypto map newmap 10 set transform-set firstset
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 209.xx.xx.xx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 3600
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 14400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 10
management-access inside
console timeout 0
terminal width 80
Cryptochecksum:914bb8f06a3efc50cd498183c43805c1
: end