lrittenhouse
Technical User
Hi All,
I need help with QOS on an ADSL router. I've tried all kinds of techniques from basic PQ to LLQ. I get mixed results with each method I try. None of them worked the way I hoped. I think the problem has to do with the MLP bundling but I'm not too sure of that. I’m running a cisco 827 ,PPPOE with static addresses /29 subnet. Connected to E0 is a cisco 7960 IP phone and a fortinet 60 firewall. The DSL is a 1.5 down with 256 up. The phone is using g.729 and I want to be able to control the upstream bandwidth better. The current config works ok but I can get the voice to breakup a little. I’ll include two of the configs that sort of work and other pertinent info. Thank you for any help you can offer.
Larry
Building configuration...
Current configuration : 2062 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging queue-limit 100
enable password 7 xxxxxxxxxxxxxx
!
username xxxxxxxxxxxx password 7 xxxxxxxxxxx
ip subnet-zero
ip name-server xxxxxxxxxxxxxx
ip name-server xxxxxxxxxxxxxx
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
class-map match-all VOIP-CONTROL
match access-group 182
class-map match-all VOIP-RTP
match access-group 181
!
!
policy-map QOS-Policy-zion
class VOIP-RTP
priority 128
class VOIP-CONTROL
bandwidth 56
class class-default
fair-queue
!
!
!
!
interface Ethernet0
ip address xxx.xxx.xxx.xxx 255.255.255.248
ip tcp adjust-mss 1452
!
interface ATM0
no ip address
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Dialer1
bandwidth 288
ip unnumbered Ethernet0
service-policy output QOS-Policy-zion
encapsulation ppp
no ip mroute-cache
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxx
00008
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
ip rtp header-compression iphc-format
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
access-list 181 permit udp any any range 16384 32767
access-list 182 permit tcp any any range 2000 2002
access-list 182 permit tcp any any eq 1720
access-list 182 permit tcp any any range 11000 11999
access-list 182 permit tcp any any eq 2427
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 120 0
login local
length 0
!
scheduler max-task-time 5000
!
end
Current configuration : 2622 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging queue-limit 100
enable password 7 xxxxxxxxxxxx
!
username xxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxx
ip subnet-zero
ip name-server x
ip name-server x
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
!
!
!
!
!
!
class-map match-all INTERNET
match access-group 180
class-map match-all VOIP-CONTROL
match access-group 182
class-map match-all VOIP-RTP
match access-group 181
!
!
policy-map QOS-Policy-zion
class VOIP-RTP
priority 128
class VOIP-CONTROL
bandwidth 56
class INTERNET
class class-default
fair-queue
policy-map shape
class class-default
service-policy QOS-Policy-zion
!
!
!
!
interface Ethernet0
ip address xxxxxx
ip tcp adjust-mss 1452
ip policy route-map Set-IP-Qos
hold-queue 100 out
!
interface ATM0
no ip address
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Dialer1
bandwidth 288
ip unnumbered Ethernet0
ip mtu 1492
service-policy output QOS-Policy-zion
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxx password 7 xxxxxxxx
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
access-list 171 permit tcp any any eq 1720
access-list 171 permit tcp any any range 11000 11999
access-list 171 permit tcp any any eq 2427
access-list 172 permit udp any any range 16384 32767
access-list 173 permit ip any any
access-list 180 permit ip any any
access-list 181 permit ip any any precedence critical
access-list 181 permit ip any any dscp ef
access-list 182 permit ip any any precedence flash
access-list 182 permit ip any any dscp af31
dialer-list 1 protocol ip permit
!
route-map Set-IP-QOS permit 10
match ip address 171
set ip precedence flash
!
route-map Set-IP-QOS permit 20
match ip address 172
!
route-map Set-IP-QOS permit 30
match ip address 173
set ip precedence routine
!
call rsvp-sync
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 120 0
login local
length 0
!
scheduler max-task-time 5000
!
end
==========================================================
Cisco Internetwork Operating System Software
IOS (tm) C820 Software (C820-K9OSV6Y6-M), Version 12.2(13)ZH, EARLY DEPLOYMENT R
ELEASE SOFTWARE (fc1)
Synched to technology version 12.2(14.5)T
TAC Support: Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 24-Apr-03 21:15 by ealyon
Image text-base: 0x800131C0, data-base: 0x80E701BC
ROM: System Bootstrap, Version 12.2(4r)XM2, RELEASE SOFTWARE (fc1)
ROM: C820 Software (C820-K9OSV6Y6-M), Version 12.2(13)ZH, EARLY DEPLOYMENT RELEA
SE SOFTWARE (fc1)
Router uptime is 22 hours, 18 minutes
System returned to ROM by power-on
System image file is "flash:c820-k9osv6y6-mz.122-13.ZH.bin"
CISCO C827-4V (MPC855T) processor (revision 0x501) with 48128K/1024K bytes of me
mory.
Processor board ID JAD041402XE (2542320182), with hardware revision 1987
CPU rev number 5
Bridging software.
4 POTS Ports
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)
Configuration register is 0x2102
sh dsl interface a0
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.1 (G.DMT)
ITU STD NUM: 0x01 0x01
Vendor ID: 'ALCB' 'ALCB'
Vendor Specific: 0x0000 0x0000
Vendor Country: 0x00 0x0F
Capacity Used: 77% 29%
Noise Margin: 11.0 dB 19.0 dB
Output Power: 18.0 dBm 2.5 dBm
Attenuation: 61.5 dB 31.5 dB
Defect Status: None None
Last Fail Code: None
Selftest Result: 0x00
Subfunction: 0x02
Interrupts: 646 (1 spurious)
Activations: 1
Init FW: embedded
Operartion FW: embedded
SW Version: 3.9.19
FW Version: 0x1A04
Interleave Fast Interleave Fast
Speed (kbps): 1536 0 160 0
Reed-Solomon EC: 1175 0 4 0
CRC Errors: 2 0 0 0
Header Errors: 1 0 0 0
Bit Errors: 0 0
BER Valid sec: 0 0
BER Invalid sec: 0 0
LOM Monitoring : Disabled
DMT Bits Per Bin
00: 0 0 0 0 0 0 0 0 2 2 4 4 4 4 4 4
10: 4 4 4 4 4 4 3 4 3 2 2 3 2 0 0 0
20: 0 0 0 0 0 0 2 2 3 4 4 4 4 4 2 3
30: 5 5 6 6 6 6 6 6 6 6 6 6 6 6 6 5
40: 5 5 5 4 3 0 0 4 5 5 6 6 6 6 6 6
50: 6 6 7 2 7 7 6 6 6 6 6 6 4 2 5 6
60: 6 6 6 6 6 6 6 6 5 5 5 5 5 5 5 5
70: 5 5 5 5 3 5 4 4 4 4 4 4 4 4 4 4
80: 4 3 2 3 3 3 3 2 2 0 2 2 2 2 2 0
90: 0 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0
A0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
B0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
Training log buffer capability is not enabled yet.
I need help with QOS on an ADSL router. I've tried all kinds of techniques from basic PQ to LLQ. I get mixed results with each method I try. None of them worked the way I hoped. I think the problem has to do with the MLP bundling but I'm not too sure of that. I’m running a cisco 827 ,PPPOE with static addresses /29 subnet. Connected to E0 is a cisco 7960 IP phone and a fortinet 60 firewall. The DSL is a 1.5 down with 256 up. The phone is using g.729 and I want to be able to control the upstream bandwidth better. The current config works ok but I can get the voice to breakup a little. I’ll include two of the configs that sort of work and other pertinent info. Thank you for any help you can offer.
Larry
Building configuration...
Current configuration : 2062 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging queue-limit 100
enable password 7 xxxxxxxxxxxxxx
!
username xxxxxxxxxxxx password 7 xxxxxxxxxxx
ip subnet-zero
ip name-server xxxxxxxxxxxxxx
ip name-server xxxxxxxxxxxxxx
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
class-map match-all VOIP-CONTROL
match access-group 182
class-map match-all VOIP-RTP
match access-group 181
!
!
policy-map QOS-Policy-zion
class VOIP-RTP
priority 128
class VOIP-CONTROL
bandwidth 56
class class-default
fair-queue
!
!
!
!
interface Ethernet0
ip address xxx.xxx.xxx.xxx 255.255.255.248
ip tcp adjust-mss 1452
!
interface ATM0
no ip address
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Dialer1
bandwidth 288
ip unnumbered Ethernet0
service-policy output QOS-Policy-zion
encapsulation ppp
no ip mroute-cache
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxx
00008
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
ip rtp header-compression iphc-format
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
access-list 181 permit udp any any range 16384 32767
access-list 182 permit tcp any any range 2000 2002
access-list 182 permit tcp any any eq 1720
access-list 182 permit tcp any any range 11000 11999
access-list 182 permit tcp any any eq 2427
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 120 0
login local
length 0
!
scheduler max-task-time 5000
!
end
Current configuration : 2622 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging queue-limit 100
enable password 7 xxxxxxxxxxxx
!
username xxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxx
ip subnet-zero
ip name-server x
ip name-server x
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
!
!
!
!
!
!
class-map match-all INTERNET
match access-group 180
class-map match-all VOIP-CONTROL
match access-group 182
class-map match-all VOIP-RTP
match access-group 181
!
!
policy-map QOS-Policy-zion
class VOIP-RTP
priority 128
class VOIP-CONTROL
bandwidth 56
class INTERNET
class class-default
fair-queue
policy-map shape
class class-default
service-policy QOS-Policy-zion
!
!
!
!
interface Ethernet0
ip address xxxxxx
ip tcp adjust-mss 1452
ip policy route-map Set-IP-Qos
hold-queue 100 out
!
interface ATM0
no ip address
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Dialer1
bandwidth 288
ip unnumbered Ethernet0
ip mtu 1492
service-policy output QOS-Policy-zion
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxx password 7 xxxxxxxx
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
access-list 171 permit tcp any any eq 1720
access-list 171 permit tcp any any range 11000 11999
access-list 171 permit tcp any any eq 2427
access-list 172 permit udp any any range 16384 32767
access-list 173 permit ip any any
access-list 180 permit ip any any
access-list 181 permit ip any any precedence critical
access-list 181 permit ip any any dscp ef
access-list 182 permit ip any any precedence flash
access-list 182 permit ip any any dscp af31
dialer-list 1 protocol ip permit
!
route-map Set-IP-QOS permit 10
match ip address 171
set ip precedence flash
!
route-map Set-IP-QOS permit 20
match ip address 172
!
route-map Set-IP-QOS permit 30
match ip address 173
set ip precedence routine
!
call rsvp-sync
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 120 0
login local
length 0
!
scheduler max-task-time 5000
!
end
==========================================================
Cisco Internetwork Operating System Software
IOS (tm) C820 Software (C820-K9OSV6Y6-M), Version 12.2(13)ZH, EARLY DEPLOYMENT R
ELEASE SOFTWARE (fc1)
Synched to technology version 12.2(14.5)T
TAC Support: Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 24-Apr-03 21:15 by ealyon
Image text-base: 0x800131C0, data-base: 0x80E701BC
ROM: System Bootstrap, Version 12.2(4r)XM2, RELEASE SOFTWARE (fc1)
ROM: C820 Software (C820-K9OSV6Y6-M), Version 12.2(13)ZH, EARLY DEPLOYMENT RELEA
SE SOFTWARE (fc1)
Router uptime is 22 hours, 18 minutes
System returned to ROM by power-on
System image file is "flash:c820-k9osv6y6-mz.122-13.ZH.bin"
CISCO C827-4V (MPC855T) processor (revision 0x501) with 48128K/1024K bytes of me
mory.
Processor board ID JAD041402XE (2542320182), with hardware revision 1987
CPU rev number 5
Bridging software.
4 POTS Ports
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)
Configuration register is 0x2102
sh dsl interface a0
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.1 (G.DMT)
ITU STD NUM: 0x01 0x01
Vendor ID: 'ALCB' 'ALCB'
Vendor Specific: 0x0000 0x0000
Vendor Country: 0x00 0x0F
Capacity Used: 77% 29%
Noise Margin: 11.0 dB 19.0 dB
Output Power: 18.0 dBm 2.5 dBm
Attenuation: 61.5 dB 31.5 dB
Defect Status: None None
Last Fail Code: None
Selftest Result: 0x00
Subfunction: 0x02
Interrupts: 646 (1 spurious)
Activations: 1
Init FW: embedded
Operartion FW: embedded
SW Version: 3.9.19
FW Version: 0x1A04
Interleave Fast Interleave Fast
Speed (kbps): 1536 0 160 0
Reed-Solomon EC: 1175 0 4 0
CRC Errors: 2 0 0 0
Header Errors: 1 0 0 0
Bit Errors: 0 0
BER Valid sec: 0 0
BER Invalid sec: 0 0
LOM Monitoring : Disabled
DMT Bits Per Bin
00: 0 0 0 0 0 0 0 0 2 2 4 4 4 4 4 4
10: 4 4 4 4 4 4 3 4 3 2 2 3 2 0 0 0
20: 0 0 0 0 0 0 2 2 3 4 4 4 4 4 2 3
30: 5 5 6 6 6 6 6 6 6 6 6 6 6 6 6 5
40: 5 5 5 4 3 0 0 4 5 5 6 6 6 6 6 6
50: 6 6 7 2 7 7 6 6 6 6 6 6 4 2 5 6
60: 6 6 6 6 6 6 6 6 5 5 5 5 5 5 5 5
70: 5 5 5 5 3 5 4 4 4 4 4 4 4 4 4 4
80: 4 3 2 3 3 3 3 2 2 0 2 2 2 2 2 0
90: 0 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0
A0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
B0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
Training log buffer capability is not enabled yet.