I am running a 2650xm with 4 DSL lines. the first 2 are working, and the last 2 won't create virtual-accesses for the atm ports.
The CD lights on the second 2 never go solid. the first 2 stay solid. I have checked the lines with modem and they sync up correctly.
Here is my config:
Building configuration...
Current configuration : 4420 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DSLrouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$u1GD$Vvb7Nx39z.8UocLY0lD9d.
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
!
!
!
!
!
!
!
interface ATM0/0
no ip address
no ip redirects
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0/0
ip address 192.168.107.5 255.255.255.0
no ip redirects
no ip proxy-arp
ip nat inside
speed 100
full-duplex
!
interface ATM0/1
no ip address
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/1.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 2
!
!
interface ATM1/0
no ip address
no ip redirects
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM1/0.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 3
!
!
interface ATM1/1
no ip address
no ip redirects
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM1/1.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 4
!
!
interface Dialer0
ip address xxx.xxx.xx.xx0 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxxx
ppp pap sent-username xxxxx password 0 xxxxx
!
interface Dialer1
ip address xxx.xxx.xx.xx1 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 2
dialer idle-timeout 0
dialer persistent
dialer-group 2
ppp authentication chap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxxxx
ppp pap sent-username xxxxxx password 0 xxxx
!
interface Dialer2
ip address xxx.xxx.xxx.xx2 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 3
dialer idle-timeout 0
dialer persistent
dialer-group 3
ppp authentication chap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxxx
ppp pap sent-username xxxxxx password 0 xxxxxx
!
interface Dialer3
ip address xxx.xxx.xxx.xx3 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 4
dialer idle-timeout 0
dialer persistent
dialer-group 4
ppp authentication chap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxx
ppp pap sent-username xxxxx password 0 xxxx
!
ip default-gateway xxx.xxx.xxx.3
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer3
ip route xxx.xxx.0.0 255.255.0.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
!
ip http server
no ip http secure-server
ip nat pool dsl0 xxx.xxx.xxx.xx0 xxx.xxx.xx.xx0 netmask 255.255.255.0
ip nat pool dsl1 xxx.xxx.xx.x1 xxx.xxx.xx.xx1 netmask 255.255.255.0
ip nat pool dsl2 xxx.xxx.xxx.xx2 xxx.xxx.xxx.xx2 netmask 255.255.255.0
ip nat pool dsl3 xxx.xxx.xxx.xx3 xxx.xxx.xxx.xx3 netmask 255.255.255.0
ip nat inside source route-map dsl0 pool dsl0 overload
ip nat inside source route-map dsl1 pool dsl1 overload
ip nat inside source route-map dsl2 pool dsl2 overload
ip nat inside source route-map dsl3 pool dsl3 overload
!
access-list 1 permit xxx.xxx.xxx.0 0.0.0.255
access-list 1 permit any
access-list 2 permit any
access-list 3 permit any
access-list 4 permit any
route-map dsl3 permit 10
match ip address 4
match interface Dialer3
!
route-map dsl2 permit 10
match ip address 3
match interface Dialer2
!
route-map dsl1 permit 10
match ip address 2
match interface Dialer1
!
route-map dsl0 permit 10
match ip address 1
match interface Dialer0
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxx
login
Thanks Tommy
The CD lights on the second 2 never go solid. the first 2 stay solid. I have checked the lines with modem and they sync up correctly.
Here is my config:
Building configuration...
Current configuration : 4420 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DSLrouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$u1GD$Vvb7Nx39z.8UocLY0lD9d.
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
!
!
!
!
!
!
!
interface ATM0/0
no ip address
no ip redirects
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0/0
ip address 192.168.107.5 255.255.255.0
no ip redirects
no ip proxy-arp
ip nat inside
speed 100
full-duplex
!
interface ATM0/1
no ip address
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/1.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 2
!
!
interface ATM1/0
no ip address
no ip redirects
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM1/0.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 3
!
!
interface ATM1/1
no ip address
no ip redirects
ip nat outside
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM1/1.1 point-to-point
pvc 0/35
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 4
!
!
interface Dialer0
ip address xxx.xxx.xx.xx0 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxxx
ppp pap sent-username xxxxx password 0 xxxxx
!
interface Dialer1
ip address xxx.xxx.xx.xx1 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 2
dialer idle-timeout 0
dialer persistent
dialer-group 2
ppp authentication chap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxxxx
ppp pap sent-username xxxxxx password 0 xxxx
!
interface Dialer2
ip address xxx.xxx.xxx.xx2 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 3
dialer idle-timeout 0
dialer persistent
dialer-group 3
ppp authentication chap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxxx
ppp pap sent-username xxxxxx password 0 xxxxxx
!
interface Dialer3
ip address xxx.xxx.xxx.xx3 255.255.255.0
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 4
dialer idle-timeout 0
dialer persistent
dialer-group 4
ppp authentication chap callin
ppp chap hostname xxxxx
ppp chap password 0 xxxx
ppp pap sent-username xxxxx password 0 xxxx
!
ip default-gateway xxx.xxx.xxx.3
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer3
ip route xxx.xxx.0.0 255.255.0.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
ip route xxx.xxx.xxx.0 255.255.255.0 xxx.xxx.xxx.3
!
ip http server
no ip http secure-server
ip nat pool dsl0 xxx.xxx.xxx.xx0 xxx.xxx.xx.xx0 netmask 255.255.255.0
ip nat pool dsl1 xxx.xxx.xx.x1 xxx.xxx.xx.xx1 netmask 255.255.255.0
ip nat pool dsl2 xxx.xxx.xxx.xx2 xxx.xxx.xxx.xx2 netmask 255.255.255.0
ip nat pool dsl3 xxx.xxx.xxx.xx3 xxx.xxx.xxx.xx3 netmask 255.255.255.0
ip nat inside source route-map dsl0 pool dsl0 overload
ip nat inside source route-map dsl1 pool dsl1 overload
ip nat inside source route-map dsl2 pool dsl2 overload
ip nat inside source route-map dsl3 pool dsl3 overload
!
access-list 1 permit xxx.xxx.xxx.0 0.0.0.255
access-list 1 permit any
access-list 2 permit any
access-list 3 permit any
access-list 4 permit any
route-map dsl3 permit 10
match ip address 4
match interface Dialer3
!
route-map dsl2 permit 10
match ip address 3
match interface Dialer2
!
route-map dsl1 permit 10
match ip address 2
match interface Dialer1
!
route-map dsl0 permit 10
match ip address 1
match interface Dialer0
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxx
login
Thanks Tommy