Thanks for showing an interest!
Here's the situation, We have a remote site with a frame relay connection (via ser0) which we want to back up with an isdn backup line using ddr and a dialer profile to the main site.
Here is the config of the router
:version 12.0
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname remoterouter
!
aaa new-model
aaa authentication login default group tacacs+ local
aaa authentication ppp default local
aaa authorization exec default group tacacs+
aaa accounting exec default start-stop group tacacs+
aaa accounting network default start-stop group tacacs+
enable secret 5 xxxxxxxxxxxx
enable password xxxxxxxxxxxxx
!
username master password 7 xxxxxxxxxxxxxxx
username trr004x password 7 xxxxxxxxxxxxx
!
!
clock timezone gmt 0
clock summer-time bst recurring last Sun Mar 2:00 last Sun Oct 2:00
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
isdn tei-negotiation first-call
!
!
interface Loopback0
no ip address
no ip directed-broadcast
!
interface Ethernet0
ip address 10.28.0.1 255.255.252.0
ip helper-address 10.2.44.200
ip helper-address 10.2.16.10
no ip directed-broadcast
keepalive 4
!
interface Serial0
description Frame-Relay Link
bandwidth 64
ip address 10.1.16.2 255.255.252.0
no ip directed-broadcast
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
no fair-queue
frame-relay map ip 10.1.16.1 100 broadcast
frame-relay lmi-type ansi
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
description dial backup link
bandwidth 56
no ip address
no ip directed-broadcast
encapsulation ppp
no ip route-cache
no ip mroute-cache
no keepalive
dialer pool-member 1
isdn switch-type basic-net3
no fair-queue
no cdp enable
!
interface Dialer0
ip address 10.2.176.10 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer remote-name trr004x
dialer pool 1
dialer idle-timeout 90
dialer string 01793848012
dialer-group 1
no fair-queue
no cdp enable
ppp authentication chap
ppp multilink
!
interface Dialer1
no ip address
no ip directed-broadcast
no cdp enable
!
router eigrp 1
network 10.0.0.0
network 144.98.0.0
no auto-summary
!
no ip classless
no ip forward-protocol udp tftp
no ip forward-protocol udp nameserver
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 Dialer0 200
no ip http server
!
logging trap debugging
access-list 101 deny eigrp any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
tacacs-server host 10.2.44.208
tacacs-server host 10.2.44.206
tacacs-server timeout 1000
tacacs-server key cisco
snmp-server engineID local 00000009020000E01E3E7080
snmp-server community public xxxxxxx
!
line con 0
transport input none
line aux 0
password xxxxxxxx
no activation-character
modem InOut
stopbits 1
flowcontrol hardware
line vty 0 4
password xxxxxxx
!
ntp clock-period 17179522
ntp server 144.98.31.172
end
MRR001X#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-P-L), Version 12.0(7)T, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 06-Dec-99 19:39 by phanguye
Image text-base: 0x0303C3D4, data-base: 0x00001000
ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOF)
MRR001X uptime is 22 hours, 16 minutes
System returned to ROM by power-on
System restarted at 15:17:01 bst Wed Jul 24 2002
System image file is "flash:c2500-p-l.120-7.T.bin"
cisco 2500 (68030) processor (revision N) with 6144K/2048K bytes of memory.
Processor board ID 06099777, with hardware revision 00000001
X.25 software, Version 3.0.0.
Basic Rate ISDN software, Version 1.1.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)
Configuration register is 0x2102
One problem is that the dialer interface is not dialing out when I ping an ip address on the main site from the remote site after having shut down the frame relay serial interface (administritively). I have tried pinging directly from the remote router and the dialer interface is not dialing out. The bri interface is working as it brings itself up to connect to the ntp server every couple of minutes (which is another problem).
The floating static default route is shown in the route table after having shut down the serial interface along with the subnets of the ethernet and dialer interfaces (and all the eigrp routes disappear).
If i do a debug dialer packets i see the following:
Jul 25 10:30:56: Dialer0 DDR: ip (s=10.2.176.10, d=224.0.0.10), 60 bytes, outgoing uninteresting (list 101)
Jul 25 10:31:00: Dialer0 DDR: ip (s=10.2.176.10, d=224.0.0.10), 60 bytes, outgoing uninteresting (list 101)
but no sign of the ping attempts that are running on the network. I would have expected to see the pings in the dbug as interesting traffic but there is no sign of them.
Please let me know if you need any further information.
Rgds,
Martin
Here's the situation, We have a remote site with a frame relay connection (via ser0) which we want to back up with an isdn backup line using ddr and a dialer profile to the main site.
Here is the config of the router
:version 12.0
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname remoterouter
!
aaa new-model
aaa authentication login default group tacacs+ local
aaa authentication ppp default local
aaa authorization exec default group tacacs+
aaa accounting exec default start-stop group tacacs+
aaa accounting network default start-stop group tacacs+
enable secret 5 xxxxxxxxxxxx
enable password xxxxxxxxxxxxx
!
username master password 7 xxxxxxxxxxxxxxx
username trr004x password 7 xxxxxxxxxxxxx
!
!
clock timezone gmt 0
clock summer-time bst recurring last Sun Mar 2:00 last Sun Oct 2:00
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
isdn tei-negotiation first-call
!
!
interface Loopback0
no ip address
no ip directed-broadcast
!
interface Ethernet0
ip address 10.28.0.1 255.255.252.0
ip helper-address 10.2.44.200
ip helper-address 10.2.16.10
no ip directed-broadcast
keepalive 4
!
interface Serial0
description Frame-Relay Link
bandwidth 64
ip address 10.1.16.2 255.255.252.0
no ip directed-broadcast
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
no fair-queue
frame-relay map ip 10.1.16.1 100 broadcast
frame-relay lmi-type ansi
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
description dial backup link
bandwidth 56
no ip address
no ip directed-broadcast
encapsulation ppp
no ip route-cache
no ip mroute-cache
no keepalive
dialer pool-member 1
isdn switch-type basic-net3
no fair-queue
no cdp enable
!
interface Dialer0
ip address 10.2.176.10 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer remote-name trr004x
dialer pool 1
dialer idle-timeout 90
dialer string 01793848012
dialer-group 1
no fair-queue
no cdp enable
ppp authentication chap
ppp multilink
!
interface Dialer1
no ip address
no ip directed-broadcast
no cdp enable
!
router eigrp 1
network 10.0.0.0
network 144.98.0.0
no auto-summary
!
no ip classless
no ip forward-protocol udp tftp
no ip forward-protocol udp nameserver
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 Dialer0 200
no ip http server
!
logging trap debugging
access-list 101 deny eigrp any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
tacacs-server host 10.2.44.208
tacacs-server host 10.2.44.206
tacacs-server timeout 1000
tacacs-server key cisco
snmp-server engineID local 00000009020000E01E3E7080
snmp-server community public xxxxxxx
!
line con 0
transport input none
line aux 0
password xxxxxxxx
no activation-character
modem InOut
stopbits 1
flowcontrol hardware
line vty 0 4
password xxxxxxx
!
ntp clock-period 17179522
ntp server 144.98.31.172
end
MRR001X#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-P-L), Version 12.0(7)T, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 06-Dec-99 19:39 by phanguye
Image text-base: 0x0303C3D4, data-base: 0x00001000
ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOF)
MRR001X uptime is 22 hours, 16 minutes
System returned to ROM by power-on
System restarted at 15:17:01 bst Wed Jul 24 2002
System image file is "flash:c2500-p-l.120-7.T.bin"
cisco 2500 (68030) processor (revision N) with 6144K/2048K bytes of memory.
Processor board ID 06099777, with hardware revision 00000001
X.25 software, Version 3.0.0.
Basic Rate ISDN software, Version 1.1.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)
Configuration register is 0x2102
One problem is that the dialer interface is not dialing out when I ping an ip address on the main site from the remote site after having shut down the frame relay serial interface (administritively). I have tried pinging directly from the remote router and the dialer interface is not dialing out. The bri interface is working as it brings itself up to connect to the ntp server every couple of minutes (which is another problem).
The floating static default route is shown in the route table after having shut down the serial interface along with the subnets of the ethernet and dialer interfaces (and all the eigrp routes disappear).
If i do a debug dialer packets i see the following:
Jul 25 10:30:56: Dialer0 DDR: ip (s=10.2.176.10, d=224.0.0.10), 60 bytes, outgoing uninteresting (list 101)
Jul 25 10:31:00: Dialer0 DDR: ip (s=10.2.176.10, d=224.0.0.10), 60 bytes, outgoing uninteresting (list 101)
but no sign of the ping attempts that are running on the network. I would have expected to see the pings in the dbug as interesting traffic but there is no sign of them.
Please let me know if you need any further information.
Rgds,
Martin