Hello all.
I have an 1841 router I'm attempting to setup an FTP port mapping through on a T1 circuit I recently acquired and setup. The circuit is working fine however my port mapping refuses to work and I'm not sure what exactly I'm missing.
I've setup the proper interfaces as inside and outside for NAT, setup static mappings for ports 20 and 21 to the appropriate internal address. For testing I have base permit IP any any ACLs setup on both the external serial interface and the internal interface where FTP traffic will flow. Based on all this it seems to me it should work. However when I attempt an FTP connection from the outside, all I receive is an error message stating "unknown error". Pertinent config details follow below:
interface Serial0/0/0:0
bandwidth 1536
ip address <external IP> 255.255.255.252
ip access-group serial in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
no cdp enable
interface FastEthernet0/1
description Test Network$ETH-LAN$
ip address 192.168.1.75 255.255.255.0
ip access-group lan in
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
ip nat pool T1 <external IP> <external IP> netmask 255.255.255.252
ip nat inside source list temporary interface Serial0/0/0:0 overload
ip nat inside source static tcp 192.168.1.20 20 <external IP> 20 extendable
ip nat inside source static tcp 192.168.1.20 21 <external IP> 21 extendable
!
ip access-list extended lan
permit ip any any
ip access-list extended serial
permit ip any any
ip access-list extended temporary
permit ip 192.168.1.0 0.0.0.255 any
Is there something painfully obvious I'm missing here? Granted it's been awhile since I've done router security but this seems right to me.
Any help would be greatly appreciated.
I have an 1841 router I'm attempting to setup an FTP port mapping through on a T1 circuit I recently acquired and setup. The circuit is working fine however my port mapping refuses to work and I'm not sure what exactly I'm missing.
I've setup the proper interfaces as inside and outside for NAT, setup static mappings for ports 20 and 21 to the appropriate internal address. For testing I have base permit IP any any ACLs setup on both the external serial interface and the internal interface where FTP traffic will flow. Based on all this it seems to me it should work. However when I attempt an FTP connection from the outside, all I receive is an error message stating "unknown error". Pertinent config details follow below:
interface Serial0/0/0:0
bandwidth 1536
ip address <external IP> 255.255.255.252
ip access-group serial in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
no cdp enable
interface FastEthernet0/1
description Test Network$ETH-LAN$
ip address 192.168.1.75 255.255.255.0
ip access-group lan in
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
ip nat pool T1 <external IP> <external IP> netmask 255.255.255.252
ip nat inside source list temporary interface Serial0/0/0:0 overload
ip nat inside source static tcp 192.168.1.20 20 <external IP> 20 extendable
ip nat inside source static tcp 192.168.1.20 21 <external IP> 21 extendable
!
ip access-list extended lan
permit ip any any
ip access-list extended serial
permit ip any any
ip access-list extended temporary
permit ip 192.168.1.0 0.0.0.255 any
Is there something painfully obvious I'm missing here? Granted it's been awhile since I've done router security but this seems right to me.
Any help would be greatly appreciated.