BritishBulldog
Technical User
Greetings,
Hope someone can help. I have a 1605 Cisco router connected as my ISDN link to my ISP who assigns a dynamic IP address on each dial up. I have it working fine for normal web browsing etc, but I want to use the dyndns service to access my web page on my local machine which is on a private address.
What config command do I need to forward all port 80 requests incoming from my ISP on BRi0 to my local machine?
Here is my current config ( usernames etc removed)
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname peteb
!
enable password 7 ***********
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-net3
!
!
!
interface Ethernet0
description connected to EthernetLAN
ip address 192.168.0.75 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface Ethernet1
no ip address
no ip directed-broadcast
ip nat inside
shutdown
!
interface BRI0
description connected to Internet
no ip address
ip helper-address 194.73.73.94
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
isdn not-end-to-end 64
no cdp enable
!
interface Dialer1
description connected to Internet
ip address negotiated
ip helper-address 194.73.73.94
no ip directed-broadcast
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer string 08089916001
dialer hold-queue 10
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname britishbulldog.fsnet.co.uk
ppp chap password 7 **************
ppp pap sent-username britishbulldog.fsnet.co.uk password 7 ******************
!
router rip
version 2
passive-interface Dialer1
network 192.168.0.0
no auto-summary
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password 7 05080B0E2A495C
login
transport input none
line vty 0 4
password 7 105E0B0C17031D05
login
!
end
Many thanks
Pete AKA BritishBulldog
Hope someone can help. I have a 1605 Cisco router connected as my ISDN link to my ISP who assigns a dynamic IP address on each dial up. I have it working fine for normal web browsing etc, but I want to use the dyndns service to access my web page on my local machine which is on a private address.
What config command do I need to forward all port 80 requests incoming from my ISP on BRi0 to my local machine?
Here is my current config ( usernames etc removed)
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname peteb
!
enable password 7 ***********
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-net3
!
!
!
interface Ethernet0
description connected to EthernetLAN
ip address 192.168.0.75 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface Ethernet1
no ip address
no ip directed-broadcast
ip nat inside
shutdown
!
interface BRI0
description connected to Internet
no ip address
ip helper-address 194.73.73.94
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
isdn not-end-to-end 64
no cdp enable
!
interface Dialer1
description connected to Internet
ip address negotiated
ip helper-address 194.73.73.94
no ip directed-broadcast
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer string 08089916001
dialer hold-queue 10
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname britishbulldog.fsnet.co.uk
ppp chap password 7 **************
ppp pap sent-username britishbulldog.fsnet.co.uk password 7 ******************
!
router rip
version 2
passive-interface Dialer1
network 192.168.0.0
no auto-summary
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password 7 05080B0E2A495C
login
transport input none
line vty 0 4
password 7 105E0B0C17031D05
login
!
end
Many thanks
Pete AKA BritishBulldog