Greetings,
I know it's possible to allow VPN users internet access without using split tunneling. I have heard this being referred to as hairpin or U-turn. Basically I need to route outside (vpn) traffic to the outside interface for internet access.
If someone could help me with the commands to make this work I would really appreciate it. here's my current config (note it's not in production and I plan on creating interface access-lists). I should also note that I have replaced the public IP's with 192.168.1.x
Thank you!!!
PIX Version 8.0(3)
!
hostname F-WIL-MSN-01
domain-name REMOVED
enable password REMOVED encrypted
names
!
interface Ethernet0
nameif outside
security-level 0
ip address 192.168.1.254 255.255.255.0
!
interface Ethernet1
nameif inside
security-level 100
ip address 192.168.25.1 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet3
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet4
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet5
shutdown
no nameif
no security-level
no ip address
!
passwd REMOVED encrypted
boot system flash:/image.bin
ftp mode passive
dns server-group DefaultDNS
domain-name REMOVED
logging enable
logging monitor debugging
logging facility 20
mtu outside 1500
mtu inside 1500
ip local pool vpnpool 192.168.35.100-192.168.35.150
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set set esp-3des esp-md5-hmac
crypto ipsec transform-set FirstSet esp-3des esp-md5-hmac
crypto dynamic-map dyn1 1 set transform-set FirstSet
crypto dynamic-map dyn1 1 set reverse-route
crypto map mymap 1 ipsec-isakmp dynamic dyn1
crypto map mymap interface outside
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 43200
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.25.0 255.255.255.0 inside
ssh timeout 30
console timeout 0
dhcpd dns 192.168.1.35
!
dhcpd address 192.168.25.100-192.168.25.250 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
username joshua password REMOVED encrypted privilege 15
tunnel-group vpngroup type remote-access
tunnel-group vpngroup general-attributes
address-pool vpnpool
tunnel-group vpngroup ipsec-attributes
pre-shared-key *
!
!
prompt hostname context
Cryptochecksum:REMOVED
: end
I know it's possible to allow VPN users internet access without using split tunneling. I have heard this being referred to as hairpin or U-turn. Basically I need to route outside (vpn) traffic to the outside interface for internet access.
If someone could help me with the commands to make this work I would really appreciate it. here's my current config (note it's not in production and I plan on creating interface access-lists). I should also note that I have replaced the public IP's with 192.168.1.x
Thank you!!!
PIX Version 8.0(3)
!
hostname F-WIL-MSN-01
domain-name REMOVED
enable password REMOVED encrypted
names
!
interface Ethernet0
nameif outside
security-level 0
ip address 192.168.1.254 255.255.255.0
!
interface Ethernet1
nameif inside
security-level 100
ip address 192.168.25.1 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet3
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet4
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet5
shutdown
no nameif
no security-level
no ip address
!
passwd REMOVED encrypted
boot system flash:/image.bin
ftp mode passive
dns server-group DefaultDNS
domain-name REMOVED
logging enable
logging monitor debugging
logging facility 20
mtu outside 1500
mtu inside 1500
ip local pool vpnpool 192.168.35.100-192.168.35.150
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set set esp-3des esp-md5-hmac
crypto ipsec transform-set FirstSet esp-3des esp-md5-hmac
crypto dynamic-map dyn1 1 set transform-set FirstSet
crypto dynamic-map dyn1 1 set reverse-route
crypto map mymap 1 ipsec-isakmp dynamic dyn1
crypto map mymap interface outside
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 43200
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.25.0 255.255.255.0 inside
ssh timeout 30
console timeout 0
dhcpd dns 192.168.1.35
!
dhcpd address 192.168.25.100-192.168.25.250 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
username joshua password REMOVED encrypted privilege 15
tunnel-group vpngroup type remote-access
tunnel-group vpngroup general-attributes
address-pool vpnpool
tunnel-group vpngroup ipsec-attributes
pre-shared-key *
!
!
prompt hostname context
Cryptochecksum:REMOVED
: end