I need help setting up a PIX 501 to allow vpn from Windows clients. Users will be using Windows XP Pro. Additionally there will be a site to site IPSEC VPN setup but for now the need is to allow Windows users to establish the VPN. Any help is appreciated. Current config is below.
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ********* encrypted
passwd ******** encrypted
hostname Met***FW
domain-name met***.net
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
name 65.220.xx.xx MET**
name 206.172.xx.xx CAN**
name 71.136.xx.xx RE**
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.1.0 255.255.255.
0
access-list nonat permit ip 192.168.200.0 255.255.255.0 192.168.1.0 255.255.255.
0
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.200.0 255.255.25
5.0
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.50.0 255.255.255
.0
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.100.0 255.255.25
5.0
access-list outside permit tcp any host 67.154.xx.xx eq ftp
access-list outside permit icmp any any echo-reply
access-list outside permit tcp any host 67.154.xx.xx eq citrix-ica
access-list outside permit udp any host 67.154.xx.xx eq 1604
access-list outside permit tcp any host 67.154.xx.xx eq smtp
access-list outside permit tcp any host 67.154.xx.xx eq pop3
access-list outside permit tcp any host 67.154.xx.xx eq www
access-list outside permit tcp any host 67.154.xx.xx eq https
access-list outside permit tcp any host 67.154.xx.xx eq 3389
access-list MET** permit ip 192.168.211.0 255.255.255.0 192.168.1.0 255.255.255.
0
access-list 101 permit ip 192.168.211.0 255.255.255.0 172.16.0.0 255.255.255.0
access-list 101 permit ip 192.168.211.0 255.255.255.0 192.168.200.0 255.255.255.
0
access-list CA** permit ip 192.168.211.0 255.255.255.0 192.168.50.0 255.255.255.
0
access-list RE** permit ip 192.168.211.0 255.255.255.0 192.168.100.0 255.255.2
55.0
pager lines 24
logging on
logging buffered errors
icmp deny any echo outside
icmp permit any echo-reply outside
icmp permit any outside
icmp permit any echo inside
icmp permit any echo-reply inside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 67.154.xx.xx 255.255.255.192
ip address inside 192.168.211.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool remotemaint 192.168.200.1-192.168.200.5
ip local pool vpnpool 172.16.0.1-172.16.0.254
pdm location 192.168.200.0 255.255.255.0 inside
pdm location 192.168.101.0 255.255.255.0 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.211.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 192.168.211.0 255.255.255.0 0 0
static (inside,outside) 67.154.xx.xx 192.168.211.100 netmask 255.255.255.255 0
0
access-group outside in interface outside
route outside 0.0.0.0 0.0.0.0 66.105.xx.65 1
timeout xlate 3:00:00
timeout conn 3:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.200.0 255.255.255.0 inside
http 192.168.101.0 255.255.255.0 inside
http 192.168.211.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community metabo022502
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1270
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set vpnset esp-des esp-md5-hmac
crypto ipsec security-association lifetime seconds 3600
crypto map WCvpn 10 ipsec-isakmp
crypto map WCvpn 10 match address RE**
crypto map WCvpn 10 set peer 71.136.xx.xx
crypto map WCvpn 10 set transform-set vpnset
crypto map WCvpn 15 ipsec-isakmp
crypto map WCvpn 15 match address CA**
crypto map WCvpn 15 set peer 206.172.xx.xx
crypto map WCvpn 15 set transform-set vpnset
crypto map WCvpn 25 ipsec-isakmp
crypto map WCvpn 25 match address MET**
crypto map WCvpn 25 set peer 65.220.xx.xx
crypto map WCvpn 25 set transform-set vpnset
crypto map WCvpn interface outside
isakmp enable outside
isakmp key ******** address 65.220.xx.xx netmask 255.255.255.255 no-xauth no-co
nfig-mode
isakmp key ******** address 71.136.xx.xx netmask 255.255.255.255 no-xauth
isakmp key ******** address 206.172.xx.xx netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp identity address
isakmp keepalive 20
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet 192.168.211.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 5
management-access inside
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 client configuration address local vpnpool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username met** password *********
vpdn enable outside
terminal width 80
Cryptochecksum:c3a5b70a602c431ad64f00c28f09a1a2
: end
MetaboFW#
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ********* encrypted
passwd ******** encrypted
hostname Met***FW
domain-name met***.net
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
name 65.220.xx.xx MET**
name 206.172.xx.xx CAN**
name 71.136.xx.xx RE**
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.1.0 255.255.255.
0
access-list nonat permit ip 192.168.200.0 255.255.255.0 192.168.1.0 255.255.255.
0
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.200.0 255.255.25
5.0
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.50.0 255.255.255
.0
access-list nonat permit ip 192.168.211.0 255.255.255.0 192.168.100.0 255.255.25
5.0
access-list outside permit tcp any host 67.154.xx.xx eq ftp
access-list outside permit icmp any any echo-reply
access-list outside permit tcp any host 67.154.xx.xx eq citrix-ica
access-list outside permit udp any host 67.154.xx.xx eq 1604
access-list outside permit tcp any host 67.154.xx.xx eq smtp
access-list outside permit tcp any host 67.154.xx.xx eq pop3
access-list outside permit tcp any host 67.154.xx.xx eq www
access-list outside permit tcp any host 67.154.xx.xx eq https
access-list outside permit tcp any host 67.154.xx.xx eq 3389
access-list MET** permit ip 192.168.211.0 255.255.255.0 192.168.1.0 255.255.255.
0
access-list 101 permit ip 192.168.211.0 255.255.255.0 172.16.0.0 255.255.255.0
access-list 101 permit ip 192.168.211.0 255.255.255.0 192.168.200.0 255.255.255.
0
access-list CA** permit ip 192.168.211.0 255.255.255.0 192.168.50.0 255.255.255.
0
access-list RE** permit ip 192.168.211.0 255.255.255.0 192.168.100.0 255.255.2
55.0
pager lines 24
logging on
logging buffered errors
icmp deny any echo outside
icmp permit any echo-reply outside
icmp permit any outside
icmp permit any echo inside
icmp permit any echo-reply inside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 67.154.xx.xx 255.255.255.192
ip address inside 192.168.211.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool remotemaint 192.168.200.1-192.168.200.5
ip local pool vpnpool 172.16.0.1-172.16.0.254
pdm location 192.168.200.0 255.255.255.0 inside
pdm location 192.168.101.0 255.255.255.0 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.211.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 192.168.211.0 255.255.255.0 0 0
static (inside,outside) 67.154.xx.xx 192.168.211.100 netmask 255.255.255.255 0
0
access-group outside in interface outside
route outside 0.0.0.0 0.0.0.0 66.105.xx.65 1
timeout xlate 3:00:00
timeout conn 3:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.200.0 255.255.255.0 inside
http 192.168.101.0 255.255.255.0 inside
http 192.168.211.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community metabo022502
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1270
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set vpnset esp-des esp-md5-hmac
crypto ipsec security-association lifetime seconds 3600
crypto map WCvpn 10 ipsec-isakmp
crypto map WCvpn 10 match address RE**
crypto map WCvpn 10 set peer 71.136.xx.xx
crypto map WCvpn 10 set transform-set vpnset
crypto map WCvpn 15 ipsec-isakmp
crypto map WCvpn 15 match address CA**
crypto map WCvpn 15 set peer 206.172.xx.xx
crypto map WCvpn 15 set transform-set vpnset
crypto map WCvpn 25 ipsec-isakmp
crypto map WCvpn 25 match address MET**
crypto map WCvpn 25 set peer 65.220.xx.xx
crypto map WCvpn 25 set transform-set vpnset
crypto map WCvpn interface outside
isakmp enable outside
isakmp key ******** address 65.220.xx.xx netmask 255.255.255.255 no-xauth no-co
nfig-mode
isakmp key ******** address 71.136.xx.xx netmask 255.255.255.255 no-xauth
isakmp key ******** address 206.172.xx.xx netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp identity address
isakmp keepalive 20
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet 192.168.211.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 5
management-access inside
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 client configuration address local vpnpool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username met** password *********
vpdn enable outside
terminal width 80
Cryptochecksum:c3a5b70a602c431ad64f00c28f09a1a2
: end
MetaboFW#