Hello...
I'm fairly new to configuring Cisco routers and I've run into a jam on my first job...DOH!
The system I'm working with has an ISDN connection to their ISP. They have a LAN with a private IP scheme, 192.168.1.x, and they use NAT on a Cisco 1604 router in order for their LAN to have Internet access. This part was already configured before I started working with it and everything with this works fine.
Here's the issue: I need to have some clients on the outside, who use registered IP addresses, establish a pcANYWHERE connection to a PC on the private LAN - the IP address of that station is 192.168.1.37. They use the latest version of pcANYWHERE, 9.x, and so the ports used are 5631 and 5632. So far, I have been unsuccessful in getting this to work, even when temporarily disabling all access lists that are running.
So in english, I need all traffic coming into the router's public IP address on the BRI0 interface using ports 5631 and 5632 to be directed to the station on the LAN having the private IP address 192.168.1.37.
Unfortunately, I can't tell the Cisco router this in English, and all combinations of commands that I've tried so far have failed. I will post the current running config of this router and hopefully someone can point me in the right direction. I have been reading the documentation that I've gotten from the Cisco website, and the solution is probably right there in front of my face, but like I said, this is my first job configuring a Cisco router and I'm just not seeing it.
If anyone can shed some light on this for me, I'd really be grateful. Sorry for the long-winded post, but I wanted to make sure that I provided enough background info for this to make sense! The config follows...
-----------------------------------------------------------
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname xxxxx
!
logging buffered 4096 informational
!
ip subnet-zero
ip name-server 207.112.128.2
ip name-server 206.54.224.1
ip inspect name internet ftp
ip inspect name internet tcp
ip inspect name internet udp
ip inspect name internet smtp
ip inspect name internet http java-list 1
isdn switch-type basic-ni
isdn tei-negotiation first-call
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip access-group 102 in
ip access-group 101 out
no ip directed-broadcast
ip nat inside
no ip route-cache
no ip mroute-cache
!
interface BRI0
description ISDN Ckt IBZD233340 (Connection to ISP)
ip address 209.100.92.245 255.255.255.0
ip access-group 111 in
ip access-group 110 out
no ip directed-broadcast
ip nat outside
ip inspect internet out
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer map ip 207.112.131.226 name tc5.chi 97140061
dialer load-threshold 70 outbound
dialer-group 1
isdn switch-type basic-ni
isdn spid1 21986446500111 8644650
isdn spid2 21986446510111 8644651
ppp authentication chap pap callin
ppp pap sent-username xxxxx password 7 041A4A0B0E335F0D4A
ppp multilink
!
ip nat inside source list 121 interface BRI0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 207.112.131.226
ip route 207.112.131.226 255.255.255.255 BRI0
!
access-list 1 permit any
access-list 101 permit tcp host 199.172.146.114 eq 192.168.1.32 eq 1464
access-list 101 permit tcp host 199.172.146.114 eq 192.168.1.32 eq 1421
access-list 101 permit tcp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5631
access-list 101 permit udp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5632
access-list 101 permit tcp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5632
access-list 101 permit udp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5631
access-list 101 permit icmp any any
access-list 101 permit ip any any
access-list 101 deny ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 deny ip any any
access-list 110 permit tcp 209.100.92.0 0.0.0.255 any
access-list 110 permit udp 209.100.92.0 0.0.0.255 any
access-list 110 permit icmp 209.100.92.0 0.0.0.255 any
access-list 110 deny ip any any
access-list 111 permit tcp host 207.112.128.12 eq pop3 host 209.100.92.245 eq 1713
access-list 111 permit tcp host 216.34.209.10 eq 209.100.92.245 eq 1611
access-list 111 permit tcp host 64.58.76.68 eq 209.100.92.245 eq 1580
access-list 111 permit tcp host 4.22.174.163 eq 209.100.92.245 eq 1358
access-list 111 permit tcp host 207.246.136.141 eq 209.100.92.245 eq 1472
access-list 111 permit tcp host 207.246.136.141 eq 209.100.92.245 eq 1450
access-list 111 permit tcp host 207.246.136.141 eq 209.100.92.245 eq 1424
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1454
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1442
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1427
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1412
access-list 111 permit tcp host 207.246.136.130 eq 209.100.92.245 eq 1470
access-list 111 permit tcp host 207.246.136.130 eq 209.100.92.245 eq 1410
access-list 111 permit tcp host 207.246.136.213 eq 209.100.92.245 eq 1453
access-list 111 permit tcp host 207.112.128.12 eq pop3 host 209.100.92.245 eq 1765
access-list 111 permit tcp host 199.172.146.114 eq 209.100.92.245 eq 1464
access-list 111 permit tcp host 199.172.146.114 eq 209.100.92.245 eq 1421
access-list 111 permit ip 208.132.215.0 0.0.0.255 host 209.100.92.245
access-list 111 deny ip 209.100.92.0 0.0.0.255 any
access-list 111 deny ip any any
access-list 121 permit icmp any any
access-list 121 permit ip any any
dialer-list 1 protocol ip list 121
!
line con 0
exec-timeout 0 0
password 7 033A1806071D32720D
login
transport input none
line vty 0 4
password 7 10704A14040501354F
login
!
end
I'm fairly new to configuring Cisco routers and I've run into a jam on my first job...DOH!
The system I'm working with has an ISDN connection to their ISP. They have a LAN with a private IP scheme, 192.168.1.x, and they use NAT on a Cisco 1604 router in order for their LAN to have Internet access. This part was already configured before I started working with it and everything with this works fine.
Here's the issue: I need to have some clients on the outside, who use registered IP addresses, establish a pcANYWHERE connection to a PC on the private LAN - the IP address of that station is 192.168.1.37. They use the latest version of pcANYWHERE, 9.x, and so the ports used are 5631 and 5632. So far, I have been unsuccessful in getting this to work, even when temporarily disabling all access lists that are running.
So in english, I need all traffic coming into the router's public IP address on the BRI0 interface using ports 5631 and 5632 to be directed to the station on the LAN having the private IP address 192.168.1.37.
Unfortunately, I can't tell the Cisco router this in English, and all combinations of commands that I've tried so far have failed. I will post the current running config of this router and hopefully someone can point me in the right direction. I have been reading the documentation that I've gotten from the Cisco website, and the solution is probably right there in front of my face, but like I said, this is my first job configuring a Cisco router and I'm just not seeing it.
If anyone can shed some light on this for me, I'd really be grateful. Sorry for the long-winded post, but I wanted to make sure that I provided enough background info for this to make sense! The config follows...
-----------------------------------------------------------
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname xxxxx
!
logging buffered 4096 informational
!
ip subnet-zero
ip name-server 207.112.128.2
ip name-server 206.54.224.1
ip inspect name internet ftp
ip inspect name internet tcp
ip inspect name internet udp
ip inspect name internet smtp
ip inspect name internet http java-list 1
isdn switch-type basic-ni
isdn tei-negotiation first-call
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip access-group 102 in
ip access-group 101 out
no ip directed-broadcast
ip nat inside
no ip route-cache
no ip mroute-cache
!
interface BRI0
description ISDN Ckt IBZD233340 (Connection to ISP)
ip address 209.100.92.245 255.255.255.0
ip access-group 111 in
ip access-group 110 out
no ip directed-broadcast
ip nat outside
ip inspect internet out
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer map ip 207.112.131.226 name tc5.chi 97140061
dialer load-threshold 70 outbound
dialer-group 1
isdn switch-type basic-ni
isdn spid1 21986446500111 8644650
isdn spid2 21986446510111 8644651
ppp authentication chap pap callin
ppp pap sent-username xxxxx password 7 041A4A0B0E335F0D4A
ppp multilink
!
ip nat inside source list 121 interface BRI0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 207.112.131.226
ip route 207.112.131.226 255.255.255.255 BRI0
!
access-list 1 permit any
access-list 101 permit tcp host 199.172.146.114 eq 192.168.1.32 eq 1464
access-list 101 permit tcp host 199.172.146.114 eq 192.168.1.32 eq 1421
access-list 101 permit tcp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5631
access-list 101 permit udp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5632
access-list 101 permit tcp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5632
access-list 101 permit udp 208.132.215.0 0.0.0.255 host 192.168.1.37 eq 5631
access-list 101 permit icmp any any
access-list 101 permit ip any any
access-list 101 deny ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 deny ip any any
access-list 110 permit tcp 209.100.92.0 0.0.0.255 any
access-list 110 permit udp 209.100.92.0 0.0.0.255 any
access-list 110 permit icmp 209.100.92.0 0.0.0.255 any
access-list 110 deny ip any any
access-list 111 permit tcp host 207.112.128.12 eq pop3 host 209.100.92.245 eq 1713
access-list 111 permit tcp host 216.34.209.10 eq 209.100.92.245 eq 1611
access-list 111 permit tcp host 64.58.76.68 eq 209.100.92.245 eq 1580
access-list 111 permit tcp host 4.22.174.163 eq 209.100.92.245 eq 1358
access-list 111 permit tcp host 207.246.136.141 eq 209.100.92.245 eq 1472
access-list 111 permit tcp host 207.246.136.141 eq 209.100.92.245 eq 1450
access-list 111 permit tcp host 207.246.136.141 eq 209.100.92.245 eq 1424
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1454
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1442
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1427
access-list 111 permit tcp host 207.211.39.119 eq 209.100.92.245 eq 1412
access-list 111 permit tcp host 207.246.136.130 eq 209.100.92.245 eq 1470
access-list 111 permit tcp host 207.246.136.130 eq 209.100.92.245 eq 1410
access-list 111 permit tcp host 207.246.136.213 eq 209.100.92.245 eq 1453
access-list 111 permit tcp host 207.112.128.12 eq pop3 host 209.100.92.245 eq 1765
access-list 111 permit tcp host 199.172.146.114 eq 209.100.92.245 eq 1464
access-list 111 permit tcp host 199.172.146.114 eq 209.100.92.245 eq 1421
access-list 111 permit ip 208.132.215.0 0.0.0.255 host 209.100.92.245
access-list 111 deny ip 209.100.92.0 0.0.0.255 any
access-list 111 deny ip any any
access-list 121 permit icmp any any
access-list 121 permit ip any any
dialer-list 1 protocol ip list 121
!
line con 0
exec-timeout 0 0
password 7 033A1806071D32720D
login
transport input none
line vty 0 4
password 7 10704A14040501354F
login
!
end