Hi Folks,
To make a long (frustrating!) story short, I'm trying to get an old Pix 501 I had reconfigured to fill in for an ASA 5505 that is giving me trouble. This is a bonehead simple setup: the Pix's inside interface is defined to match the public IPs of a small subnet and several boxes with various services sit behind it with their public IPs defined the same on the inside and the outside. I've had this working before, including VPN and such, but I can't for the life of me figure out what I'm missing (or what spurious thing I've added to the config that's blocking outside traffic to IPs/Ports that the ACL entries should allow).
Suggestions gratefully accepted (I've trimmed out some stuff in the config so that it's just the one server--a web server that also allows SSH access--or used to before I blew things up!).
To recap, everything behind the firewall can initiate connections to things on the Internet; but when I'm remotely connected to a box out on the Internet, I can't pull up the web site. (I know I messed something up--and did a similar number on the ASA 5505, but that's another forum--I just do not know what it is.)
Thanks,
John
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password <snip> encrypted
passwd <snip> encrypted
hostname pixie
domain-name <snip>
clock timezone MST -7
clock summer-time MDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name xxx.xxx.xxx.131 mail-outside
name xxx.xxx.xxx.132 femail-outside
name xxx.xxx.xxx.133 wrt54g-outside
name xxx.xxx.xxx.128 public_subnet
name xxx.xxx.xxx.130 blacky-public
object-group service email tcp
description email ports
port-object range 995 995
port-object range 465 465
port-object eq smtp
access-list outside_access_in remark blacky
access-list outside_access_in permit tcp any host blacky-public eq access-list outside_access_in remark SSH access to blacky
access-list outside_access_in permit tcp any host blacky-public eq ssh log
access-list outside_access_in permit icmp any any echo-reply log
access-list outside_access_in permit icmp any any redirect log
access-list outside_access_in permit icmp any any traceroute log
access-list outside_access_in permit udp any eq nameserver any
access-list outside_access_in permit udp any eq rip any
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside xxx.xxx.xxx.129 255.255.255.248
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
pdm location xxx.xxx.xxx.134 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) blacky-public blacky-public netmask 255.255.255.255 0 0
static (outside,inside) blacky-public blacky-public netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
timeout xlate 0:05:00
timeout conn 8:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http public_subnet 255.255.255.248 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection timewait
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-SHA
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
telnet timeout 5
ssh public_subnet 255.255.255.248 inside
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:d9641da21ec7b67ced8a61f6e8006306
: end
To make a long (frustrating!) story short, I'm trying to get an old Pix 501 I had reconfigured to fill in for an ASA 5505 that is giving me trouble. This is a bonehead simple setup: the Pix's inside interface is defined to match the public IPs of a small subnet and several boxes with various services sit behind it with their public IPs defined the same on the inside and the outside. I've had this working before, including VPN and such, but I can't for the life of me figure out what I'm missing (or what spurious thing I've added to the config that's blocking outside traffic to IPs/Ports that the ACL entries should allow).
Suggestions gratefully accepted (I've trimmed out some stuff in the config so that it's just the one server--a web server that also allows SSH access--or used to before I blew things up!).
To recap, everything behind the firewall can initiate connections to things on the Internet; but when I'm remotely connected to a box out on the Internet, I can't pull up the web site. (I know I messed something up--and did a similar number on the ASA 5505, but that's another forum--I just do not know what it is.)
Thanks,
John
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password <snip> encrypted
passwd <snip> encrypted
hostname pixie
domain-name <snip>
clock timezone MST -7
clock summer-time MDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name xxx.xxx.xxx.131 mail-outside
name xxx.xxx.xxx.132 femail-outside
name xxx.xxx.xxx.133 wrt54g-outside
name xxx.xxx.xxx.128 public_subnet
name xxx.xxx.xxx.130 blacky-public
object-group service email tcp
description email ports
port-object range 995 995
port-object range 465 465
port-object eq smtp
access-list outside_access_in remark blacky
access-list outside_access_in permit tcp any host blacky-public eq access-list outside_access_in remark SSH access to blacky
access-list outside_access_in permit tcp any host blacky-public eq ssh log
access-list outside_access_in permit icmp any any echo-reply log
access-list outside_access_in permit icmp any any redirect log
access-list outside_access_in permit icmp any any traceroute log
access-list outside_access_in permit udp any eq nameserver any
access-list outside_access_in permit udp any eq rip any
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside xxx.xxx.xxx.129 255.255.255.248
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
pdm location xxx.xxx.xxx.134 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) blacky-public blacky-public netmask 255.255.255.255 0 0
static (outside,inside) blacky-public blacky-public netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
timeout xlate 0:05:00
timeout conn 8:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http public_subnet 255.255.255.248 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection timewait
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-SHA
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
telnet timeout 5
ssh public_subnet 255.255.255.248 inside
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:d9641da21ec7b67ced8a61f6e8006306
: end