Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Obtaining an ip address automatically (cable modem)?

Status
Not open for further replies.

arisythila

Technical User
Jun 3, 2006
43
0
0
US
Hello, I am new to the forums, I've searched Cisco's site for what im looking for, and also tried to google it, after looking for a long long time, I decided to ask.

I am trying to get my Cisco 2600 Series router to do just that, route. I want to setup my cable modem on my Ethernet0/1 port, (needs to obtain IP automatically) and then setup DHCP on Ethernet0/0 (I may have figured this out, not sure).

Any help would be awesome, Im sure someone has done this before, I just maybe not looking in the right spot.

This is what I have so far.

//code//

!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mike
!
enable secret 5 /
enable password
!
ip subnet-zero
no ip routing
!
!
!
ip dhcp pool Mypool
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
no ip redirects
no ip unreachables
no ip route-cache
speed auto
full-duplex
!
interface Serial0/0
no ip address
no ip route-cache
shutdown
!
interface FastEthernet0/1
ip address gets automatically from cable modem
no ip redirects
no ip unreachables
ip nat inside
no ip route-cache
speed auto
full-duplex
!

//end of code//

Thanks again, for the help.

~Mike
 
Mike,
Take a look - you have most of it in place -

service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
!
ip subnet-zero
no ip finger
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool insideDHCP
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.5 4.2.2.6 4.2.2.66
!
!
!
!
!
interface FastEthernet0/0
description Facing my LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
speed auto
full-duplex
!
interface FastEthernet0/1
description Facing the ISP (the WAN)
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
speed auto
full-duplex
no cdp enable (for exterior facing interfaces)


!
interface Serial0/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
!
ip kerberos source-interface any
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
banner motd ^C
Property of
Your Company Name
Unauthorized Use Prohibited
For more information, contact:
^C

!
line con 0
exec-timeout 0 0
password 7 104308100F1E1C0C
logging synchronous
login
transport input none
line aux 0
password 7 082C4D4703100B10
login
line vty 0 4
password 7 050607062B45400E
login
!
end

Hope this helps!



E.A. Broda
CCNA, CCDA, CCAI, Network +
 
I was able to get DHCP working for the inside network, but Its still now pulling and IP address from the cable modem.

Mike#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES NVRAM up down
Serial0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 unassigned YES DHCP up up
Mike#

This is what I get. Im not sure what to do besides assigning an IP address. Any ideas?

This is what that ethernet port looks like.

interface FastEthernet0/1
description ISP
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
speed auto
full-duplex
no cdp enable

Thanks again

~Mike
 
Mike,
Have you talked to your cable co. ?

I remember some, to keep sharing down locked the MAC address of the 1st thing that conected to it, your old PC or router - that is the only thing the modem will communicate with. They have to release it or you have to "spoof" the MAC address of the item it thinks it wants to talk to.

I would call your cable co. and ask or you can go to and see if they have a forum for your cable co - there you could get specific info on what will work with YOUR cable co.

Just more thoughts!


E.A. Broda
CCNA, CCDA, CCAI, Network +
 
No, I have no problems switching devices. The Cisco Router doesnt even pick up DHCP if I was to hook it up to my linksys router.

~Mike
 
CiscoGuy33 said;

I remember some, to keep sharing down locked the MAC address of the 1st thing that conected to it, your old PC or router - that is the only thing the modem will communicate with. They have to release it or you have to "spoof" the MAC address of the item it thinks it wants to talk to.


The above comment is right....Did the config of CiscoGuy33 work??
 
Its still not picking up DHCP. I can swap the cable modem to different routers and they will each pick up DHCP from the cable modem. All I have to do is shut down the cable modem for 1-2 minutes, and it works fine.

Cisco on the other hand doesnt want to work for me.... It should, but it doesnt.. I am able to get DHCP from the router so thats a good start.. just having a problem getting it from the cable modem.

~Mike
 
arisythila, something I noticed in your initial config display.....is there a particular reason why "no ip routing" is in there?
 
interface FastEthernet0/1
description Facing the ISP (the WAN)
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
speed auto
full-duplex
no cdp enable (for exterior facing interfaces)

ip kerberos source-interface any
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
!

Just been talking to a colleague of mine and he basically outlined what CiscoGuy33 said.
He also mentioned that NAT-ing your FastEthernet0/0
and the above command will allow your LAN IP's to have access to the internet, as its currently trying to access the internet under the 10.10.10.0
 
I am new to this forum, and I am going crazy...I have a need for the same setup... put a 2621 cisco between the cable modem and the switches to get rid of the crappy old linksys box.

Here is the problem
Once in the console of the 2621;
I CAN ping I CAN ping 192.168.1.100 (a laptop on the inside network)

On the laptop;
I CAN ping anything inside my network
I CAN NOT ping
I unplugged everything only to find that dhcp has "limited connectivity", its funny though, because when i do a release/renew on the laptop it seems to work. I originally did my config EXACTLY like CiscoGuy33 put on the board, below is what i ended up with.

Anywho here is a rundown of the config

Router#show ver
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(34a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Tue 02-May-06 11:58 by pwade
Image text-base: 0x8000808C, data-base: 0x81472108

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

Router uptime is 14 minutes
System returned to ROM by power-on
System image file is "flash:c2600-js-mz.122-34a.bin"

cisco 2621 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory
.
Processor board ID JAD05030S13 (3351723419)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
2 FastEthernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102





Router#show startup-config
Using 1101 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
ip dhcp excluded-address 192.168.1.5
!
ip dhcp pool insideDHCP
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 65.32.5.74 65.32.5.75
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed auto
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
description WAN
ip address dhcp
ip nat outside
speed auto
full-duplex
no cdp enable
!
router rip
version 2
passive-interface FastEthernet0/1
network 192.168.1.0
no auto-summary
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end





ANY HELP IS VERY VERY VERY Appriciated <---spelling?
 
Once again, I've spoken to a colleague of mine in regards to this issue and here is his conclusion;

You have half the answer already, as you have IP NAT inside already, but it seems as though you need to IP NAT outside.. (fa0/1 - I believe)

IP Nat Outside can be done by the following commands;

IP Nat Pool (Pool Name) x.x.x.x x.x.x.x
Prefix-length 24

IP Nat Inside source list 1 Pool (Pool name) overload



All the best...
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top