Dannyrae74
Technical User
I'm trying to PAT rdp traffic from an external IP to an internal IP but its not working. The client VPN works fine.
Please help, thanks inadvance for any responses.
PIX Version 7.2(3)
!
hostname PIX
domain-name pix.org
enable password twM2DBp5KWm3aWPK encrypted
names
!
interface Ethernet0
nameif outside
security-level 0
ip address 212.x.x.212 255.255.255.240
!
interface Ethernet1
nameif inside
security-level 100
ip address 10.0.1.251 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
passwd twM2DBp5KWm3aWPK encrypted
banner login !!! Warning !!!
banner login Only authororised users may access this system. If you are
banner login not authorised, please disconnect immediately!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
domain-name xxx.org
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host 212.x.x.214 eq 3389
access-list xxxvpn_splitTunnelAcl standard permit 10.0.0.0 255.0.0.0
access-list no_nat extended permit ip 10.0.0.0 255.0.0.0 10.0.0.0 255.0.0.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
ip local pool xxx-vpnpool 10.0.1.60-10.0.1.69 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no_nat
nat (inside) 1 10.0.1.0 255.255.255.0
static (inside,outside) tcp 212.x.x.214 3389 10.0.1.207 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 212.x.x.211 1
route inside 10.0.5.0 255.255.255.0 10.0.1.253 1
route inside 10.0.8.0 255.255.255.0 10.0.1.8 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server clientvpn protocol radius
aaa-server clientvpn host 10.0.1.13
timeout 5
key xxx666
aaa authentication ssh console LOCAL
http server enable
http 10.0.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 40
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
telnet 10.0.1.0 255.255.255.0 inside
telnet timeout 5
ssh 195.x.x.0 255.255.255.0 outside
ssh 213.x.x.0 255.255.255.0 outside
ssh 80.x.x.113 255.255.255.255 outside
ssh 10.0.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
group-policy xxxvpn internal
group-policy xxxvpn attributes
dns-server value 10.0.1.13 10.0.1.7
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value xxxvpn_splitTunnelAcl
username xxxxx password 61DJLosg25XOnOr. encrypted privilege 15
username xxxxx password LIjaT.91LxPeEEpU encrypted privilege 15
username xxxxx password pRscgNCX9PUI/XoY encrypted privilege 15
tunnel-group xxxvpn type ipsec-ra
tunnel-group xxxvpn general-attributes
address-pool xxx-vpnpool
authentication-server-group clientvpn
default-group-policy xxxvpn
tunnel-group xxxvpn ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:321344da5a955c43304eb0bc5cb37ef9
: end
Please help, thanks inadvance for any responses.
PIX Version 7.2(3)
!
hostname PIX
domain-name pix.org
enable password twM2DBp5KWm3aWPK encrypted
names
!
interface Ethernet0
nameif outside
security-level 0
ip address 212.x.x.212 255.255.255.240
!
interface Ethernet1
nameif inside
security-level 100
ip address 10.0.1.251 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
passwd twM2DBp5KWm3aWPK encrypted
banner login !!! Warning !!!
banner login Only authororised users may access this system. If you are
banner login not authorised, please disconnect immediately!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
domain-name xxx.org
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host 212.x.x.214 eq 3389
access-list xxxvpn_splitTunnelAcl standard permit 10.0.0.0 255.0.0.0
access-list no_nat extended permit ip 10.0.0.0 255.0.0.0 10.0.0.0 255.0.0.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
ip local pool xxx-vpnpool 10.0.1.60-10.0.1.69 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no_nat
nat (inside) 1 10.0.1.0 255.255.255.0
static (inside,outside) tcp 212.x.x.214 3389 10.0.1.207 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 212.x.x.211 1
route inside 10.0.5.0 255.255.255.0 10.0.1.253 1
route inside 10.0.8.0 255.255.255.0 10.0.1.8 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server clientvpn protocol radius
aaa-server clientvpn host 10.0.1.13
timeout 5
key xxx666
aaa authentication ssh console LOCAL
http server enable
http 10.0.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 40
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
telnet 10.0.1.0 255.255.255.0 inside
telnet timeout 5
ssh 195.x.x.0 255.255.255.0 outside
ssh 213.x.x.0 255.255.255.0 outside
ssh 80.x.x.113 255.255.255.255 outside
ssh 10.0.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
group-policy xxxvpn internal
group-policy xxxvpn attributes
dns-server value 10.0.1.13 10.0.1.7
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value xxxvpn_splitTunnelAcl
username xxxxx password 61DJLosg25XOnOr. encrypted privilege 15
username xxxxx password LIjaT.91LxPeEEpU encrypted privilege 15
username xxxxx password pRscgNCX9PUI/XoY encrypted privilege 15
tunnel-group xxxvpn type ipsec-ra
tunnel-group xxxvpn general-attributes
address-pool xxx-vpnpool
authentication-server-group clientvpn
default-group-policy xxxvpn
tunnel-group xxxvpn ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:321344da5a955c43304eb0bc5cb37ef9
: end