Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

map IP address

Status
Not open for further replies.

mikeasa

Technical User
Dec 23, 2005
133
US
I need help with a 7200 to map an outside IP address to an internal IP address.
 
For a single address:

conf t
interface fastethernet0/0
ip add 1.2.3.4 255.255.255.255
ip nat inside
exit

interface serial0/0/0
ip add 4.5.6.7 255.255.255.255
ip nat outside
exit

ip nat outside source static (inside 'real' address) (outside 'alias' address)

exit



 
I need to do 3 of them. Never needed to do this before and didnt learn how thanks for your help. This is what is there now.

interface FastEthernet0/0
ip address 65.46.73.146 255.255.255.252
no ip redirects
no ip proxy-arp
ip nat outside
duplex full
speed 10
!
interface FastEthernet0/1
ip address 67.11.79.65 255.255.255.224
ip nat inside
ip dhcp relay information trusted
no ip route-cache
no ip mroute-cache
duplex full
speed auto
!
interface Serial1/0
ip address 69.64.206.2 255.255.255.252 secondary
ip address 192.168.10.2 255.255.255.0
no ip redirects
ip accounting output-packets
no ip route-cache
no ip mroute-cache
dsu bandwidth 44210
framing c-bit
cablelength 224
serial restart_delay 0
 
You need to map three of them to one address or three of them to three addresses? Which needs to be mapped to what?
 
I need to map 3 different outside addresses to 3 different internal addresses

public 67.11.79.20 to private 192.168.0.20
public 67.11.79.21 to private 192.168.0.21
public 67.11.79.22 to private 192.168.0.22
 
Ya a topology would help.

It seems that your FA0/0 port is the outside NAT port and your FA0/1 port is the inside port with your S1/0 port being a T3.

If I had to take a guess I think it'd go something like this:

ip access-list 40 permit 67.11.79.20 0.0.0.0
ip access-list 40 permit 67.11.79.21 0.0.0.0
ip access-list 40 permit 67.11.79.22 0.0.0.0

ip nat pool inside_range 192.168.0.20 192.168.0.22 netmask 255.255.255.0

ip nat outside source list 40 pool inside_range

That's a wild guess..don't implement it. Wait for other responses. I may very well be wrong.

-E
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top