Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Load balancing over two ADSL lines

Status
Not open for further replies.

superduperlopez

Technical User
Mar 21, 2006
32
0
0
GB
Hi,

I need to load balance traffic from one router over two ADSL lines but I only have control over the on-site router, not over the ISP router.

Is there a way of doing this...I've been reading trying to find some information regarding the subject but in all the papers they seem to think that you have to have control over the two routers (ISP and site) .....is it there a way of applying load balancing without having to contact the ISP and ask them to modify the config in their router???

so far my config looks like this....

ip address 88.99.88.99 255.255.255.0
ip access-group 150 in
ip access-group sdm_dialer1_out out
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip load-sharing per-packet
service-policy output policing
no ip route-cache
no ip mroute-cache
speed auto
half-duplex
hold-queue 224 in

I believe that the commands that should apply the load balancing are these two..
no ip route-cache
ip load-sharing per-packet

is that correct???

Thank your for your help

 
sorry I forgot to mention in my previous post..........


would "Multilink PPP" be an alternative???

cheers
 
Do you have two incoming adsl lines? The fact that you're asking about multiling ppp tells me no...if there's only one adsl line, what do you mean by load balancing? And what kind of router? Are you doing pppoe or pppoa? Can you post a general "show interface", which includes the atm and virtual access? Thanks. Also, version would help also.
 
Just noticed in your config that you setup per-packet. Be aware that if your router has limited resources it may overwhelm the CPU and is not recommended if your are doing and VOIP traffic. The other command you need is to enable IP CEF in global configby just entering IP CEF.
 
Also need two equal cost paths...
ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route 0.0.0.0 0.0.0.0 2.2.2.2
 
Hello again,

The router is a 2621XM
I am not doing any VoIP

interface ATM0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 2
!
dsl operating-mode auto
no fair-queue

interface ATM0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
no fair-queue
!
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool pptp
ppp encrypt mppe 40
ppp authentication ms-chap
!
interface Dialer1
ip address negotiated
ip access-group 150 in
ip access-group test_too out
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 1
dialer-group 1
service-policy output policing
ppp authentication chap pap callin
ppp chap hostname test@test
ppp chap password 7
ppp ipcp dns request
crypto map combinedmap
hold-queue 224 in
!
interface Dialer2
ip address negotiated
ip access-group 150 in
ip access-group test_too out
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 2
dialer-group 2
service-policy output policing
no cdp enable
ppp authentication chap pap callin
ppp chap hostname test@test
ppp chap password 7
ppp ipcp dns request
crypto map combinedmap
hold-queue 224 in
!

I also have to default routes set with equal cost
and "ip cef" configured at global level

There are two ADSL interfaces coming out of the router and I want to use both to load balance the traffic

If I ping google while having debug ip icmp on I get the following...
Apr 27 14:52:22.111: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:22.151: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:22.195 ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:22.239: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:22.279: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.94
Satra_router#ping 66.249.93.99

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 66.249.93.99, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/38/40 ms
Satra_router#
Apr 27 14:52:27.011: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.94
Apr 27 14:52:27.051: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.94
Apr 27 14:52:27.091: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.96.77.94
Apr 27 14:52:27.135 ICMP: echo reply rcvd, src 66.249.93.99, dst 77.96.77.94
Apr 27 14:52:27.175: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.96.77.94
Satra_router#ping 66.249.93.99

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 66.249.93.99, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms
Satra_router#
Apr 27 14:52:29.447: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:29.491: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:29.535: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:29.579: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22
Apr 27 14:52:29.623: ICMP: echo reply rcvd, src 66.249.93.99, dst 77.77.77.22

so it does seem to be kind of load balancing, however, when I do a "debug ip packet" ALL the traffic seems to coming through Dialer1

any ideas why?

thanks
 
Note If you want to enable per-packet load sharing to a particular destination, then all interfaces that can forward traffic to the destination must be enabled for per-packet load sharing.

Above is from Cisco. Dont you need to have ip load-sharing per-packet on your dialer interfaces also?
 
Does it show that dialer 1 is bound to a virtual access (I'm sure it does), but does it show dialer 2 bound to one as well? do a show int di1 and di2,.
 
yes, both Dialers are bound to Virtual-Access 1 and 2 respectively

...and after applying the "ip load-sharing per-packet" on both Dialers.....still the same

any more ideas??

cheers
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top