The Tunnel is up between my Cisco 871 and my Pix 515e but I can't ping through the tunnel on either side:-\ I moved my 871 to the outside of my firewall in a testing lab scenario, the tunnel builds but I can't ping from either side. More than likely this is a nat issue on my pix but I can't find out what the issue is through my debug sessions.
I also want to keep Vlan1 up on my Cisco 871 even though I have nothing plugged into it. I can't even ping vlan1 on the Cisco 871 because the protocol layer is down.
The 10.35.1.0/24 network is on the inside of my network so the traffic flows through the inside interface of the Pix.
--------------------------------------
pix515(config)# sh vpn-sessiondb l2l
Session Type: LAN-to-LAN
Connection : 192.168.10.50
Index : 101 IP Addr : 10.44.44.0
Protocol : IKE IPsec
Encryption : 3DES Hashing : MD5
Bytes Tx : 127000 Bytes Rx : 1400
Login Time : 19:23:38 UTC Fri Jun 26 2009
Duration : 0h:06m:34s
--------------------------------------
pix515(config)# ping 10.44.44.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.44.44.2, timeout is 2 seconds:
?????
Success rate is 0 percent (0/5)
--------------------------------------
871w-rtr#ping 10.35.1.5 source 10.44.44.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.35.1.5, timeout is 2 seconds:
Packet sent with a source address of 10.44.44.2
.....
Success rate is 0 percent (0/5)
-----------------------------
Pix
pix515(config)# sh run nat
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
pix515(config)# sh access-list nonat
access-list nonat; 5 elements
access-list nonat line 1 extended permit ip 10.35.1.0 255.255.255.0 10.44.44.0 255.255.255.0 (hitcnt=0) 0x33ce6f2d
static (inside,DMZ) 10.44.44.0 10.44.44.0 netmask 255.255.255.0
crypto map cmap-vpncient 1 match address outside_cryptomap
crypto map cmap-vpncient 1 set peer 192.168.10.50
crypto map cmap-vpncient 1 set transform-set ESP-3DES-MD5
-----------------------------
871
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
crypto isakmp key ******** address 192.168.10.20
crypto isakmp invalid-spi-recovery
crypto isakmp keepalive 10
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
!
crypto map IPSec 1 ipsec-isakmp
set peer 192.168.10.20
set transform-set myset
match address tunnel
!
crypto map testmap 10 ipsec-isakmp
set peer 192.168.10.20
set security-association idle-time 300
set transform-set myset
match address tunnel
!
interface FastEthernet4
ip address 192.168.10.50 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map IPSec
!
interface Vlan1
description Users
ip address 10.44.44.2 255.255.255.0
ip tcp adjust-mss 1452
!
!
-----------------------------
871w-rtr#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0 unassigned YES unset up down
FastEthernet1 unassigned YES unset up down
FastEthernet2 unassigned YES unset up down
FastEthernet3 unassigned YES unset up down
FastEthernet4 192.168.10.50 YES manual up up
Dot11Radio0 unassigned YES NVRAM administratively down down
Vlan1 10.44.44.2 YES manual up down
-----------------------------
871w-rtr#ping 10.35.1.5 source 10.44.44.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.35.1.5, timeout is 2 seconds:
Packet sent with a source address of 10.44.44.2
.....
Success rate is 0 percent (0/5)
-----------------------------
871w-rtr#sh crypto isakmp sa
IPv4 Crypto ISAKMP SA
dst src state conn-id slot status
192.168.10.20 192.168.10.50 QM_IDLE 2056 0 ACTIVE
IPv6 Crypto ISAKMP SA
871w-rtr#
-----------------------------
I also want to keep Vlan1 up on my Cisco 871 even though I have nothing plugged into it. I can't even ping vlan1 on the Cisco 871 because the protocol layer is down.
The 10.35.1.0/24 network is on the inside of my network so the traffic flows through the inside interface of the Pix.
--------------------------------------
pix515(config)# sh vpn-sessiondb l2l
Session Type: LAN-to-LAN
Connection : 192.168.10.50
Index : 101 IP Addr : 10.44.44.0
Protocol : IKE IPsec
Encryption : 3DES Hashing : MD5
Bytes Tx : 127000 Bytes Rx : 1400
Login Time : 19:23:38 UTC Fri Jun 26 2009
Duration : 0h:06m:34s
--------------------------------------
pix515(config)# ping 10.44.44.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.44.44.2, timeout is 2 seconds:
?????
Success rate is 0 percent (0/5)
--------------------------------------
871w-rtr#ping 10.35.1.5 source 10.44.44.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.35.1.5, timeout is 2 seconds:
Packet sent with a source address of 10.44.44.2
.....
Success rate is 0 percent (0/5)
-----------------------------
Pix
pix515(config)# sh run nat
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
pix515(config)# sh access-list nonat
access-list nonat; 5 elements
access-list nonat line 1 extended permit ip 10.35.1.0 255.255.255.0 10.44.44.0 255.255.255.0 (hitcnt=0) 0x33ce6f2d
static (inside,DMZ) 10.44.44.0 10.44.44.0 netmask 255.255.255.0
crypto map cmap-vpncient 1 match address outside_cryptomap
crypto map cmap-vpncient 1 set peer 192.168.10.50
crypto map cmap-vpncient 1 set transform-set ESP-3DES-MD5
-----------------------------
871
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
crypto isakmp key ******** address 192.168.10.20
crypto isakmp invalid-spi-recovery
crypto isakmp keepalive 10
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
!
crypto map IPSec 1 ipsec-isakmp
set peer 192.168.10.20
set transform-set myset
match address tunnel
!
crypto map testmap 10 ipsec-isakmp
set peer 192.168.10.20
set security-association idle-time 300
set transform-set myset
match address tunnel
!
interface FastEthernet4
ip address 192.168.10.50 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map IPSec
!
interface Vlan1
description Users
ip address 10.44.44.2 255.255.255.0
ip tcp adjust-mss 1452
!
!
-----------------------------
871w-rtr#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0 unassigned YES unset up down
FastEthernet1 unassigned YES unset up down
FastEthernet2 unassigned YES unset up down
FastEthernet3 unassigned YES unset up down
FastEthernet4 192.168.10.50 YES manual up up
Dot11Radio0 unassigned YES NVRAM administratively down down
Vlan1 10.44.44.2 YES manual up down
-----------------------------
871w-rtr#ping 10.35.1.5 source 10.44.44.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.35.1.5, timeout is 2 seconds:
Packet sent with a source address of 10.44.44.2
.....
Success rate is 0 percent (0/5)
-----------------------------
871w-rtr#sh crypto isakmp sa
IPv4 Crypto ISAKMP SA
dst src state conn-id slot status
192.168.10.20 192.168.10.50 QM_IDLE 2056 0 ACTIVE
IPv6 Crypto ISAKMP SA
871w-rtr#
-----------------------------