I have a 1720 with 1 FastE, 1 Serial, and 1 DSL WIC installed. I want to use the Serial as the primary connection to the internet, and the dsl dialer as the backup. If you have not used DSL before, think of it as ISDN, as it used a dialer in the same manner.
My problem right now is if I disconnect my serial line, (I have the DSL up and running to the point that it connects and gets an address) I cannot get any packets through the router. From the router console, I can ping hosts outside my network no problem, but I can ping no one using a host on the LAN. I have looked at it everway to Sunday and cannot figure this one out. Thanks for any help. I pasted the config below.
Here is my config:
interface Serial0
ip address x.x.x.x 255.255.255.252
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
no fair-queue
service-module t1 timeslots 17-24
service-module t1 remote-alarm-enable
no cdp enable
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname test@bellsouth.net
ppp chap password 7 <removed>
!
ip nat pool mypool y.y.y.y z.z.z.z prefix-length 27
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 7 pool mypool overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
ip pim bidir-enable
!
!
logging history debugging
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 7 permit 10.0.0.0 0.0.0.255
access-list 7 permit 192.168.0.0 0.0.0.255
My problem right now is if I disconnect my serial line, (I have the DSL up and running to the point that it connects and gets an address) I cannot get any packets through the router. From the router console, I can ping hosts outside my network no problem, but I can ping no one using a host on the LAN. I have looked at it everway to Sunday and cannot figure this one out. Thanks for any help. I pasted the config below.
Here is my config:
interface Serial0
ip address x.x.x.x 255.255.255.252
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
no fair-queue
service-module t1 timeslots 17-24
service-module t1 remote-alarm-enable
no cdp enable
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname test@bellsouth.net
ppp chap password 7 <removed>
!
ip nat pool mypool y.y.y.y z.z.z.z prefix-length 27
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 7 pool mypool overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
ip pim bidir-enable
!
!
logging history debugging
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 7 permit 10.0.0.0 0.0.0.255
access-list 7 permit 192.168.0.0 0.0.0.255