I need to configure a core switch which is connected to two switches located on two floors of a building.
Floor 1, attached to Ethernet 0/1 on the core switch has two vlans : Vlan 60 192.168.51.1 (Data) and VLAN 100 - 192.168.3.1 (Voice)
Floor 2, attached to Ethernet 0/2 on the core switch has two vlans : Vlan 70 192.168.52.1 (Data) and vlan 100 192.168.4.1 (Voice)
I have to use the same vlan ID for voice on each floor but I need the DHCP server to send an address from the correct dhcp scope - ie each floor has its own class c subnet for voice.
My question is how do I ensure that when a dhcp request is issued in vlan 100 from Floor 1 it gets sent to the dhcp scope containing 192.168.3.x addresses, while vlan 100 dhcp requests on Floor 2 get sent to the scope 192.168.4.x.
I started to build the configuration - which is below - but I cant see how a dhcp request on vlan 100 for Floor 1 is going to be differentiated from a vlan 100 request from floor 2 by the switch.
Is there some way of directly associating a specific vlan with a specific physical interface or am I missing something.
Thanks
Current configuration : 2487 bytes
(4) --
!b
version 12.1
no service pad
Check
service timestamps debug uptime..line> 20x7eba700 (link_even
service timestamps log uptime
!
spanning-tree mode pvst SSS
spanning-tree extend system-id
!S
!
!
!
interface FastEthernet0/1 SS
switchport access vlan 50
switchport trunk encapsulation dot1q SS SSS
switchport mode trunk
!
interface FastEthernet0/2
SSS
switchport mode dynamic desirable
SSS
!
interface FastEthernet0/3ands for 40/8:
switchport mode dynamic desirable version
!
interface FastEthernet0/4configuration
switchport mode dynamic desirable (3) -- Change system configurati
!
interface FastEthernet0/5
(
switchport access vlan 60
? -- Help
switchport trunk encaps
!o
auto-neg
!i
interface FastEthernet0/8 trap link-statusus
switchport mode dynamic desirable DiffServ_Policy_ef-4646
!
interface FastEthernet0/9
port lacpmodede
switchport mode dynamic desirable
vlan pvid 3
!0
interface FastEthernet0/10uest 11
switchport access vlan 70e 0/1226
switchport mode access
snmp trap lin
!s
interface FastEthernet0/11e-policy in DiffServ_Polic
switchport mode dynamic desirable
port lacpmode
!
interface FastEthernet0/12ng-tree edgeportrmal' and
switchport mode dynamic desirable
vlan pvid 30
!
interface FastEthernet0/1313
exit
spannin
!t
interface FastEthernet0/16e switc
switchport mode dynamic desirable 30and manageme
!
interface FastEthernet0/17
exit
!
switchport mode dynamic desirableFSM7326P) #!
auto-neg
!i
interface FastEthernet0/18
snmp trap link-st
switchport mode dynamic desirable
interface 0/1668.51.10 255.25
!
interface FastEthernet0/19uto-negotiate.51.1
switchport mode dynamic desirable
service-policy
!n
interface FastEthernet0/20 60
switchport access vlan 100t lacpmode#
s
switchport mode access 50 for IP Phone, v
!
interface FastEthernet
spanning-tr
switchport mode dynamic desirable(FSM7326P
vlan pvid 30 na
!
interface GigabitEthernet0/1
dot1x user guest 17
switchport mode dynamic desirable
interface 0/18
ip helper-address 192.168.52.52
!
interface Vlan60
ip address 192.168.51.1 255.255.255.0
ip helper-address 192.168.52.52
!
interface Vlan70
ip address 192.168.52.1 255.255.255.0
!
interface Vlan100
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.167.52.52
!
ip classless
ip http server
!
!
line con 0
line vty 5 15
!
!
end
Switch#
Floor 1, attached to Ethernet 0/1 on the core switch has two vlans : Vlan 60 192.168.51.1 (Data) and VLAN 100 - 192.168.3.1 (Voice)
Floor 2, attached to Ethernet 0/2 on the core switch has two vlans : Vlan 70 192.168.52.1 (Data) and vlan 100 192.168.4.1 (Voice)
I have to use the same vlan ID for voice on each floor but I need the DHCP server to send an address from the correct dhcp scope - ie each floor has its own class c subnet for voice.
My question is how do I ensure that when a dhcp request is issued in vlan 100 from Floor 1 it gets sent to the dhcp scope containing 192.168.3.x addresses, while vlan 100 dhcp requests on Floor 2 get sent to the scope 192.168.4.x.
I started to build the configuration - which is below - but I cant see how a dhcp request on vlan 100 for Floor 1 is going to be differentiated from a vlan 100 request from floor 2 by the switch.
Is there some way of directly associating a specific vlan with a specific physical interface or am I missing something.
Thanks
Current configuration : 2487 bytes
(4) --
!b
version 12.1
no service pad
Check
service timestamps debug uptime..line> 20x7eba700 (link_even
service timestamps log uptime
!
spanning-tree mode pvst SSS
spanning-tree extend system-id
!S
!
!
!
interface FastEthernet0/1 SS
switchport access vlan 50
switchport trunk encapsulation dot1q SS SSS
switchport mode trunk
!
interface FastEthernet0/2
SSS
switchport mode dynamic desirable
SSS
!
interface FastEthernet0/3ands for 40/8:
switchport mode dynamic desirable version
!
interface FastEthernet0/4configuration
switchport mode dynamic desirable (3) -- Change system configurati
!
interface FastEthernet0/5
(
switchport access vlan 60
? -- Help
switchport trunk encaps
!o
auto-neg
!i
interface FastEthernet0/8 trap link-statusus
switchport mode dynamic desirable DiffServ_Policy_ef-4646
!
interface FastEthernet0/9
port lacpmodede
switchport mode dynamic desirable
vlan pvid 3
!0
interface FastEthernet0/10uest 11
switchport access vlan 70e 0/1226
switchport mode access
snmp trap lin
!s
interface FastEthernet0/11e-policy in DiffServ_Polic
switchport mode dynamic desirable
port lacpmode
!
interface FastEthernet0/12ng-tree edgeportrmal' and
switchport mode dynamic desirable
vlan pvid 30
!
interface FastEthernet0/1313
exit
spannin
!t
interface FastEthernet0/16e switc
switchport mode dynamic desirable 30and manageme
!
interface FastEthernet0/17
exit
!
switchport mode dynamic desirableFSM7326P) #!
auto-neg
!i
interface FastEthernet0/18
snmp trap link-st
switchport mode dynamic desirable
interface 0/1668.51.10 255.25
!
interface FastEthernet0/19uto-negotiate.51.1
switchport mode dynamic desirable
service-policy
!n
interface FastEthernet0/20 60
switchport access vlan 100t lacpmode#
s
switchport mode access 50 for IP Phone, v
!
interface FastEthernet
spanning-tr
switchport mode dynamic desirable(FSM7326P
vlan pvid 30 na
!
interface GigabitEthernet0/1
dot1x user guest 17
switchport mode dynamic desirable
interface 0/18
ip helper-address 192.168.52.52
!
interface Vlan60
ip address 192.168.51.1 255.255.255.0
ip helper-address 192.168.52.52
!
interface Vlan70
ip address 192.168.52.1 255.255.255.0
!
interface Vlan100
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.167.52.52
!
ip classless
ip http server
!
!
line con 0
line vty 5 15
!
!
end
Switch#