I have a Cisco 2821 which is my Internet router. I have 1 Cisco 2611XM that connects to another 2611XM via T1. The computers at the remote end connect OK to us and can access the Internet as long as I give them static IPs. They cannot get addresses assigned via DHCP server which is on our end. I have created different scopes for our site and theirs. In their scope their server is the IP of the remote 2611XM. I have added the IP helper-address command to point to the DHCP server, but nothing works. The DHCP service on the routers have not been disabled. DHCP works correctly for the systems that are on this side. Here are exerpts from config:
Router1:
interface FastEthernet0/0
ip address 172.16.5.1 255.255.255.0 secondary
ip address 10.11.32.5 255.255.255.0
ip helper-address 10.11.32.10
ip route-cache policy
ip policy route-map data
.
.
.
router eigrp 100
redistribute static
network 10.11.32.0 0.0.0.255
network 172.16.0.0 0.0.0.255
network 172.16.1.0 0.0.0.3
network 172.16.2.0 0.0.0.3
network 172.16.5.0 0.0.0.255
no auto-summary
!
ip classless
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
ip route 0.0.0.0 0.0.0.0 10.11.32.1
ip route 10.11.33.0 255.255.255.0 172.16.2.2
Router2 (remote):
interface FastEthernet0/1
description DATA Interface
ip address 10.11.33.1 255.255.255.0 secondary
ip address 172.16.4.1 255.255.255.0
ip helper-address 10.11.32.10
ip route-cache policy
ip policy route-map data
.
.
.
router eigrp 100
redistribute static
network 10.11.33.0 0.0.0.255
network 172.16.1.0 0.0.0.3
network 172.16.2.0 0.0.0.3
network 172.16.3.0 0.0.0.255
network 172.16.4.0 0.0.0.255
no auto-summary
!
ip classless
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
ip route 0.0.0.0 0.0.0.0 172.16.2.1
So why is this happening? Everything I have found just says add the ip helper-address command which I did. This has been like this for more than a year. I had quit searching for an answer, but I would like to resolve the problem.
Thanks.
Router1:
interface FastEthernet0/0
ip address 172.16.5.1 255.255.255.0 secondary
ip address 10.11.32.5 255.255.255.0
ip helper-address 10.11.32.10
ip route-cache policy
ip policy route-map data
.
.
.
router eigrp 100
redistribute static
network 10.11.32.0 0.0.0.255
network 172.16.0.0 0.0.0.255
network 172.16.1.0 0.0.0.3
network 172.16.2.0 0.0.0.3
network 172.16.5.0 0.0.0.255
no auto-summary
!
ip classless
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
ip route 0.0.0.0 0.0.0.0 10.11.32.1
ip route 10.11.33.0 255.255.255.0 172.16.2.2
Router2 (remote):
interface FastEthernet0/1
description DATA Interface
ip address 10.11.33.1 255.255.255.0 secondary
ip address 172.16.4.1 255.255.255.0
ip helper-address 10.11.32.10
ip route-cache policy
ip policy route-map data
.
.
.
router eigrp 100
redistribute static
network 10.11.33.0 0.0.0.255
network 172.16.1.0 0.0.0.3
network 172.16.2.0 0.0.0.3
network 172.16.3.0 0.0.0.255
network 172.16.4.0 0.0.0.255
no auto-summary
!
ip classless
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
ip route 0.0.0.0 0.0.0.0 172.16.2.1
So why is this happening? Everything I have found just says add the ip helper-address command which I did. This has been like this for more than a year. I had quit searching for an answer, but I would like to resolve the problem.
Thanks.