Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

ip default-network, i hate this command

Status
Not open for further replies.

norteldude78

IS-IT--Management
Nov 10, 2005
214
US
ok 3 routers:
corinth ---> sparta ---> athens ---> f0/0

all running eigrp
on the right side of athens is a network 10.1.1.0/24
this network shows up in corinth's routing table.
I use the following command on athens to mark the network as default:

ip default-network 10.0.0.0
I also advertise the network via eigrp.
yet corinth is not seeing it as the default route.
can you see why?

Here are my configs, I put descriptions on the interfaces.

corinth:

Code:
interface FastEthernet0/0
 description LAN interface
 ip address 172.16.4.1 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:DB8:0:4::1/64
!
interface Serial1/0
 description connectiopn to Sparta
 ip address 172.16.3.1 255.255.255.0
 ipv6 address 2001:DB8:0:3::1/64
 serial restart-delay 0
!
interface Serial1/3
 description connection to Athens
 ip address 172.16.5.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 172.16.0.0
 no auto-summary

sparta:

Code:
interface Serial1/0
 description connection to corinth
 ip address 172.16.3.2 255.255.255.0
 ipv6 address 2001:DB8:0:3::2/64
 serial restart-delay 0
!
interface Serial1/1
 description another router not in picture
 ip address 172.16.2.2 255.255.255.0
 ipv6 address 2001:DB8:0:2::2/64
 serial restart-delay 0
!
interface Serial1/2
 description connection to athens
 ip address 172.16.1.2 255.255.255.0
 ipv6 address 2001:DB8:0:1::2/64
 serial restart-delay 0
!
router eigrp 1
 network 172.16.0.0
 no auto-summary

athens:

Code:
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:DB8:0:A1::4/64
!
interface Serial1/2
 description connection to sparta
 ip address 172.16.1.4 255.255.255.0
 ipv6 address 2001:DB8:0:1::4/64
 serial restart-delay 0
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip default-network 10.0.0.0
!

Route tables:

corinth:

Code:
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 6 subnets
C       172.16.4.0 is directly connected, FastEthernet0/0
C       172.16.5.0 is directly connected, Serial1/3
D       172.16.6.0 [90/2195456] via 172.16.5.3, 00:11:42, Serial1/3
D       172.16.1.0 [90/2681856] via 172.16.3.2, 00:11:42, Serial1/0
D       172.16.2.0 [90/2681856] via 172.16.5.3, 00:11:45, Serial1/3
                   [90/2681856] via 172.16.3.2, 00:11:45, Serial1/0
C       172.16.3.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 1 subnets
D       10.1.1.0 [90/2707456] via 172.16.3.2, 00:11:41, Serial1/0

sparta:

Code:
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.4.0 [90/2195456] via 172.16.3.1, 00:11:58, Serial1/0
D       172.16.5.0 [90/2681856] via 172.16.3.1, 00:11:58, Serial1/0
                   [90/2681856] via 172.16.2.3, 00:11:58, Serial1/1
D       172.16.6.0 [90/2195456] via 172.16.2.3, 00:11:58, Serial1/1
C       172.16.1.0 is directly connected, Serial1/2
C       172.16.2.0 is directly connected, Serial1/1
C       172.16.3.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 1 subnets
D       10.1.1.0 [90/2195456] via 172.16.1.4, 00:11:58, Serial1/2

athens:
Code:
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 6 subnets
D       172.16.4.0 [90/2707456] via 172.16.1.2, 00:12:14, Serial1/2
D       172.16.5.0 [90/3193856] via 172.16.1.2, 00:12:14, Serial1/2
D       172.16.6.0 [90/2707456] via 172.16.1.2, 00:12:12, Serial1/2
C       172.16.1.0 is directly connected, Serial1/2
D       172.16.2.0 [90/2681856] via 172.16.1.2, 00:12:14, Serial1/2
D       172.16.3.0 [90/2681856] via 172.16.1.2, 00:12:14, Serial1/2
 *   10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

any ideas?
i tried changing the default-network command to 10.1.1.0 but this didn't work either.

thanks
 
Not sure this works for EIGRP...I have used this with static routing, but not a routing protocol. You may have to try redistribute commands (static/connected) for this to work like the ip default-network command. I imagine this is a lab? This may work with RIP, though...

Burt
 
Thanks Burt...yep, this is a lab. It's actually chapter 12, page 687 of Doyle's Routing tcp/ip volume 1. The first step is to do it with RIP and that worked. Then they do it with EIGRP...but mine isn't working...
 
I'll have to look that one up...I think I have both volumes...

Burt
 
I have both the hard copies and pdf versions of vol 1 and 2, but I can't find the hard copies at the moment (must be at work)...what is the name of the chapter?

Burt
 
chapter is called "default routes and on-demand routing" its volume 1 second edition. the example is in the 1st edition as well. the heading is "case study: The default-network command"

thanks
 
Do you have a fourth router at 172.16.2.x? If so, have you tried to plug the default-network in this router? It looks to me that with a topology of only 3 routers, that network might have to be one more hop away.

Burt
 
i have a fourth router plugged into sparta, this is kind of parallel to corinth. according to the book, which has example outputs this should work...im curious to know how eigrp marks a route as default in it's advertisements, it must use a flag of some sort...sparta would get this and most certainly pass it to the others, i mean the 10.1.1.0 route is in the tables...just not marking it as default

i could add another router off of corinth...
 
EIGRP marks the default route as a route, rather than 0.0.0.0

I labbed this up, and here are the routes before the command...

Argos#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.5.0 is directly connected, Serial0/1
D 172.16.1.0 [90/2172416] via 172.16.2.2, 00:00:08, Serial0/0
C 172.16.2.0 is directly connected, Serial0/0
D 172.16.3.0 [90/2681856] via 172.16.5.2, 00:00:08, Serial0/1
[90/2681856] via 172.16.2.2, 00:00:08, Serial0/0
D 10.0.0.0/8 [90/2684416] via 172.16.2.2, 00:00:08, Serial0/0
Argos#
Corinth#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.5.0 is directly connected, Serial0
D 172.16.1.0 [90/2684416] via 172.16.5.1, 00:00:52, Serial0
D 172.16.2.0 [90/2681856] via 172.16.5.1, 00:00:53, Serial0
C 172.16.3.0 is directly connected, Serial1
D 10.0.0.0/8 [90/3196416] via 172.16.5.1, 00:00:52, Serial0
Corinth#
Sparta>en
Sparta#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
D 172.16.5.0 [90/2681856] via 172.16.2.1, 00:01:12, Serial0/0
C 172.16.1.0 is directly connected, FastEthernet0/0
C 172.16.2.0 is directly connected, Serial0/0
C 172.16.3.0 is directly connected, Serial0/1
D 10.0.0.0/8 [90/2172416] via 172.16.1.2, 04:43:01, FastEthernet0/0
Sparta#
Athens>en
Athens#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
D 172.16.5.0/24 [90/2684416] via 172.16.1.1, 00:01:30, FastEthernet0/0
D 172.16.0.0/16 is a summary, 04:43:19, Null0
C 172.16.1.0/24 is directly connected, FastEthernet0/0
D 172.16.2.0/24 [90/2172416] via 172.16.1.1, 00:01:32, FastEthernet0/0
D 172.16.3.0/24 [90/2172416] via 172.16.1.1, 04:50:17, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 04:43:19, Null0
C 10.1.1.0/24 is directly connected, Serial0/0

and then...

Athens(config)#ip default-network 10.0.0.0
Athens(config)#exi
Athens#
05:07:52: %SYS-5-CONFIG_I: Configured from console by consolewr
Building configuration...
[OK]

and the routing tables now...

Athens#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 10.0.0.0

172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
D 172.16.5.0/24 [90/2684416] via 172.16.1.1, 00:02:44, FastEthernet0/0
D 172.16.0.0/16 is a summary, 04:44:32, Null0
C 172.16.1.0/24 is directly connected, FastEthernet0/0
D 172.16.2.0/24 [90/2172416] via 172.16.1.1, 00:02:46, FastEthernet0/0
D 172.16.3.0/24 [90/2172416] via 172.16.1.1, 04:51:31, FastEthernet0/0
* 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D* 10.0.0.0/8 is a summary, 04:44:33, Null0
C 10.1.1.0/24 is directly connected, Serial0/0
Athens#
Corinth#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR

Gateway of last resort is 172.16.5.1 to network 10.0.0.0

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.5.0 is directly connected, Serial0
D 172.16.1.0 [90/2684416] via 172.16.5.1, 00:03:07, Serial0
D 172.16.2.0 [90/2681856] via 172.16.5.1, 00:03:09, Serial0
C 172.16.3.0 is directly connected, Serial1
D* 10.0.0.0/8 [90/3196416] via 172.16.5.1, 00:00:42, Serial0
Corinth#
Argos#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.2.2 to network 10.0.0.0

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.5.0 is directly connected, Serial0/1
D 172.16.1.0 [90/2172416] via 172.16.2.2, 00:03:24, Serial0/0
C 172.16.2.0 is directly connected, Serial0/0
D 172.16.3.0 [90/2681856] via 172.16.5.2, 00:03:24, Serial0/1
[90/2681856] via 172.16.2.2, 00:03:24, Serial0/0
D* 10.0.0.0/8 [90/2684416] via 172.16.2.2, 00:00:59, Serial0/0
Argos#
Sparta#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.1.2 to network 10.0.0.0

172.16.0.0/24 is subnetted, 4 subnets
D 172.16.5.0 [90/2681856] via 172.16.2.1, 00:03:41, Serial0/0
C 172.16.1.0 is directly connected, FastEthernet0/0
C 172.16.2.0 is directly connected, Serial0/0
C 172.16.3.0 is directly connected, Serial0/1
D* 10.0.0.0/8 [90/2172416] via 172.16.1.2, 00:01:15, FastEthernet0/0

It works for me, labbed up exactly as the book. Note I consoled from one router to the next, and the next, and so on---too lazy for vty passwords...lol

Corinth=2503, Argos, Sparta and Athens=2620's. What router do you have connected to Sparta? Is this where you are putting the command "ip default-network 10.0.0.0"? Is your topology like Corinth, Argos and Sparta all in a triangle, and off of Sparta is Athens?

Also, remember that for networks to be advertised, the links have to be up, so you must have something connected to 10.0.0.0

Burt
 
For those without access to the book, the topology is...

Corinth
| \
| \
| \
| Sparta---------Athens--------another router
| /
| /
| /
Argos

Burt
 
According to the link I posted, if you use the ip default-network command you have to have a static route pointing that network to the proper next hop.
 
I don't...

Athens>en
Athens#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Athens
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
no ip directed-broadcast
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
clockrate 4000000
!
router eigrp 69
network 10.0.0.0
network 172.16.0.0
!
ip classless
ip default-network 10.0.0.0
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

Sparta#sh run
Building configuration...

Current configuration : 843 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Sparta
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
no ftp-server write-enable
!
!
!
!
!
no crypto isakmp ccm
!
!
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
no fair-queue
no dce-terminal-timing-enable
!
interface Serial0/1
ip address 172.16.3.1 255.255.255.0
no dce-terminal-timing-enable
!
router eigrp 69
network 172.16.0.0
auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

Argos>en
Argos#sh run
Building configuration...

Current configuration : 862 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Argos
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
no ip domain lookup
!
no ftp-server write-enable
!
!
!
!
!
no crypto isakmp ccm
!
!
!
interface FastEthernet0/0
ip address 172.16.6.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.1 255.255.255.0
no fair-queue
no dce-terminal-timing-enable
!
interface Serial0/1
ip address 172.16.5.1 255.255.255.0
no dce-terminal-timing-enable
!
router eigrp 69
network 172.16.0.0
auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

Corinth>en
Corinth#sh run
Building configuration...

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Corinth
!
!
!
!
interface Ethernet0
ip address 172.16.4.1 255.255.255.0
!
interface Serial0
ip address 172.16.5.2 255.255.255.0
no ip mroute-cache
no fair-queue
clockrate 4000000
!
interface Serial1
ip address 172.16.3.1 255.255.255.0
clockrate 4000000
!
interface BRI0
no ip address
shutdown
!
router eigrp 69
network 172.16.0.0
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Athens is connected to a 2620XM, int s0/1, ip add 10.1.1.2/24...

Burt
 
I would just like to throw in the perfectly useless comment that the ip default-network command is one of the reasons I hate EIGRP. If I need to propagate a default route through a network, I use OSPF. EIGRP is just so weird about it.
 
oh my goodness, you will never guess what the problem was...i'm sitting here just completely stumped looking at me config on athens and I notice "no auto-summary"...something I do every time i configure eigrp...

i remember reading about ip-default network needing a classful network. I just had to find the link so here it is:


....so I went back to auto-summary and immediately the route had * next to it, now it's working...

man, I almost gave up...i kind of feel like the giants against patriots...never give up and you will conquer!

thanks everyone, im studying for ccie lab so i am sure you will see many more posts from me :)
 
I was just about to recommend you change the "no auto-summary" to "auto summary".....just joking....

Good catch...my head is still spinning from looking at your and burts configs. Good stuff.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top