I need help please.
I need to restrict remote vpn access to a lan-side server (192.168.1.2 natted to 41.204.56.251). At the moment any IP address from the internet can access the server once the person knows the nat ip and the password.
How do I allow vnc access only to IP address 41.204.54.98?
Below is my current config:
**********************************************************
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 41.204.56.250 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
switchport mode trunk
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
ip address 10.200.18.2 255.255.255.0
ip virtual-reassembly
!
interface Vlan3
ip address 172.16.1.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 41.204.56.249
ip route 10.1.0.0 255.255.0.0 10.200.18.1
ip route 10.76.100.0 255.255.255.0 10.200.18.1
ip route 192.168.0.0 255.255.255.0 10.200.18.1
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 10 interface FastEthernet0/1 overload
ip nat inside source static 192.168.1.2 41.204.56.251
ip nat inside source static 192.168.1.3 41.204.56.252
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
!
**************************************************
Thanks
I need to restrict remote vpn access to a lan-side server (192.168.1.2 natted to 41.204.56.251). At the moment any IP address from the internet can access the server once the person knows the nat ip and the password.
How do I allow vnc access only to IP address 41.204.54.98?
Below is my current config:
**********************************************************
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 41.204.56.250 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
switchport mode trunk
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
ip address 10.200.18.2 255.255.255.0
ip virtual-reassembly
!
interface Vlan3
ip address 172.16.1.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 41.204.56.249
ip route 10.1.0.0 255.255.0.0 10.200.18.1
ip route 10.76.100.0 255.255.255.0 10.200.18.1
ip route 192.168.0.0 255.255.255.0 10.200.18.1
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 10 interface FastEthernet0/1 overload
ip nat inside source static 192.168.1.2 41.204.56.251
ip nat inside source static 192.168.1.3 41.204.56.252
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
!
**************************************************
Thanks