Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

How to Setup IPX over a PPP using the Aux Port 2

Status
Not open for further replies.
May 9, 2002
9
US
I have two 2501's connected and setup using the script following this message .

I need to setup IPX and have not done so before.

IP works fine. Could someone advise me on the intricacies of IPX.

Thanks,

Eric

bottom#show conf
Using 460 out of 32762 bytes
!
version 11.3
no service password-encryption
!
hostname Router
!
!
!
!
interface Ethernet0
ip address 192.168.14.100 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.10.2 255.255.255.0
encapsulation ppp
async dynamic routing
async mode dedicated
!
ip classless
ip route 192.168.13.0 255.255.255.0 192.168.10.1
!
line con 0
line aux 0
line vty 0 4
login
!
end


Top Router

Using 463 out of 32762 bytes
!
version 11.3
no service password-encryption
!
hostname Router
!
!
!
!
interface Ethernet0
ip address 192.168.13.100 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.10.1 255.255.255.0
encapsulation ppp
async dynamic routing
async mode dedicated
!
no ip classless
ip route 192.168.14.0 255.255.255.0 192.168.10.2
!
line con 0
line aux 0
line vty 0 4
login
!
end

top#
 
Fairly simple:
This default may not be suitable for your PPP link if you are worried about Broadcast traffic..keep in mind that SAP and ipx RIP are heavy and continual traffic sources.
Note:
(The ipx address is 80 bits + 16 bits for a socket descriptor)

(config)ipx routing (optional address)
(config-if) ipx network ABC

#caveat: be aware that this command #takes an optional encapsulation #command, if you are not familiar with #the mess that is ipx
#encapsulation and the cisco equivalents
#you should really get a good book.

Same thing on the other router with a different ipx network.
Now you can try the remote host keeping in mind that you append the 48 bit mac style address to the net address
in dot quad format.

ping ipx ABC.01ef.cdd4.7809
or just ping ipx the broadcast ipx address:
ping ipx ABC.ffff.ffff.ffff

Hope this helps.
 
I have added the following commands:

Top Router

ipx routing 0010.7b7f.11da

e0 has ipx network 100
async1 has ipx network 200


Bottom Router

ipx routing 0010.7b7f.14a0

e0 has ipx network 200
async1 has ipx network 100

I can no ipx ping the local address from each router:

ie ipx ping 100.0010.7b7f.11da and get a response, but can not ping across the routers

Any ideas???
 
Dont forget as soon as you enable IPX, the router will enable RIP1 without asking or even telling you. If you plan to use something else, then you need to say no rip and the network ID.

MikeS
Find me at
"Take advantage of the enemy's unreadiness, make your way by unexpected routes, and attack unguarded spots."
Sun Tzu
 
wybnormal
..long time no see..
Please remember that ipx RIP and ip RIP are totally
different beasts.
Enabling ipx does NOT enable ip RIP1.
There is no such thing as ipx rip1 only ipx rip.
There are only ipx rip, and nlsp in a netware
environment, eigrp can also be used with cisco
gear I believe. If this is what you meant please
disregard this.
Also just disabling ipx rip and assigning a
an internal address number will accomplish nothing.
You must enable nlsp or use eigrp in addition or
assign static routes. I would suggest hanging tough with ipx rip till you have a working config.

Eouderkirk,
Here are commands to tshoot your issue:
#show ipx ?
show ipx traffic
show ipx route
debug ipx routing activity
ios 12.0+ you can also use the trace ipx command.
Also remember your encapsulations must be the same.



Write back if you need more help.
 
WYBNORMAL,

UNFORTUNATELY, THIS IS MY FIRST IPX ROUTER IMPLEMENTATION.
I HAVE ALL OF MY IP EQUIPMENT WORKING, AND NEED TO SETUP A NOVELL IPX LOGON DUE TO ONE PROGRAM THAT IS ANCIENT. AFTER REVIEWING THE AVAILBLE COMMANDS FOR IPX STATIC ROUTES, I DO NOT UNDERSTAND HOW TO IMPLEMENT THIS, I HAVE NOT USED NLSP OR EIGRP. IF YOU DO NOT MIND POSTING AN EXAMPLE BASED ON MY CURRENT SETUP, I WOULD APPRECIATE IT. i HAVE NO OTHER NOVELL, OR IPX IN MY NETWORK. THE ROUTER IS VERSION 11.3.

BOTH ROUTERS SHOW THAT THE IPX ROUTES ARE CONNECTED AS FOLLOWS:

bottom#SHOW IPX ROUTE
Codes: C - Connected primary network, c - Connected secondary network
S - Static, F - Floating static, L - Local (internal), W - IPXWAN
R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
s - seconds, u - uses, U - Per-user static

2 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C 100 (PPP), As1
C 200 (NOVELL-ETHER), Et0

IPX DEBUGGING SHOWS:
IPXRIP: positing full update to 100.ffff.ffff.ffff via Async1 (broadcast)
IPXRIP: Update len 40 src=100.0010.7b7f.14a0, dst=100.ffff.ffff.ffff(453)
network 200, hops 1, delay 31
IPXRIP: positing full update to 200.ffff.ffff.ffff via Ethernet0 (broadcast)
IPXRIP: Update len 40 src=200.0010.7b7f.14a0, dst=200.ffff.ffff.ffff(453)
network 100, hops 1, delay 2
IPXRIP: positing full update to 100.ffff.ffff.ffff via Async1 (broadcast)
IPXRIP: Update len 40 src=100.0010.7b7f.14a0, dst=100.ffff.ffff.ffff(453)
network 200, hops 1, delay 31

I WOULD APPRECIATE ANY ASSISTANCE.
 
Do you have ipx rip active on both routers?
This output just shows that this router knows about directly connected network interfaces.
Are your router ppp interfaces on the same ipx network(100?), it doesn't look like it from here.
 
Marsd-

quite correct and thanks for the correction. I had Ip on the brain and typed RIP1.. IPX RIP is IPX RIP. EIGRP is used with IPX.. and it works pretty well if put together correctly. A bit of a memory hog if you have lots of routes and they are not able to be summerized.

Honestly, I would forgo the static and just use the RIP. It's pretty bulletproof for what you want to do.

Here is everything you need to know to config IPX on yoru router.

Short version
R1 R2
LAN-----------WAN-----------LAN
IPX ABC IPX CDE ACD

Each segment has it's own IPX network ID. E0 of R1 is network ABC. The serial ports are network CDE and the E9 of R2 is ACD.

The printout you pasted only shows the connected (c) routes, no RIP or other routes like a static route.

I assume you are trying to configure the Async as the *wan* side?

R1
ipx routing <mac address if you are so inclined>

interface E0
ipx network ABC encapsulation novell-ether
!
!
ipx router rip
network ABC
network CDE

R2
ipx routing <mac address if you are so inclined>

interface E0
ipx network ACD encapsulation novell-ether
!
!
ipx router rip
network ACD
network CDE

Here everyone knows everyone.

If I missed something, I'm sure it will be pointed out to me[wink]

MikeS
Find me at
&quot;Take advantage of the enemy's unreadiness, make your way by unexpected routes, and attack unguarded spots.&quot;
Sun Tzu
 
marsd,

Thank you for your input, i set the async network to the ipx of the other router. Was this suppose to be set to the same as the eth ipx network?

Regards,

Eric
 
No, pls read wybnormals last post, that just about takes care of what is what.
Good luck with your ipx net.
Eventually you may want to add sap filters
and tweak your rip updates, but for now
everything should be good.

Seeya.
 
Top Router

ipx routing 0010.7b7f.11da

e0 has ipx network 100
async1 has ipx network 200


Bottom Router

ipx routing 0010.7b7f.14a0

e0 has ipx network 200 ; this is incorrect. Make it 300. It's a different segment then the async so it needs it's own IPX network ID (subnet)

async1 has ipx network 100 ; this is incorrect. Make it 200 to match the other side of the sync link. Both Asyncs are in the same IPX network (subnet) so they need to both be in the 200 ipx network

MikeS


Find me at
&quot;Take advantage of the enemy's unreadiness, make your way by unexpected routes, and attack unguarded spots.&quot;
Sun Tzu
 
Thanks all, I knew I was missing something simple. I have searched this forum in the past, and have noted a very technical audience.

Regards,

Eric
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top