I wanted to know if anyone can help with configing a router with two T-1 connections to two different providers for failover. Will i need to work with both ISP and configure BGP for Failover? Thanks for any help.
Hi,
If you are running a default route to your current ISP i.e. no BGP, just run another static route to your back-up ISP but with a higher distance metric i.e.
ip route 0.0.0.0 0.0.0.0 ip_address_of_primary_ISP
ip route 0.0.0.0 0.0.0.0 ip_address_of_back-up_ISP 250
If your T1 is used for inbound as well as outbound traffic, then you'll need to use BGP or get creative with DNS. Otherwise, if your primary router is down any addresses assigned by that ISP will be unreachable.
Pretty much. You'll probably want to receive updates for all networks, and advertise only yours. Here's how I did it:
! list all of my public network segments to advertise
access-list 10 permit x.x.x.x 0.0.0.31
access-list 10 permit y.y.y.y 0.0.0.255
access-list 10 deny any
route-map localonly permit 10
match ip address 10
router bgp MY_ASN
no synchronization
bgp log-neighbor-changes
network x.x.x.x mask 255.255.255.224
network y.y.y.y mask 255.255.255.0
neighbor 10.99.2.1 remote-as MY_ASN
neighbor 10.99.2.1 description IBGP to my other router
neighbor 10.99.2.1 update-source Loopback0
neighbor 10.99.2.1 version 4
neighbor 10.99.2.1 next-hop-self
neighbor my.isp.ip.addr remote-as ISP_ASN
neighbor my.isp.ip.addr description EBGP to my ISP router
neighbor my.isp.ip.addr version 4
neighbor my.isp.ip.addr route-map localonly out
In this case, I had two routers, each running BGP with a different ISP and between themselves. Also, they ran HSRP on the LAN side.
I wanted to post my configure that I’m planning to deploy to see if someone can point out if there's something wrong with it.
interface Serial1/0
description connected to XO
ip address *.*.*.* 255.255.255.252
no ip unreachables
no ip route-cache
encapsulation ppp
interface FastEthernet0/0
ip address 207.*.*.* 255.255.255.0
no ip unreachables
speed auto
duplex auto
interface Serial1/1
description connected to SPRINT
ip address 144.*.*.* 255.255.255.252
no ip unreachables
no ip route-cache
encapsulation ppp
interface FastEthernet0/1
description connect to CISCO 4000
ip address 67.*.*.* 255.255.255.0
no ip unreachables
keepalive 30
duplex auto
speed auto
router bgp MY AS
no synchronization
bgp log-neighbor-changes
network 67.*.*.*
network 207.*.*.*
neighbor *.*.*.* remote-as My ISP
neighbor *.*.*.* remote-as My 2ndISP
no auto-summary
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1/0
ip route 0.0.0.0 0.0.0.0 144.*.*.* 100
no ip http server
Two T1's for redundency is great but for most businesses it really does not work. Most of the time you will find that it is the same copper for both coming into the building and terminating to the same CO. We found this to be true for our location and there was not an option for two seperate copper providers and different CO's. In light of that we opted to go with one provider and bond two T1 lines together into one 3 meg pipe. If one T1 fails we do not lose connection just 50% of the bandwidth. If the CO office goes down or the fiber seeking backhoe digs up the line we are dead even with two providers.
U can set bgp local pref >100 for ur primary link neighbour.
f.e.
!
neighbor ip-primary-isp bgp local preference 200 .
!
Or use a route-map to set local pref for incoming updates.
!
neighbor ip-primary-isp route-map SET-LOCAL-PREF in
!
!
route-map SET-LOCAL-PREF permit 10
set local-preference 200
!
Can you tell me but are you interested in simply having one link as a redundant connection OR load-sharing outbound and/or inbound?
With your current config, you'll send all outbound traffic to the ISP on s1/0. Inbound traffic may semi load-balance however - depending which ISP typically has the shorter AS path to your network from any particular destination.
For instance, if ISP1 is an international tier 1 ISP, chances are he will have peering agreements with major AS's around the globe. If ISP2 is more of a national carrier and has many national peering arrangements, you may find he provides the better path back to your network for national sites.
As you may be able to see you may already achieve some form of inbound load-balancing. I'd probably put both links on MRTG or Concord so I could get a historical view of utilisation in and out of those ISP links to see if any changes were required to achieve the balance I wanted.
Anyways let me know what your intention are: redundant or inbound/outbound load-balancing. I may be able to advise further.
Hey thanks everyone for your help on this project. KiscoKid my intention is to provide redundant links. The load-balancing is something i would like to work on later thanks for your help.
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.