I am trying to connect a Cisco 3620 to a Linksys BEFSX41 using a VPN. The Linksys has an easy setup but I can't get the Cisco to make a VPN connection to the Linksys.
It doesn't look like the 1st Proposal was ever done. On the Linksys, I told it to connect. It send the first message to the Cisco, but there is no response.
Is there something I need to tell the Cisco to start the VPN tunnel? Does the ISAKMP handshake occur first? Can I look at the Cisco's debug statements if I am NOT connecting to another Cisco?
Here is the Config:
CISCO 3620
Configuration with Firewall and NAT
NavRouter#show run
Building configuration...
Current configuration : 2893 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NavRouter
!
enable password XXXXXXX
!
ip subnet-zero
ip name-server YY.YY.28.12
!
crypto isakmp policy 1
hash md5
authentication pre-share
!
crypto isakmp key cisco123 address x.x.x.x
crypto ipsec transform-set rtpset esp-des esp-md5-hmac
!
crypto map cm-cryptomap 1 ipsec-isakmp
set peer x.x.x.x
set transform-set rtpset
match address 105
!
ip inspect max-incomplete high 1100
ip inspect one-minute high 1100
ip inspect name Ethernet_1_0 tcp
ip inspect name Ethernet_1_0 udp
ip inspect name Ethernet_1_0 cuseeme
ip inspect name Ethernet_1_0 ftp
ip inspect name Ethernet_1_0 h323
ip inspect name Ethernet_1_0 rcmd
ip inspect name Ethernet_1_0 realaudio
ip inspect name Ethernet_1_0 smtp
ip inspect name Ethernet_1_0 streamworks
ip inspect name Ethernet_1_0 vdolive
ip inspect name Ethernet_1_0 sqlnet
ip inspect name Ethernet_1_0 tftp
ip inspect name Ethernet_0_0 smtp
ip inspect name Ethernet_0_0 tcp
ip inspect name Ethernet_0_0 udp
ip inspect name Ethernet_0_0 ftp
ip audit notify log
ip audit po max-events 100
!
interface BRI0/0
no ip address
shutdown
!
interface Ethernet0/0
description connected to Internet
ip address XX.XX.99.225 255.255.255.248
ip access-group 103 in
ip nat outside
ip inspect Ethernet_0_0 in
crypto map cm-cryptomap
!
interface Serial0/0
no ip address
shutdown
!
interface BRI1/0
no ip address
shutdown
!
interface Ethernet1/0
description connected to EthernetLAN
ip address 192.168.3.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip inspect Ethernet_1_0 in
!
interface Serial1/0
no ip address
shutdown
!
ip default-gateway XX.XX.99.230
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static 192.168.3.200 XX.XX.99.226
ip nat inside source static 192.168.3.199 XX.XX.99.227
ip nat inside source static tcp 192.168.3.201 3000 XX.XX.99.225 3000 extendable
ip nat inside source static tcp 192.168.3.200 80 XX.XX.99.225 80 extendable
ip nat inside source static tcp 192.168.3.200 20 XX.XX.99.225 20 extendable
ip nat inside source static tcp 192.168.3.201 110 XX.XX.99.225 110 extendable
ip nat inside source static tcp 192.168.3.201 25 XX.XX.99.225 25 extendable
ip nat inside source static tcp 192.168.3.200 21 XX.XX.99.225 21 extendable
ip nat inside source static tcp 192.168.3.200 412 XX.XX.99.226 412 extendable
ip nat inside source static udp 192.168.3.200 412 XX.XX.99.226 412 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 XX.XX.99.230
no ip http server
!
access-list 1 permit 192.168.3.0 0.0.0.255
access-list 102 permit ip any any
access-list 103 permit tcp any host XX.XX.99.225 eq www
access-list 103 permit tcp any host XX.XX.99.225 eq 3000
access-list 103 permit tcp any host XX.XX.99.225 eq ftp
access-list 103 permit tcp any host XX.XX.99.225 eq smtp
access-list 103 permit tcp any host XX.XX.99.225 eq pop3
access-list 103 permit tcp any host XX.XX.99.226 eq 412
access-list 103 permit udp any host XX.XX.99.226 eq 412
access-list 103 permit icmp any host XX.XX.99.225
access-list 103 deny ip any any
access-list 105 permit ip 192.168.3.0 0.0.0.255 192.168.90.0 0.0.0.255
access-list 150 deny ip 192.168.3.0 0.0.0.255 192.168.90.0 0.0.0.255
access-list 150 permit ip 192.168.3.0 0.0.0.255 any
!
route-map nonat permit 10
match ip address 150
!
line con 0
exec-timeout 0 0
password XXXX
login
line aux 0
line vty 0 4
password XXXX
login
!
end
Thanks in advance for your help,
Nav
It doesn't look like the 1st Proposal was ever done. On the Linksys, I told it to connect. It send the first message to the Cisco, but there is no response.
Is there something I need to tell the Cisco to start the VPN tunnel? Does the ISAKMP handshake occur first? Can I look at the Cisco's debug statements if I am NOT connecting to another Cisco?
Here is the Config:
CISCO 3620
Configuration with Firewall and NAT
NavRouter#show run
Building configuration...
Current configuration : 2893 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NavRouter
!
enable password XXXXXXX
!
ip subnet-zero
ip name-server YY.YY.28.12
!
crypto isakmp policy 1
hash md5
authentication pre-share
!
crypto isakmp key cisco123 address x.x.x.x
crypto ipsec transform-set rtpset esp-des esp-md5-hmac
!
crypto map cm-cryptomap 1 ipsec-isakmp
set peer x.x.x.x
set transform-set rtpset
match address 105
!
ip inspect max-incomplete high 1100
ip inspect one-minute high 1100
ip inspect name Ethernet_1_0 tcp
ip inspect name Ethernet_1_0 udp
ip inspect name Ethernet_1_0 cuseeme
ip inspect name Ethernet_1_0 ftp
ip inspect name Ethernet_1_0 h323
ip inspect name Ethernet_1_0 rcmd
ip inspect name Ethernet_1_0 realaudio
ip inspect name Ethernet_1_0 smtp
ip inspect name Ethernet_1_0 streamworks
ip inspect name Ethernet_1_0 vdolive
ip inspect name Ethernet_1_0 sqlnet
ip inspect name Ethernet_1_0 tftp
ip inspect name Ethernet_0_0 smtp
ip inspect name Ethernet_0_0 tcp
ip inspect name Ethernet_0_0 udp
ip inspect name Ethernet_0_0 ftp
ip audit notify log
ip audit po max-events 100
!
interface BRI0/0
no ip address
shutdown
!
interface Ethernet0/0
description connected to Internet
ip address XX.XX.99.225 255.255.255.248
ip access-group 103 in
ip nat outside
ip inspect Ethernet_0_0 in
crypto map cm-cryptomap
!
interface Serial0/0
no ip address
shutdown
!
interface BRI1/0
no ip address
shutdown
!
interface Ethernet1/0
description connected to EthernetLAN
ip address 192.168.3.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip inspect Ethernet_1_0 in
!
interface Serial1/0
no ip address
shutdown
!
ip default-gateway XX.XX.99.230
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static 192.168.3.200 XX.XX.99.226
ip nat inside source static 192.168.3.199 XX.XX.99.227
ip nat inside source static tcp 192.168.3.201 3000 XX.XX.99.225 3000 extendable
ip nat inside source static tcp 192.168.3.200 80 XX.XX.99.225 80 extendable
ip nat inside source static tcp 192.168.3.200 20 XX.XX.99.225 20 extendable
ip nat inside source static tcp 192.168.3.201 110 XX.XX.99.225 110 extendable
ip nat inside source static tcp 192.168.3.201 25 XX.XX.99.225 25 extendable
ip nat inside source static tcp 192.168.3.200 21 XX.XX.99.225 21 extendable
ip nat inside source static tcp 192.168.3.200 412 XX.XX.99.226 412 extendable
ip nat inside source static udp 192.168.3.200 412 XX.XX.99.226 412 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 XX.XX.99.230
no ip http server
!
access-list 1 permit 192.168.3.0 0.0.0.255
access-list 102 permit ip any any
access-list 103 permit tcp any host XX.XX.99.225 eq www
access-list 103 permit tcp any host XX.XX.99.225 eq 3000
access-list 103 permit tcp any host XX.XX.99.225 eq ftp
access-list 103 permit tcp any host XX.XX.99.225 eq smtp
access-list 103 permit tcp any host XX.XX.99.225 eq pop3
access-list 103 permit tcp any host XX.XX.99.226 eq 412
access-list 103 permit udp any host XX.XX.99.226 eq 412
access-list 103 permit icmp any host XX.XX.99.225
access-list 103 deny ip any any
access-list 105 permit ip 192.168.3.0 0.0.0.255 192.168.90.0 0.0.0.255
access-list 150 deny ip 192.168.3.0 0.0.0.255 192.168.90.0 0.0.0.255
access-list 150 permit ip 192.168.3.0 0.0.0.255 any
!
route-map nonat permit 10
match ip address 150
!
line con 0
exec-timeout 0 0
password XXXX
login
line aux 0
line vty 0 4
password XXXX
login
!
end
Thanks in advance for your help,
Nav