Okay first off sorry I am a newb at this Cisco stuff. I'm only used to configuring linksys routers with handly web access
For all I know the 1721 is configured for the T1, but DHCP is not. Can someone hint him how I can set this up for NAT'd dhcp?
I guess I will be doing this with hyperterminal?
ANY HELP AT ALL WOULD BE GREATLY APPRECIATED!!!
Here is the initial setup of the router:
> router>enable
> router#config t
> router(config)#int [name of the interface ] <---LAN interface
> router(config-if)#ip address [ internal ip ] [subnet mask ]
> router(config-if)#no shutdown router(config-if)#exit Enter the
> configuration of the outside interface router(config)#int [name of the
> interface ] <---WAN interface router(config)#ip address [ external ip
> ] [subnet mask ] router(config-if)#no shutdown
> router(config-if)#ctrl-z
>
> To check the status of the interfaces use the command router#show ip
> interface brief they should have an up up status . If they are down
> check the physical connection of the interface.
> If you are not sure if the ip address that you are using is valid you
> can check it with the Subnet Calculator.
>
> >
>
>
> ROUTING TO THE ISP
> router>enable
> router#config t
> router(config)#ip route 0.0.0.0 0.0.0.0 x.x.x.x. <------- x.x.x.x is
> the addres of the ISP, default gateway router(config)#ip routing
> router(config)#ip classless
>
>
> NAT ( Remember that you need to use a public ip address to enable the
> internal LAN to reach the Internet )
> router>enable
> router#config t
> router(config)#ip nat inside source list 120 interface [name of the
> outisde interface] overload router(config)#access-list 120 permit ip
> [address of the LAN] [inverse mask of the LAN ] any router(config)#int
> [name of the interface ] <---LAN interface router(config-if)#ip nat
> inside router(config-if)#exit router(config)#int [name of the
> interface ] <---INTERNET interface router(config-if)#ip nat outside
> router(config-if)#exit
>
> If you have a internal server ( web, exchange for example ) that the
> Internet will access you need to use static nat .
>
> router>enable
> router#config t
> router(config)#ip nat inside source static x.x.x.x y.y.y.y <----where
> x.x.x.x is the internal ip and y.y.y.y is the public ip
> router(config)#exit
>
>
>
>
> DHCP
> To make the router work as a DHCP server :
> router>enable
> router#config t
> router(config)#service dhcp or
> router(config)#ip bootp
> router(config)#ip dhcp pool TEST
> router(dhcp-config)# network X.X.X.X Y.Y.Y.Y ( ip address and subnet
> mask that the LAN will use ) router(dhcp-config)#dns-server {ip of dns
> 1} {ip of dns 2} router(dhcp-config)#default-router Z.Z.Z.Z ( internal
> ip address of the
> router)
> router(dhcp-config)#ctrl-z <----to exit
> -----------------------------------------------------------
>
> ip dhcp excluded-address 172.16.1.100 172.16.1.103
>
> ip dhcp excluded-address 172.16.2.100 172.16.2.103
> --------------------------------------------------
> To use a remote dhcp server
> router>enable
> router#config t
> router(config)#ip helper-address x.x.x.x <---- ip address of the
> remote dhcp server router(config)#exit
>
> ---------------------------------------------
> Router(config)# ip address dhcp
>
> ACCESS-LIST
>
> To enable basic security on the router
> router>enable
> router#config t
> router(config)#access-list 120 permit tcp any any established
> router(config)#access-list 120 permit udp any eq 53 any
> router(config)#access-list 120 permit icmp any any echo-reply
> router(config)#int [name of the interface going to the internet ]
> router(config-if)# ip access-group 120 in router(config)#ctrl-z <--to
> exit
>
> This access-list will prevent outside connections and pings although
> it allows you to ping the outside, have DNS resolution and get a reply
> when the trafic started in your LAN, all other incoming traffic will
> be dropped so if you are using an internal device that the Internet
> will reach you need to specify it . There is a list of common ports in
> this link :
>
> >
> To remove an access-list you first need to disable it :
> router>enable
> router#config t
> router(config)#int [name of the interface going to the internet ]
> router(config-if)#no ip access-group 120 in Then you can modify it on
> a note pad, erase it and paste the new access-list back in config t
> mode:
>
> PASSWORDS
> To have a telnet password
> router>enable
> router#config t
> router(config)#line vty 0 4
> router(config-line)# login
> router(config-line)# password cisco
>
> TO SAVE THE CONFIGURATION :
> router#wr mem
THANKS!
For all I know the 1721 is configured for the T1, but DHCP is not. Can someone hint him how I can set this up for NAT'd dhcp?
I guess I will be doing this with hyperterminal?
ANY HELP AT ALL WOULD BE GREATLY APPRECIATED!!!
Here is the initial setup of the router:
> router>enable
> router#config t
> router(config)#int [name of the interface ] <---LAN interface
> router(config-if)#ip address [ internal ip ] [subnet mask ]
> router(config-if)#no shutdown router(config-if)#exit Enter the
> configuration of the outside interface router(config)#int [name of the
> interface ] <---WAN interface router(config)#ip address [ external ip
> ] [subnet mask ] router(config-if)#no shutdown
> router(config-if)#ctrl-z
>
> To check the status of the interfaces use the command router#show ip
> interface brief they should have an up up status . If they are down
> check the physical connection of the interface.
> If you are not sure if the ip address that you are using is valid you
> can check it with the Subnet Calculator.
>
> >
>
>
> ROUTING TO THE ISP
> router>enable
> router#config t
> router(config)#ip route 0.0.0.0 0.0.0.0 x.x.x.x. <------- x.x.x.x is
> the addres of the ISP, default gateway router(config)#ip routing
> router(config)#ip classless
>
>
> NAT ( Remember that you need to use a public ip address to enable the
> internal LAN to reach the Internet )
> router>enable
> router#config t
> router(config)#ip nat inside source list 120 interface [name of the
> outisde interface] overload router(config)#access-list 120 permit ip
> [address of the LAN] [inverse mask of the LAN ] any router(config)#int
> [name of the interface ] <---LAN interface router(config-if)#ip nat
> inside router(config-if)#exit router(config)#int [name of the
> interface ] <---INTERNET interface router(config-if)#ip nat outside
> router(config-if)#exit
>
> If you have a internal server ( web, exchange for example ) that the
> Internet will access you need to use static nat .
>
> router>enable
> router#config t
> router(config)#ip nat inside source static x.x.x.x y.y.y.y <----where
> x.x.x.x is the internal ip and y.y.y.y is the public ip
> router(config)#exit
>
>
>
>
> DHCP
> To make the router work as a DHCP server :
> router>enable
> router#config t
> router(config)#service dhcp or
> router(config)#ip bootp
> router(config)#ip dhcp pool TEST
> router(dhcp-config)# network X.X.X.X Y.Y.Y.Y ( ip address and subnet
> mask that the LAN will use ) router(dhcp-config)#dns-server {ip of dns
> 1} {ip of dns 2} router(dhcp-config)#default-router Z.Z.Z.Z ( internal
> ip address of the
> router)
> router(dhcp-config)#ctrl-z <----to exit
> -----------------------------------------------------------
>
> ip dhcp excluded-address 172.16.1.100 172.16.1.103
>
> ip dhcp excluded-address 172.16.2.100 172.16.2.103
> --------------------------------------------------
> To use a remote dhcp server
> router>enable
> router#config t
> router(config)#ip helper-address x.x.x.x <---- ip address of the
> remote dhcp server router(config)#exit
>
> ---------------------------------------------
> Router(config)# ip address dhcp
>
> ACCESS-LIST
>
> To enable basic security on the router
> router>enable
> router#config t
> router(config)#access-list 120 permit tcp any any established
> router(config)#access-list 120 permit udp any eq 53 any
> router(config)#access-list 120 permit icmp any any echo-reply
> router(config)#int [name of the interface going to the internet ]
> router(config-if)# ip access-group 120 in router(config)#ctrl-z <--to
> exit
>
> This access-list will prevent outside connections and pings although
> it allows you to ping the outside, have DNS resolution and get a reply
> when the trafic started in your LAN, all other incoming traffic will
> be dropped so if you are using an internal device that the Internet
> will reach you need to specify it . There is a list of common ports in
> this link :
>
> >
> To remove an access-list you first need to disable it :
> router>enable
> router#config t
> router(config)#int [name of the interface going to the internet ]
> router(config-if)#no ip access-group 120 in Then you can modify it on
> a note pad, erase it and paste the new access-list back in config t
> mode:
>
> PASSWORDS
> To have a telnet password
> router>enable
> router#config t
> router(config)#line vty 0 4
> router(config-line)# login
> router(config-line)# password cisco
>
> TO SAVE THE CONFIGURATION :
> router#wr mem
THANKS!