I need a little help here. I have an 806 cisco router. I am connected to a cable modem, but I can't get to the internet from my computer when I'm going through my router. I can get to the internet when the modem is connected to my computer though. I can ping my gateway from my router to the modem, I can ping from my pc to my ethernet port that getting the dhcp address dished out to it, but cant ping the gateway to the modem from my computer. here is my config if anyone has any answers that would be great.
sh run
00:57:27: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
Current configuration : 1049 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname jeremy
!
logging rate-limit console 10 except errors
enable secret 5 $1$IdsQ$gXjsEFksiZbpqOr4SpTdN1
!
ip subnet-zero
no ip domain-lookup
ip domain-name roc.mn.charter.com
ip dhcp excluded-address 10.10.10.1 10.10.10.5
!
ip dhcp pool 10-net
import all
network 10.10.10.0 255.255.255.0
--More-- dns-server 206.147.20.2
netbios-name-server 206.147.20.2
default-router 10.10.10.1
!
ip dhcp pool 10=net
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
pppoe enable
hold-queue 32 in
!
interface Ethernet1
ip address dhcp
ip nat outside
pppoe enable
!
router rip
--More-- network 10.0.0.0
network 66.0.0.0
!
ip classless
ip http server
!
!
ip access-list standard permit
permit any
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end
sh run
00:57:27: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
Current configuration : 1049 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname jeremy
!
logging rate-limit console 10 except errors
enable secret 5 $1$IdsQ$gXjsEFksiZbpqOr4SpTdN1
!
ip subnet-zero
no ip domain-lookup
ip domain-name roc.mn.charter.com
ip dhcp excluded-address 10.10.10.1 10.10.10.5
!
ip dhcp pool 10-net
import all
network 10.10.10.0 255.255.255.0
--More-- dns-server 206.147.20.2
netbios-name-server 206.147.20.2
default-router 10.10.10.1
!
ip dhcp pool 10=net
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
pppoe enable
hold-queue 32 in
!
interface Ethernet1
ip address dhcp
ip nat outside
pppoe enable
!
router rip
--More-- network 10.0.0.0
network 66.0.0.0
!
ip classless
ip http server
!
!
ip access-list standard permit
permit any
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end