injector22
Technical User
I'm working on a project for school we are using 5 routers in a star layout with a main hub, i managed to config FR into all the routers and they all ping each others interfaces just fine, my problem is that i can't ping through the ethernet intefaces, i can ping the interface itself but not the devices connected to it.
a picture is worth a thousand words:
here are my configs
hostname Hub
!
frame-relay switching
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
ip address 20.0.1.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.1.2 102 broadcast
frame-relay interface-dlci 102
frame-relay intf-type dce
!
interface Serial1/2
ip address 20.0.2.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.2.2 103 broadcast
frame-relay interface-dlci 103
frame-relay intf-type dce
!
interface Serial1/3
ip address 20.0.3.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.3.2 104 broadcast
frame-relay interface-dlci 104
frame-relay intf-type dce
!
interface Serial1/4
ip address 20.0.4.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.4.2 105 broadcast
frame-relay interface-dlci 105
frame-relay intf-type dce
!
interface Serial1/5
no ip address
shutdown
!
interface Serial1/6
no ip address
shutdown
!
interface Serial1/7
no ip address
shutdown
!
router eigrp 100
network 0.0.0.0
auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
control-plane
!
scheduler allocate 20000 1000
!
end
***********************************************************************
hostname Daytona
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.3.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.3.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 401
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
dial-peer voice 1 pots
destination-pattern 1111
port 0/0/1
!
dial-peer voice 2 voip
destination-pattern 2222
session target ipv4:20.0.4.1
!
scheduler allocate 20000 1000
end
***********************************************************************
hostname Miami
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.4.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 501
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
dial-peer voice 1 pots
destination-pattern 2222
port 0/0/1
!
dial-peer voice 2 voip
destination-pattern 1111
session target ipv4:20.0.3.1
!
scheduler allocate 20000 1000
end
***********************************************************************
hostname Tampa
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.2.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.2.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 301
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
scheduler allocate 20000 1000
end
***********************************************************************
hostname Orlando
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.1.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.1.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 201
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
scheduler allocate 20000 1000
end
***********************************************************************
a picture is worth a thousand words:
here are my configs
hostname Hub
!
frame-relay switching
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
ip address 20.0.1.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.1.2 102 broadcast
frame-relay interface-dlci 102
frame-relay intf-type dce
!
interface Serial1/2
ip address 20.0.2.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.2.2 103 broadcast
frame-relay interface-dlci 103
frame-relay intf-type dce
!
interface Serial1/3
ip address 20.0.3.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.3.2 104 broadcast
frame-relay interface-dlci 104
frame-relay intf-type dce
!
interface Serial1/4
ip address 20.0.4.2 255.255.255.0
encapsulation frame-relay
clock rate 72000
frame-relay map ip 20.0.4.2 105 broadcast
frame-relay interface-dlci 105
frame-relay intf-type dce
!
interface Serial1/5
no ip address
shutdown
!
interface Serial1/6
no ip address
shutdown
!
interface Serial1/7
no ip address
shutdown
!
router eigrp 100
network 0.0.0.0
auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
control-plane
!
scheduler allocate 20000 1000
!
end
***********************************************************************
hostname Daytona
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.3.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.3.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 401
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
dial-peer voice 1 pots
destination-pattern 1111
port 0/0/1
!
dial-peer voice 2 voip
destination-pattern 2222
session target ipv4:20.0.4.1
!
scheduler allocate 20000 1000
end
***********************************************************************
hostname Miami
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.4.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 501
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
dial-peer voice 1 pots
destination-pattern 2222
port 0/0/1
!
dial-peer voice 2 voip
destination-pattern 1111
session target ipv4:20.0.3.1
!
scheduler allocate 20000 1000
end
***********************************************************************
hostname Tampa
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.2.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.2.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 301
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
scheduler allocate 20000 1000
end
***********************************************************************
hostname Orlando
!
frame-relay switching
!
interface FastEthernet0/0
ip address 10.0.1.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 20.0.1.1 255.255.255.0
no shutdown
encapsulation frame-relay
frame-relay interface-dlci 201
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 100
network 0.0.0.0
auto-summary
!
scheduler allocate 20000 1000
end
***********************************************************************