Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Have a problem setting up a C2522 as a frame relay switch 4

Status
Not open for further replies.

two3

Technical User
Jan 28, 2005
3
0
0
GB
C2522 has 2 MB mem & 8MB flash, IOS 11.2 (12.x won't do as it requires 16MB of flash)
I've previously set up Frame switching on a 1750 with 2 x WIC 1T, routing the DLCI attached on s0 to s1 & routing DLCI on s1 to s0,no problem works a treat. However when I try to set more than one DLCI routing command I get an error, this is a sample of the problem (configuring s0)
"2522_Frameswitch(config-if)#frame-relay route 100 int s1 200
2522_Frameswitch(config-if)#frame-relay route 100 int s2 300
Can't use same dlci on overlapping circuits"
DLCI 100 is (or will be) attached on s0, 200 on s1, 300 on s2.
I'd like to to set up R1 (attached to s0) as point to multipoint & the remaining routers (attached to s1-s4) as point to point with s0, but it seems as if I've fallen at the first hurdle.
I've had a look on the Cisco forum & there are one or two posts about this, even have a config for aggregating 2 routers & creating a GRE tunnel via their AUX ports, but that doesn't fit my needs.
So your mission should you choose to accept it, is to help me to resolve my issue (or at least explain why it can't be done). Thanks in anticipation
 
int s0 (I assume)
2522_Frameswitch(config-if)#frame-relay route 100 int s1 200
2522_Frameswitch(config-if)#frame-relay route 100 int s2 300
Can't use same dlci on overlapping circuits"

If I understand correctly, you have a DLCI problem. You can't have one layer 2 DLCI entry going to two different destinations from interface S0. Traffic recieved as DLCI 100 can go to interface s1 DLCI 200 OR S2 DLCI 300. Frame Relay switching is a layer 2 technology and has no knowledge of IP. If you require traffic to different destinations, you will need different source DLCI's to do so.
 
Dan is correct in your situation, two3. Simply configuring the switch is one thing, and configuring the routers to go point-to-point/multipoint has nothing to do with the switch. Here's my config on my 2503...
version 11.3
service telnet-zeroidle
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname Frame_Switch

enable password xxxxxxx

frame-relay switching

interface Ethernet0
ip address 172.16.0.2 255.255.0.0

interface Serial0
no ip address
encapsulation frame-relay
no ip mroute-cache
clockrate 1300000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial1 102

interface Serial1
no ip address
encapsulation frame-relay
clockrate 1300000
frame-relay intf-type dce
frame-relay route 102 interface Serial0 101

interface BRI0
no ip address
shutdown

ip classless

line con 0
password xxxx
logging synchronous
login
line aux 0
line vty 0 4
password xxxxxx
login

end

Hope this helps. I just found out that you can open a regular Cisco config with Wordpad...ha ha...

Burt
 
Hi Guys,

burtsbees can i ask you a question?, i was looking your config and i see that your frame relay switching has only 2 serial interfaces, i'll attach a pic and please can you tell me if that is your config in the 3 routers?, i'm asking because i have a 2520 with 4 routers connected to it and i having problems setup the switching.

Sorry guys for ask in this post but i think this can help two3 too.

 
Hi two3;

just do this in the frame relay switch:

Code:
2522_Frameswitch(config-if)#frame-relay route 100 int s1 200
2522_Frameswitch(config-if)#frame-relay route 101 int s2 300

and in the hub router do this:
Code:
interface Serial---> put your serial interface here
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 100
 frame-relay interface-dlci 101

doing that you be able to do it, check my config:

Code:
FR_Switch#sh run
Building configuration...

Current configuration : 1663 bytes
!
version 12.2
no service pad
service tcp-keepalives-in
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname FR_Switch
!
logging buffered 52100 debugging
logging console warnings
enable secret 5 XXXXXXXXXXXXXXXX
!
clock timezone EST -5
clock summer-time EST recurring 1 Sun Mar 2:00 2 Sun Nov 2:00
ip subnet-zero
no ip source-route
no ip domain-lookup
!
no ip bootp server
frame-relay switching
!
!
!
interface Ethernet0
 no ip address
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 101 interface Serial1 104
 frame-relay route 102 interface Serial2 105
 frame-relay route 103 interface Serial3 106
!
interface Serial1
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 104 interface Serial0 101
!
interface Serial2
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 105 interface Serial0 102
!
interface Serial3
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 106 interface Serial0 103
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
ip classless
ip http server
!
no cdp run
!
!
line con 0
 exec-timeout 0 0
 password 7 XXXXXXXXXXXXXXXX
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 5 0
 password 7 XXXXXXXXXXXXXXXX
 logging synchronous
 login
!
end

FR_Switch#

Code:
FR_Switch#sh frame route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0         101             Serial1         104             active
Serial0         102             Serial2         105             active
Serial0         103             Serial3         106             active
Serial1         104             Serial0         101             active
Serial2         105             Serial0         102             active
Serial3         106             Serial0         103             active
FR_Switch#

Hope this help.
 
Thank you to all for your help & guidance, it is most gratifying to "meet" so many helpful people. The strange thing is that almost as soon as I'd posted the question the answer came to me why I couldn't do what I envisaged. As TechDan said,"frame is a layer 2 protocol & has no knowledge of addressing". I'll set up multiple subints on R1 with a dlci for each & single int & dlci on the others.

Thanks again all.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top