I have been banging my head on this issue for days now. I have a Cisco Call Manager Express system at one of my locations. I have an H.323 connection to it, and I can get calls in and out with no problem. The problem I'm having is when incoming H.323 calls to that CME try to roll to voicemail, I get a reorder tone.
It's weird, because I have another CME out there where everything works fine. I have compared the configs on the two, and I cannot see what I have done incorrectly. Both are connecting through a Cisco Call Manager 4.1, and I have tried the H.323 directly from CME to CME with the same result. Dial Patterns are set up identically.
I only have the issue with H.323 calls going to this site. Users at the site have no issue reaching CUE or reaching voicemail at any other site.
I've looked at debugs, but they aren't telling me anything. The only thing I noticed is on a "Show H323 Gateway," I saw incrementing errors under "H245 Failed." This indicates (to me) an error in call signaling, but I have no idea where the breakdown is occuring.
Below is an excerpt from my running config. Any thoughts?
show run
Building configuration...
Current configuration : 21370 bytes
!
!
!
version 12.4
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
!
ip cef
!
!
voice-card 0
codec complexity medium
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
supplementary-service h450.12
h323
!
!
!
!
!
!
class-map match-all L3-to-L2_VoIP-Cntrl
match ip dscp af31
class-map match-all BrinksApps
match access-group name BrinksApps
class-map match-all L3-to-L2_VoIP-RTP
match ip dscp ef
class-map match-all VoIP
match ip rtp 16384 16383
class-map match-all Monitor
match access-group name Monitor
!
!
policy-map output-L3-to-L2
class L3-to-L2_VoIP-RTP
set cos 5
class L3-to-L2_VoIP-Cntrl
set cos 3
policy-map BrinksQOS
class VoIP
priority percent 5
class BrinksApps
bandwidth percent 65
class Monitor
bandwidth percent 5
class class-default
fair-queue
!
!
!
!
!
interface FastEthernet0/0
description Connection to KnoxvilleSW1
ip address 10.41.36.1 255.255.252.0
ip helper-address 10.32.4.15
ip helper-address 10.32.4.14
no ip mroute-cache
duplex auto
speed auto
no keepalive
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.41.36.1
!
interface Service-Engine0/0
ip unnumbered FastEthernet0/0
service-module ip address 10.41.37.1 255.255.252.0
service-module ip default-gateway 10.41.36.1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
load-interval 30
service-module t1 timeslots 1-24
frame-relay lmi-type cisco
service-policy output BrinksQOS
!
interface Serial0/0/0.1 point-to-point
ip address 10.41.0.34 255.255.255.252
frame-relay interface-dlci 200 IETF
!
interface Serial0/0/0.2 point-to-point
ip address 10.41.2.34 255.255.255.252
delay 2500
frame-relay interface-dlci 201 IETF
!
router eigrp 200
network 10.0.0.0
auto-summary
!
ip route 10.41.37.1 255.255.255.255 Service-Engine0/0
!
!
!
!
mgcp
!
!
!
!
dial-peer voice 170 voip
description ** cue voicemail pilot number **
destination-pattern 6000
session protocol sipv2
session target ipv4:10.41.37.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 171 voip
description ** cue auto attendant number **
destination-pattern 6001
session protocol sipv2
session target ipv4:10.41.37.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 8002 voip
destination-pattern 8........
delay transport-address
session target ipv4:10.32.4.201
codec g711ulaw
!
dial-peer voice 8001 voip
destination-pattern 81804...
delay transport-address
session target ipv4:10.32.4.201
!
dial-peer voice 2999 pots
destination-pattern 2999
no digit-strip
port 0/1/0
!
dial-peer voice 172 voip
description ** cue voicemail pilot number **
destination-pattern 6999
session protocol sipv2
session target ipv4:10.41.37.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!
sip-ua
!
!
!
telephony-service
load 7910 P00403020214
load 7935 P00503010100
load 7960-7940 P00303020214
load 7914 S00103020002
load ATA ATA030100SCCP040211A
load 7905 CP7905040000SCCP040701A
load 7902 CP7902040000SCCP040701A
load 7920 cmterm_7920.3.3-01-08
load 7941 SCCP41.8-0-4SR2S
load 7961 SCCP41.8-0-4SR2S
load 7971 TERM70.6-0-3SR1S
load 7970 TERM70.6-0-3SR1S
load 7911 phone/7906-7911/SCCP11.7-2-1
load 7912 CP7912040000SCCP040701A
max-ephones 36
max-dn 108
ip source-address 10.41.36.1 port 2000
system message Brink's Inc.
cnf-file location flash:
time-zone 12
voicemail 6000
max-conferences 8 gain -6
moh SampleAudio.wav
multicast moh 239.23.4.10 port 2000
web admin system name cisco password cisco
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp 7960 Oct 11 2008 10:26:29
!
!
!
end
show h323 gateway
H.323 STATISTICS AT 7w0d
H.225 REQUESTS SENT RECEIVED FAILED
Setup 25 82 0
Setup confirm 7 2 0
Alert 78 13 0
Progress 2 0 0
Call proceeding 80 13 0
Notify 8 19 0
Info 0 0 0
User Info 0 0 0
Facility 0 0 0
Release 85 42 0
Reject 0 0 0
Passthrough 0 0 0
H225 establish timeout 0
RAS failed 0
H245 failed 48
RAS MESSAGE REQUESTS SENT CONFIRMS RCVD REJECTS RCVD
GK Discovery grq 257362 gcf 0 grj 0
Registration rrq 0 rcf 0 rrj 0
Admission arq 0 acf 0 arj 0
Bandwidth brq 0 bcf 0 brj 0
Disengage drq 0 dcf 0 drj 0
Unregister urq 0 ucf 0 urj 0
Resource Avail rai 0 rac 0
Req In Progress rip 0
RAS MESSAGE REQUESTS RCVD CONFIRMS SENT REJECTS SENT
GK Discovery grq 0 gcf 0 grj 0
Registration rrq 0 rcf 0 rrj 0
Admission arq 0 acf 0 arj 0
Bandwidth brq 0 bcf 0 brj 0
Disengage drq 0 dcf 0 drj 0
Unregister urq 0 ucf 0 urj 0
Resource Avail rai 0 rac 0
Req In Progress rip 0
DISC CAUSE CODE FROM OTHER PEER FROM H323 PEER
1 unassigned number (1) 2 12
16 normal call clearing ( 9 24
127 interworking (127) 6 54
H323 gateway internal event queue:
Events queued 0, free 3, held 3, allocated 3 times, exceed max 0 times
Max serviced 3, Max serviced exceed 0
no dest 0, no buffers 0, call flushes 0
CRV statistics
In use: 0
Max collisions obtaining crv: 0
**CUE**
Generating configuration:
ccn application autoattendant
description "autoattendant"
enabled
maxsessions 6
script "aasimple.aef"
parameter "allowExternalTransfers" "false"
parameter "BusinessOpenPrompt" "AABusinessOpen.wav"
parameter "MaxRetry" "3"
parameter "BusinessClosedPrompt" "AABusinessClosed.wav"
parameter "PlayExtensionsPrompt" "UserPrompt_01212009120056.wav"
parameter "HolidayPrompt" "AAHolidayPrompt.wav"
parameter "WelcomePrompt" "AAWelcome02.wav"
parameter "BusinessSchedule" "systemschedule"
parameter "ExtensionLength" "4"
end application
ccn application ciscomwiapplication
description "ciscomwiapplication"
enabled
maxsessions 6
script "setmwi.aef"
parameter "strMWI_OFF_DN" "5000"
parameter "strMWI_ON_DN" "5001"
parameter "CallControlGroupID" "0"
end application
ccn application promptmgmt
description "promptmgmt"
enabled
maxsessions 1
script "promptmgmt.aef"
end application
ccn application voicemail
description "voicemail"
enabled
maxsessions 6
script "voicebrowser.aef"
parameter "logoutUri" " parameter "uri" " end application
ccn engine
end engine
ccn subsystem jtapi
ccm-manager address 0.0.0.0
end subsystem
ccn subsystem sip
gateway address "10.41.36.1"
end subsystem
ccn trigger sip phonenumber 6000
application "voicemail"
enabled
maxsessions 6
end trigger
ccn trigger sip phonenumber 6001
application "autoattendant"
enabled
maxsessions 6
end trigger
ccn trigger sip phonenumber 6999
application "promptmgmt"
enabled
maxsessions 1
end trigger
It's weird, because I have another CME out there where everything works fine. I have compared the configs on the two, and I cannot see what I have done incorrectly. Both are connecting through a Cisco Call Manager 4.1, and I have tried the H.323 directly from CME to CME with the same result. Dial Patterns are set up identically.
I only have the issue with H.323 calls going to this site. Users at the site have no issue reaching CUE or reaching voicemail at any other site.
I've looked at debugs, but they aren't telling me anything. The only thing I noticed is on a "Show H323 Gateway," I saw incrementing errors under "H245 Failed." This indicates (to me) an error in call signaling, but I have no idea where the breakdown is occuring.
Below is an excerpt from my running config. Any thoughts?
show run
Building configuration...
Current configuration : 21370 bytes
!
!
!
version 12.4
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
!
ip cef
!
!
voice-card 0
codec complexity medium
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
supplementary-service h450.12
h323
!
!
!
!
!
!
class-map match-all L3-to-L2_VoIP-Cntrl
match ip dscp af31
class-map match-all BrinksApps
match access-group name BrinksApps
class-map match-all L3-to-L2_VoIP-RTP
match ip dscp ef
class-map match-all VoIP
match ip rtp 16384 16383
class-map match-all Monitor
match access-group name Monitor
!
!
policy-map output-L3-to-L2
class L3-to-L2_VoIP-RTP
set cos 5
class L3-to-L2_VoIP-Cntrl
set cos 3
policy-map BrinksQOS
class VoIP
priority percent 5
class BrinksApps
bandwidth percent 65
class Monitor
bandwidth percent 5
class class-default
fair-queue
!
!
!
!
!
interface FastEthernet0/0
description Connection to KnoxvilleSW1
ip address 10.41.36.1 255.255.252.0
ip helper-address 10.32.4.15
ip helper-address 10.32.4.14
no ip mroute-cache
duplex auto
speed auto
no keepalive
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.41.36.1
!
interface Service-Engine0/0
ip unnumbered FastEthernet0/0
service-module ip address 10.41.37.1 255.255.252.0
service-module ip default-gateway 10.41.36.1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
load-interval 30
service-module t1 timeslots 1-24
frame-relay lmi-type cisco
service-policy output BrinksQOS
!
interface Serial0/0/0.1 point-to-point
ip address 10.41.0.34 255.255.255.252
frame-relay interface-dlci 200 IETF
!
interface Serial0/0/0.2 point-to-point
ip address 10.41.2.34 255.255.255.252
delay 2500
frame-relay interface-dlci 201 IETF
!
router eigrp 200
network 10.0.0.0
auto-summary
!
ip route 10.41.37.1 255.255.255.255 Service-Engine0/0
!
!
!
!
mgcp
!
!
!
!
dial-peer voice 170 voip
description ** cue voicemail pilot number **
destination-pattern 6000
session protocol sipv2
session target ipv4:10.41.37.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 171 voip
description ** cue auto attendant number **
destination-pattern 6001
session protocol sipv2
session target ipv4:10.41.37.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 8002 voip
destination-pattern 8........
delay transport-address
session target ipv4:10.32.4.201
codec g711ulaw
!
dial-peer voice 8001 voip
destination-pattern 81804...
delay transport-address
session target ipv4:10.32.4.201
!
dial-peer voice 2999 pots
destination-pattern 2999
no digit-strip
port 0/1/0
!
dial-peer voice 172 voip
description ** cue voicemail pilot number **
destination-pattern 6999
session protocol sipv2
session target ipv4:10.41.37.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!
sip-ua
!
!
!
telephony-service
load 7910 P00403020214
load 7935 P00503010100
load 7960-7940 P00303020214
load 7914 S00103020002
load ATA ATA030100SCCP040211A
load 7905 CP7905040000SCCP040701A
load 7902 CP7902040000SCCP040701A
load 7920 cmterm_7920.3.3-01-08
load 7941 SCCP41.8-0-4SR2S
load 7961 SCCP41.8-0-4SR2S
load 7971 TERM70.6-0-3SR1S
load 7970 TERM70.6-0-3SR1S
load 7911 phone/7906-7911/SCCP11.7-2-1
load 7912 CP7912040000SCCP040701A
max-ephones 36
max-dn 108
ip source-address 10.41.36.1 port 2000
system message Brink's Inc.
cnf-file location flash:
time-zone 12
voicemail 6000
max-conferences 8 gain -6
moh SampleAudio.wav
multicast moh 239.23.4.10 port 2000
web admin system name cisco password cisco
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp 7960 Oct 11 2008 10:26:29
!
!
!
end
show h323 gateway
H.323 STATISTICS AT 7w0d
H.225 REQUESTS SENT RECEIVED FAILED
Setup 25 82 0
Setup confirm 7 2 0
Alert 78 13 0
Progress 2 0 0
Call proceeding 80 13 0
Notify 8 19 0
Info 0 0 0
User Info 0 0 0
Facility 0 0 0
Release 85 42 0
Reject 0 0 0
Passthrough 0 0 0
H225 establish timeout 0
RAS failed 0
H245 failed 48
RAS MESSAGE REQUESTS SENT CONFIRMS RCVD REJECTS RCVD
GK Discovery grq 257362 gcf 0 grj 0
Registration rrq 0 rcf 0 rrj 0
Admission arq 0 acf 0 arj 0
Bandwidth brq 0 bcf 0 brj 0
Disengage drq 0 dcf 0 drj 0
Unregister urq 0 ucf 0 urj 0
Resource Avail rai 0 rac 0
Req In Progress rip 0
RAS MESSAGE REQUESTS RCVD CONFIRMS SENT REJECTS SENT
GK Discovery grq 0 gcf 0 grj 0
Registration rrq 0 rcf 0 rrj 0
Admission arq 0 acf 0 arj 0
Bandwidth brq 0 bcf 0 brj 0
Disengage drq 0 dcf 0 drj 0
Unregister urq 0 ucf 0 urj 0
Resource Avail rai 0 rac 0
Req In Progress rip 0
DISC CAUSE CODE FROM OTHER PEER FROM H323 PEER
1 unassigned number (1) 2 12
16 normal call clearing ( 9 24
127 interworking (127) 6 54
H323 gateway internal event queue:
Events queued 0, free 3, held 3, allocated 3 times, exceed max 0 times
Max serviced 3, Max serviced exceed 0
no dest 0, no buffers 0, call flushes 0
CRV statistics
In use: 0
Max collisions obtaining crv: 0
**CUE**
Generating configuration:
ccn application autoattendant
description "autoattendant"
enabled
maxsessions 6
script "aasimple.aef"
parameter "allowExternalTransfers" "false"
parameter "BusinessOpenPrompt" "AABusinessOpen.wav"
parameter "MaxRetry" "3"
parameter "BusinessClosedPrompt" "AABusinessClosed.wav"
parameter "PlayExtensionsPrompt" "UserPrompt_01212009120056.wav"
parameter "HolidayPrompt" "AAHolidayPrompt.wav"
parameter "WelcomePrompt" "AAWelcome02.wav"
parameter "BusinessSchedule" "systemschedule"
parameter "ExtensionLength" "4"
end application
ccn application ciscomwiapplication
description "ciscomwiapplication"
enabled
maxsessions 6
script "setmwi.aef"
parameter "strMWI_OFF_DN" "5000"
parameter "strMWI_ON_DN" "5001"
parameter "CallControlGroupID" "0"
end application
ccn application promptmgmt
description "promptmgmt"
enabled
maxsessions 1
script "promptmgmt.aef"
end application
ccn application voicemail
description "voicemail"
enabled
maxsessions 6
script "voicebrowser.aef"
parameter "logoutUri" " parameter "uri" " end application
ccn engine
end engine
ccn subsystem jtapi
ccm-manager address 0.0.0.0
end subsystem
ccn subsystem sip
gateway address "10.41.36.1"
end subsystem
ccn trigger sip phonenumber 6000
application "voicemail"
enabled
maxsessions 6
end trigger
ccn trigger sip phonenumber 6001
application "autoattendant"
enabled
maxsessions 6
end trigger
ccn trigger sip phonenumber 6999
application "promptmgmt"
enabled
maxsessions 1
end trigger