Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

GRE Tunnel: Line Protocol Down? 2

Status
Not open for further replies.

hummer3331973

Technical User
Feb 1, 2007
121
US
This is probably too simple for some. I set-up a GRE tunnel between 2 routers but I can't seem to find what's wrong here. The Line Protocol is "Down" and can't get it up. What am I missing here:

Code:
Router A

interface Tunnel0
 ip address 1.1.1.1 255.255.255.240
 keepalive 10 3
 tunnel source 10.200.20.3
 tunnel destination 192.168.10.106
!
interface FastEthernet0/0
 ip address 10.200.20.3 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 10.200.110.0 255.255.255.0 10.200.20.1
ip route 82.195.180.248 255.255.255.248 10.200.20.1
ip route 192.168.10.0 255.255.255.0 Tunnel0

Here's Router B

Code:
interface Tunnel0
 ip address 1.1.1.2 255.255.255.240
 keepalive 10 3
 tunnel source 192.168.10.106
 tunnel destination 10.200.20.3
!
interface FastEthernet0/0
 ip address 192.168.10.106 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 10.200.8.0 255.255.255.0 192.168.10.1
ip route 10.200.20.0 255.255.255.0 Tunnel0
ip route 10.200.110.0 255.255.255.0 192.168.10.1
 
On the debug, I was able to bring it up but the Line Protocol goes down again:

Code:
*Nov 15 02:28:55.245: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, c
hanged state to up
*Nov 15 02:29:04.245: Tunnel0: 1-level recursive routing detected
*Nov 15 02:29:04.245: %TUN-5-RECURDOWN: Tunnel0 temporarily disabled due to recu
rsive routing
*Nov 15 02:29:05.245: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, c
hanged state to down
 
Its because when you bring up the tunnel the static routes that you have for the tunnel interfaces kick in.. Which is fine, but the tunnel destinations are in the same subnet as the static route you have.

When the tunnels aren't up those static routes don't get installed into the routing-table, therefore it follows the default route.

Basically when the tunnels come up the commands tell the router to get to the remote end of the GRE tunnel to use the tunnel interface.. This no workie :)

To fix, change the destination of the GRE tunnel to something other then the 192.168.x.x


A network topology diagram would help..

BuckWeet
 
Buck, sorry for the late reply. My set-up is simple, 2 routers are connected back-to-back over a WAN using only static routing.

Here's how it looks like:
Code:
Router A (FE 0/0) <---IP WAN--> Router B (FE 0/0)
FE0/0 IP 10.200.20.3                FE0/0 IP 192.168.10.106
All the other interfaces are disabled, except VIC cards connected to the PBX.

Thanks for the help.
 
The key word that sticks out here is the old "recursive routing detected" issue. I figured this was the problem before I even began to read the post. Your post's output just emphasizedthat fact. Buckwheet pretty much stated it as such in his post.

If you care to learn more about the subject read here or search CCO:


This article has to do with flapping neighbors using rdynamic routing protocols. Static routes though would indeed act the same way though.
 
Thanks for the help guys. I created a Loopback interface for the Tunnel's Source and Destination IP add and it fix the recursive problem.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top